[UIFe] BFB icon swirl should run clockwise not anti-clockwise

Bug #1169238 reported by Matthieu James
34
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Matthieu James
unity (Ubuntu)
Undecided
Unassigned

Bug Description

It seems that most of positive symbols across different cultures in the world run clockwise. The swirl displayed in our launcher home (BFB) icon runs anti-clockwise. We should change its direction of rotation.

If the screenshots included in the documentation are not up to date, the overall understanding of the system will not be compromised.

This 'issue' has been reported by an Ubuntu user, and forwarded to me by Mark. Here is the original email:
-----------------------------------------------------------------------------

Mr Mark and Canonical people,

I have being using Ubuntu since 2009 version for personal and business purposes and I have to tell you that I am so pleased to have some alternative system that effectively works, its so nice to have this opportunity :)

I would like to give you a small contribution: I am sorry to be a pain, but I understand a little bit about symbolism and how this can affect minds.

The new Ubuntu logo (13.04) is running in an Anti-clockwise way and not in a clockwise way.

If you allow me to add a little comment, life must go forward, not backwards, as I am sure you want to do with your operative system, but subconsciously you are telling people exactly the opposite.

If you pay correct attention to the ubuntu logo, it rotates in the "wrong" way, please trust my words, as this has a strong influence in people's decision.

In the Latin world, "sinistro" is used for anti-clockwise, and "sinistro" also means, wrong, direction, accident, among many other things, please check here: http://pt.wikipedia.org/wiki/Sinistro_%28seguro%29

In india, if someone asks why the swastika cross is turning to the right side, they will answer: because that's how life should turn/run.

There is a lot of misunderstandings about how the correct Swasthika should be, after Hitler.

Ubuntu, looks very much like a Celtic pattern, you may also confirm that you have here they turning to the same side as I described.

https://www.google.co.uk/search?q=celtic+symbols&hl=en&client=ubuntu&hs=uCE&channel=fs&gl=uk&tbm=isch&tbo=u&source=univ&sa=X&ei=afY1UfqaAcWkPfC4gfgK&ved=0CDAQsAQ&biw=1231&bih=682

Please feel free to contact me for further information.

Kind regards
Gustavo

Related branches

Didier Roche (didrocks)
summary: - BFB icon swirl should run clockwise not anti-clockwise
+ [UIFe] BFB icon swirl should run clockwise not anti-clockwise
Revision history for this message
Matthieu James (tiheum) wrote :
Matthieu James (tiheum)
description: updated
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

−1. I don't see any reason why this can't wait until next release. The release team may disagree, though.

Revision history for this message
Scott Kitterman (kitterman) wrote :

This should be addressed by the Unity upstream project first, so unsubscribing the release team for now.

Revision history for this message
Stephen M. Webb (bregma) wrote :

+1 from the Unity upstream, after a brief discussion with designers about the aesthetics and cultural symbolism of the swirl direction

Changed in unity:
status: New → Triaged
Revision history for this message
z (steveriley-deactivatedaccount-deactivatedaccount) wrote :

Who gets to set the rules that clockwise is "correct" and counter-clockwise is "incorrect"? The notion that left = bad and right = good is steeped in ancient (and wrong) beliefs about what nature prefers. Consider the centuries of abuse that left-handed folks had to endure, for instance.

That clocks move "clockwise" is a completely arbitrary decision and has nothing to with life moving forward or backward. Nature itself seems to show a predilection for counter-clockwise behavior. When viewed from north of the galactic plane, Earth rotates counter-clockwise on its axis and it revolves counter-clockwise about the sun. People move counter-clockwise in skating rinks, on race tracks, on baseball diamonds. Amusement park rides go counter-clockwise.

It's the 21st century now. Do people really make technology decisions based on iron age fairy tales?

Revision history for this message
Stephen Michael Kellat (skellat) wrote :

I'm going to object for docs at this point since we're 10 days out from release.

This really, really should not be dropping in at this late of an hour. If this is a cultural issue, it is far more appropriate that a *unified* response take place across all the flavors instead of just tweaking Unity. I was not aware of this being a dramatic cultural concern prior to now which means that I'm going to ask that this be delayed until the S cycle and that a blueprint be logged so that all flavors can discuss this matter. If this truly is that dramatic of a cultural concern there needs to be a session where this is discussed at UDS-1305 so everybody has a better background as to what is going on.

This is not a show stopper for 13.04.

Revision history for this message
Kevin Godby (godbyk) wrote :

-1 on the UIFe from ubuntu-docs and ubuntu-manual from my view. We don't have time to retake all the screenshots at this late date.

Revision history for this message
Adolfo Jayme (fitojb) wrote :

The change in the icon is so minimal, that I don't think any docs' screenshots would be "affected" by this.

Revision history for this message
Kevin Godby (godbyk) wrote :

I think this change is more likely to be noticed (and be a problem for) new users who are reading the documentation and trying to find the home button.

If the change is so minimal and won't be noticed by anyone, then I'd think it could wait until the next cycle.

Revision history for this message
Stephen Michael Kellat (skellat) wrote :

We're ten days out from release. This release is only going to be supported for 9 months. If this is such a major cultural concern, now is the time to prep a blueprint for UDS-1305 so all flavors can be apprised of this apparently hereto unconsidered issue. It is appropriate to get all flavors on board if this is that drastic. Otherwise, if this is a minor thing, it is not a show stopper and can wait. Certainly we could have quite a change across the flavors spectrum by October if this is that major of an issue.

Revision history for this message
Mark Shuttleworth (sabdfl) wrote : Re: [Bug 1169238] Re: [UIFe] BFB icon swirl should run clockwise not anti-clockwise

Guys, it's a trivial change, not material for screenshots (this icon
looks essentially the same and is in the same place). We are 10 days
from release, we are not at RC ;)

+1

Revision history for this message
Scott Kitterman (kitterman) wrote :

OK, based on Mark's comment resubscribed the release team and set the 13.04 milestone.

Changed in unity (Ubuntu):
milestone: none → ubuntu-13.04
Revision history for this message
Carsten Gerlach (carsteng) wrote :

+1 to Steve Riley and Kevin Godby

Revision history for this message
Kevin Godby (godbyk) wrote :

Here are my final thoughts on this:

Your argument for the UIFe is that people will notice the anticlockwise background. Your argument as to why we don't need to retake the screenshots is that no one will notice the anticlockwise background. This is an obvious contradiction. Will people notice or won't they?

Should we expect a UIFe for the anticlockwise arrows on the Software Updater, as well? (This isn't a slippery slope fallacy, I'm honestly asking. Should we be expecting more UIFes for other icons? If so, when will we have a list?)

As to the timing issue, the ubuntu-docs package (with its screenshots) needs to be uploaded within hours, not days.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Roland (Rolandixor) Taylor (rolandixor) wrote :

Why isn't this marked as critical? This is of utmost importance. If we change the direction of the swirl we will bring world peace and end world hunger and all wars!

Revision history for this message
David Klasinc (bigwhale) wrote :

I am left handed and I feel offended by this bug.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Awesome James Bond reference in the default Ubuntu install =)

http://youtu.be/gkNeQdLg6Nc

+1 for geeky pop-culture reference.

Revision history for this message
Alan Bell (alanbell) wrote :

maybe it should go clockwise in the northern hemisphere and anticlockwise in the southern hemisphere based on IP geolocation and in harmony with the coriolis effect?

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Software updater icon needs direction change as well to match.

Andrea Azzarone (azzar1)
Changed in unity:
status: Triaged → In Progress
milestone: none → 7.0.1
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
assignee: nobody → Matthieu (thieume)
assignee: Matthieu (thieume) → Matthieu James (tiheum)
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone backlog

Changed in unity:
status: In Progress → Fix Committed
Revision history for this message
Gareth Witty (vapedog1666) wrote :

I think its should be changed to a picture of Alan Pope.

Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.0.0daily13.04.18~13.04-0ubuntu1

---------------
unity (7.0.0daily13.04.18~13.04-0ubuntu1) raring; urgency=low

  [ Manuel de la Pena ]
  * Purchased songs won't download when not logged to U1 (LP: #1168674)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3309

unity (7.0.0daily13.04.17~13.04-0ubuntu1) raring; urgency=low

  [ Marco Trevisan (Treviño) ]
  * Top Bar, window managment - top bar shadow not falling on restored
    windows that are partially off the top edge of the screen (LP:
    #871758)

  [ Matthieu James ]
  * [UIFe] BFB icon swirl should run clockwise not anti-clockwise (LP:
    #1169238)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3305
 -- Ubuntu daily release <email address hidden> Thu, 18 Apr 2013 05:43:34 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Stephen M. Webb (bregma) wrote :

Fix released in Unity 7.1.0.

Changed in unity:
milestone: 7.0.1 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers