test-gtest [ FAILED ] TestIconLoader.TestGetManyIcons - segfaults at times.

Bug #1162886 reported by Brandon Schaefer on 2013-04-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Brandon Schaefer
unity (Ubuntu)
Medium
Brandon Schaefer

Bug Description

Stack trace: http://paste.ubuntu.com/5668678/
Full stack trace: http://paste.ubuntu.com/5668696/

Run: ./test-gtest --gtest_filter=*GetManyIcons*

It also passes at times as well.

*Update*
I also just got this while restarting unity...so this seems a bit more serious then a failing unit test:
http://paste.ubuntu.com/5667999/

I got it after doing a compiz --replace ccp, then opening the dash...though I can't reproduce it :(.

Changed in unity:
status: New → Triaged
importance: Undecided → High
milestone: none → 7.0.0
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
description: updated

I hit the seg fault again running trunk unity, making this critical. Still only happens randomly when restarting unity :(, but fixing that unit tests should also fix this crash, so an easy way to reproduce this would be running that failing unit test!

Changed in unity:
importance: High → Critical
Changed in unity (Ubuntu):
importance: High → Critical
description: updated
description: updated

Turns out this is an ABI break in lp:fontconfig, and after fixing that theres an ABI break in lp:pango, compiling both those from source has fixed the crash (after running it more then 1000 times).

Actually looks like we are using non-thread safe code, and lp:fontconfig is thread safe. So we'll have to remove the use of threads surrounding the LoadJobFunc call.

Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress

Right now this seems to only be happening in the tests. Very rarely, if ever in trunk unity. Keeping eye on it.

Changed in unity:
importance: Critical → High
status: In Progress → Triaged
Changed in unity (Ubuntu):
status: In Progress → Triaged
importance: Critical → High
Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Stephen M. Webb (bregma) on 2013-04-25
Changed in unity:
milestone: 7.0.1 → 7.1.0

*Should* be fixed now that be moved to saucy. I haven't seen the test fail in sometime now.

Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.1.0.

Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers