Filters are disappearing and impacting already displayed results

Bug #1159814 reported by Didier Roche on 2013-03-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

See the attached video:
- search for gcalc
- open the filters
- click on "shotwell" source
-> the first result from app scope is duplicated
- click on another filter
-> they are all disappearing (and refreshed after some time)

Related branches

Didier Roche (didrocks) wrote :
tags: added: 100scopes
Changed in unity:
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

confirmed, a bit difficult to confirm since the filter section keeps being emptied, stay empty for some seconds and repopulate again (seems to be depending on server result to return)

Changed in unity:
status: New → Confirmed
Paweł Stołowski (stolowski) wrote :

Filters are dynamically updated at least two times as search is in progress, e.g. as soon as we get recommendations for smart scopes server, we light respective filters up, however when we actually query the recommended scopes and get no results, we update filters again by turning some of them off.. This was "by design", but all this is currently investigated by design team.

Changed in unity:
importance: High → Undecided
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:~unity-team/unity/libunity-7.0-breakage at revision None, scheduled for release in unity, milestone Unknown

Changed in unity:
status: Confirmed → Fix Committed
Stephen M. Webb (bregma) wrote :

Released in Unity 7.1.0

Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers