Fails to build after revision 3183

Bug #1159584 reported by Andrew Gunnerson
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Invalid
Undecided
Unassigned
Unity for Arch Project
Undecided
Andrew Gunnerson

Bug Description

For some reason, every revision after 3183 fails to build on other distros. I have all of Unity's dependencies dependencies installed (package versions matching Ubuntu 13.04's). It fails when app-manager is linked against libunity-core-6.0.so.5.0.0

I'm not very familiar with CMake and I've been at this for days, but I can't come up with a patch to fix the issue.

The build log is attached to this bug report. The compile command is "cmake .. -DCMAKE_VERBOSE_MAKEFILE=TRUE && make -j1". The exact same command works perfectly in Ubuntu 13.04. I attached the build log on Ubuntu as well because it may be helpful to diff them to find the issue :)

Revision history for this message
Andrew Gunnerson (cxl) wrote :
Revision history for this message
Andrew Gunnerson (cxl) wrote :
Revision history for this message
Andrew Gunnerson (cxl) wrote :

Unity compiles successfully with GCC 4.8.0 (or Ubuntu's 4.7.2 with some patches from 4.8.0). Maybe Unity should check for this.

Changed in unity-for-arch:
assignee: nobody → Xiao-Long Chen (cxl)
status: New → Fix Released
Changed in unity:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers