[regression] Quickly opening then closing dash causes loss of focus.

Bug #1157879 reported by Brandon Schaefer on 2013-03-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Brandon Schaefer
Unity
Invalid
High
Brandon Schaefer
nux (Ubuntu)
High
Brandon Schaefer
unity (Ubuntu)
High
Brandon Schaefer

Bug Description

To reproduce:

1) Assert any window has focus by the title on the panel.
2) Quickly press Super twice to open then close the dash.

Expected:
  The window that was focused before going into the dash has focus once again.

Result:
  The window that was focused is no longer focused and the panel is empty.

Related branches

Changed in unity:
status: New → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
summary: - [regression] Quickly opening then closing dash causes lose of focus.
+ [regression] Quickly opening then closing dash causes loss of focus.
Changed in unity:
milestone: none → 7.0.0

Turns out to be a racing problem when we re-focus the dash when its first focused. The X event buffer needs to be flushed other wise the XSetInputFocus will come through a bit late causing the dash to be re-focused after its closed.

Changed in unity (Ubuntu):
status: In Progress → Invalid
Changed in nux:
status: New → In Progress
Changed in unity (Ubuntu):
status: Invalid → In Progress
Changed in nux:
importance: Undecided → High
Changed in nux (Ubuntu):
importance: Undecided → High
status: New → In Progress
Changed in unity:
status: In Progress → Invalid
Changed in unity (Ubuntu):
status: In Progress → Invalid
Changed in nux:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in nux (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in nux:
milestone: none → 4.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:nux at revision None, scheduled for release in nux, milestone 4.0

Changed in nux:
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 4.0.0daily13.03.25-0ubuntu1

---------------
nux (4.0.0daily13.03.25-0ubuntu1) raring; urgency=low

  [ Brandon Schaefer ]
  * [regression] Quickly opening then closing dash causes loss of focus.
    (LP: #1157879)
  * [regression] Text disappears when restoring/maximizing the Dash (LP:
    #1157329)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 768
 -- Ubuntu daily release <email address hidden> Mon, 25 Mar 2013 04:02:25 +0000

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) on 2013-04-03
Changed in unity:
milestone: 7.0.0 → none
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Nux 4.0.0.

Changed in nux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers