F10 or Alt+<accelerator> opens the window menus within the window

Bug #1113008 reported by William Hua
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
William Hua
Unity GTK+ module
Fix Released
Critical
William Hua
unity (Ubuntu)
Undecided
Unassigned
unity-gtk-module (Ubuntu)
Critical
Unassigned

Bug Description

Attempting to activate the menu bar using F10 or Alt+F causes the menu to pop open within the menu instead of from the panel.

Related branches

Revision history for this message
Allan LeSage (allanlesage) wrote :

Will, I think I erred in claiming that I have sexy screenshots for this, will follow up shortly. . . .

Revision history for this message
Christopher Townsend (townsend) wrote :

This is causing the unity.tests.test_panel.PanelKeyNavigationTests.test_panel_menu_accelerators_work AP test to fail for Unity 7.

Another way to reproduce:
1. Open gedit.
2. Press Alt+F to open the file menu.

Observe the menu window is local to the application window and not from the Panel.

Changed in unity-gtk-module:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Stephen M. Webb (bregma) wrote :

It's not just F10, it's all menu hotkeys, and all menus, in all GTK applications.

This serious bug is blocking Unity landing in distro.

Changed in unity-gtk-module:
status: Confirmed → Triaged
summary: - F10 opens the window menus within the window
+ F10 or Alt+<accelerator> opens the window menus within the window
description: updated
Changed in unity-gtk-module:
importance: High → Critical
Ted Gould (ted)
Changed in unity-gtk-module:
assignee: nobody → William Hua (attente)
Revision history for this message
Jesse Nazario (jessenzr) wrote :

How long until this bug gets fixed? Unity is currently unsable for me because of this.

Revision history for this message
David (david.regev) wrote :

I noticed this too in Ubuntu 13.10. It appears even when maximized. It doesn’t seem to occur in non-GTK+ applications, such as Firefox. See the screenshots, including the one of the expected behaviour.

Revision history for this message
David (david.regev) wrote :
Revision history for this message
David (david.regev) wrote :
Stephen M. Webb (bregma)
Changed in unity-gtk-module (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
William Hua (attente)
tags: added: ubuntu-desktop-trusty
Changed in unity:
assignee: nobody → William Hua (attente)
status: New → In Progress
importance: Undecided → High
milestone: none → 7.2.0
Revision history for this message
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone 7.2.0

Changed in unity:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (18.5 KiB)

This bug was fixed in the package unity - 7.1.2+14.04.20140214.1-0ubuntu1

---------------
unity (7.1.2+14.04.20140214.1-0ubuntu1) trusty; urgency=low

  [ Sebastien Bacher ]
  * use unity-control-center by default.
  * lists keybinding in unity-control-center. (LP: #1271710)

  [ Brandon Schaefer ]
  * Bump to new libnux from this branch:
    https://code.launchpad.net/~brandontschaefer/nux/xim-preedit-
    support.
  * Adds Super+L to lock the screen, while keeping the older shortcut
    around in g-s-d (Ctrl+Alt+L). (LP: #830709)
  * Do not open the dash/hud on a monitor with a top most window that is
    fullscreen. (LP: #1267210)
  * Implement an EMConveter. This way with default settings such that
    DPI = 96.0f, and font_size = system font size. We can get the
    correct EM value for any pixel size. Once we have the correct EM
    value for any pixel size, the DPI value can be adjusted to the
    current logical one. From here, you can now get the correct pixel
    size based from of the EM value for the logical DPI of the screen.
  * Refactor EMConverter API. Now all thats needed is int
    ConvertPixels(int pixel); This will calculate the correct pixel size
    based on the DPI and font size.
  * Testing that the ibus anthy tests could possibly be causing strange
    issues on the nvidia machine. So skipping them to test if tihs is
    the source of the error.
  * Add Pt to Px function to em converter.
  * Move EMConverter over to unity settings.
  * Add multi monitor support for EMConverter in unity settings. Now you
    can grab a specific converter per monitor.
  * Simple RawPixel class. It adds 2 define literals, ex: 10_em,
    10.0_em. From there it turns them into raw pixels. RawPixels have CP
    (CovertPixel) function which takes in an EMConverter that allows you
    to use a converter specific to a monitor to convert the raw pixel to
    the correct value.

  [ Marco Trevisan (Treviño) ]
  * Don't re-present all of our windows on every frame. Only do that if
    damage intersects it. Use the new APIs exposed by compiz and nux to
    intelligently determine which windows need to be presented per-frame
    and only register damage for those windows. This fixes two things:
    1. BaseWindows being redrawn from scratch every time damage was
    registered over them. That was incorrect and should only be done in
    the case of background blurs. 2. BaseWindows being drawn to the
    screen on every frame, regardless of whether or not they needed to
    be. Now they will only be drawn if some damage intersects beneath
    them. Note that unity will expand the damage region to accomadate
    the base window since nux does not support geometry clipping. So if
    there is a partial intersection of the launcher for example, the
    area of the screen which contains the launcher will be re-painted
    (but the launcher itself won't be redrawn, just its texture) (LP:
    #1080947). (LP: #1080947)
  * Convert compiz regions / rects to nux::Geometry's and back easily.
  * UnityScreen: remove the useless and expensive gl{Push,Pop}Attrib
    calls For some reasons this code was copied by the opengl plugin as
    a workaround to fix the s...

Changed in unity (Ubuntu):
status: New → Fix Released
William Hua (attente)
Changed in unity-gtk-module:
status: Triaged → Fix Released
Changed in unity-gtk-module (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.2.0.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers