Exiting expo mode leaves the BFB quicklist open

Bug #1090565 reported by Francis Ginther on 2012-12-14
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Low
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

Clicking on the expo (workspace) button to enter, then leave expo mode results in the BFB quicklist menu opening.

Using ppa:unity-team/staging.

[Testcase]
 - Click the expo button or use the workspace key to show all workspaces.
 - Click the expo button or use the workspace key again to leave expo mode.
Expected result:
 - Desktop should look as it did before the test.
Actual result:
 - The quicklist menu for the BFB icon is opened and left open.

This causes autopilot tests failures:
unity.tests.launcher.test_icon_beheavior.LauncherIconsTests.test_expo_launcher_icon_initiates_expo (Single Monitor)

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: unity 6.12.0daily12.12.05bzr2985pkg0raring102 [origin: LP-PPA-unity-team-staging]
ProcVersionSignature: Ubuntu 3.7.0-4.12-generic 3.7.0-rc7
Uname: Linux 3.7.0-4-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.7-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CrashDB: unity
Date: Fri Dec 14 14:42:27 2012
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-08-29 (107 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120627)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to raring on 2012-12-06 (8 days ago)

Related branches

Francis Ginther (fginther) wrote :
Łukasz Zemczak (sil2100) wrote :

Ok, so, *normally* this bug is not present on my system, but there is a certain way I can trigger it on my staging machine. Since normally clicking on the workspaces and switching back works normally. But, if you first do this:
1. Start the expo (workspace switcher)
2. Now, leave expo by right-clicking on the BFB button

After these steps are done once, all subsequent entering and leaving expo results in the quicklist opened. So, probably unity remembered that it should open the quicklist and didn't clear the state when we're not leaving expo through the quicklists. This failure might happen in autopilot since we're actually testing if we're leaving expo when accessing the quicklist. So after this test is executed, all subsequent exits from expo open the quicklist.

So I confirm!

Changed in unity:
assignee: nobody → Łukasz Zemczak (sil2100)
status: New → In Progress
Changed in unity:
importance: Undecided → Low
Robert Roth (evfool) on 2013-01-14
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: Łukasz Zemczak (sil2100) → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 7.0.0
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2013-02-06
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily13.02.07-0ubuntu1

---------------
unity (6.12.0daily13.02.07-0ubuntu1) raring; urgency=low

  [ Andrea Azzarone ]
  * make check fails on test-unit (LP: #1117487)
  * Notification area whitelist is obsolete (LP: #974480)

  [ Marco Trevisan (Treviño) ]
  * Switcher - when opening in detail mode (Alt+`) it should not use the
    spread animation (LP: #1116927)
  * Alt-tab sometimes focuses a window that is not in top of the app
    stack (LP: #1115775)
  * Switcher: Opening and closing the detail mode quickly makes unity
    re-enable it (LP: #1116785)
  * Exiting expo mode leaves the BFB quicklist open (LP: #1090565)

  [ MC Return ]
  * unmaximize_window_key instead of unmaximize_or_minimize_window_key
    exposed in g-c-c (LP: #1115128)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3136
 -- Automatic PS uploader <email address hidden> Thu, 07 Feb 2013 06:20:12 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints