TestDashController.TestShowAndHideDash fails

Bug #1089904 reported by Andrea Azzarone on 2012-12-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Andrea Azzarone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

./tests/test-gtest --gtest_filter="TestDashController.TestShowAndHideDash"
Note: Google Test filter = TestDashController.TestShowAndHideDash
[==========] Running 1 test from 1 test case.
[----------] Global test environment set-up.
[----------] 1 test from TestDashController
[ RUN ] TestDashController.TestShowAndHideDash
/home/andy/unity/source/unity/tests/test_dash_controller.cpp:72: Failure
Actual function call count doesn't match EXPECT_CALL(*base_window_, SetOpacity(Eq(1.0f)))...
         Expected: to be called once
           Actual: never called - unsatisfied and active
/home/andy/unity/source/unity/tests/test_dash_controller.cpp:80: Failure
Value of: 1.0
  Actual: 1
Expected: base_window_->GetOpacity()
Which is: 0
/home/andy/unity/source/unity/tests/test_dash_controller.cpp:85: Failure
Actual function call count doesn't match EXPECT_CALL(*base_window_, SetOpacity(_))...
         Expected: to be called at least once
           Actual: never called - unsatisfied and active
/home/andy/unity/source/unity/tests/test_dash_controller.cpp:86: Failure
Actual function call count doesn't match EXPECT_CALL(*base_window_, SetOpacity(Eq(0.0f)))...
         Expected: to be called once
           Actual: never called - unsatisfied and active
[ FAILED ] TestDashController.TestShowAndHideDash (2181 ms)
[----------] 1 test from TestDashController (2181 ms total)

[----------] Global test environment tear-down
[==========] 1 test from 1 test case ran. (2181 ms total)
[ PASSED ] 0 tests.
[ FAILED ] 1 test, listed below:
[ FAILED ] TestDashController.TestShowAndHideDash

Related branches

Andrea Azzarone (azzar1) on 2012-12-13
Changed in unity:
importance: Undecided → High
status: New → In Progress
milestone: none → 7.0.0
assignee: nobody → Andrea Azzarone (andyrock)
summary: - TestDashController.TestShowAndHideDash and
- TestHudController.TestShowAndHideDash fail
+ TestDashController.TestShowAndHideDash
summary: - TestDashController.TestShowAndHideDash
+ TestDashController.TestShowAndHideDash fail
summary: - TestDashController.TestShowAndHideDash fail
+ TestDashController.TestShowAndHideDash fails
Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package unity - 6.12.0daily13.01.11.2-0ubuntu1

---------------
unity (6.12.0daily13.01.11.2-0ubuntu1) raring; urgency=low

  [ Didier Roche ]
  * debian/control:
    - bump some missed build-deps
    - bump compiz and nux build-deps for the API and ABI breakages
      (LP: #1095981)
  * debian/rules:
    - disable pch for now as it's not working with -g -02 (LP: #1095978)

  [ Brandon Schaefer ]
  * Ported Compiz to 0.9.9
  * debian/control:
    - bump the build-deps
  * Dash and HUD do not have X event focus, causing XIM to not work.
    (LP: #1086988)
  * Windows losing focus after the start/restart of Unity (LP: #1097368)

  [ Łukasz 'sil2100' Zemczak ]
  * Dash - Update Dash nav bar icons (LP: #1089373)
  * Autopilot tests failing in the test_hud suite due to locale
    dependency (LP: #1076531)
  * Super key not registered if held too long (LP: #1097189)
  * Unity HUD uses wrong icon when switching from the Dash to HUD (LP:
    #1089482)

  [ Marco Trevisan (Treviño) ]
  * Using bleeding edge Mesa drivers causes GL_INVALID_OPERATION error
    in glDrawBuffer / glReadBuffer (LP: #1092550)
  * [Regression] Window buttons / Title doesn't redraw correctly on
    windows with no menus (LP: #1090439)

  [ Nick Dedekind ]
  * Dash - When the Dash preview is open, the ghost images should run
    all the way to the top of the screen as shown in the design (LP:
    #1060948)
  * Dash - When the Dash preview opens, the category headers should be
    expanded and the filters should hide (LP: #1060937)
  * Dash - In the Dash preview, when a user moves to the next or
    previous preview the highlighted ghost image should change (LP:
    #1060941)
  * Dash - As soon as a user starts dragging a .png file from the Dash,
    the file icon changes size (LP: #863412)

  [ Gord Allott <email address hidden>, Łukasz 'sil2100' Zemczak <email address hidden>, Didier Roche ]
  * "unitydashlegalseen" Causing back-up error (LP: #1066646)
  * unity dash should show legal disclaimer (LP: #1065652)

  [ Manuel de la Pena ]
  * StaticCairoText makes NUX get into an infinte loop (LP: #1071327)

  [ Daniel van Vugt ]
  * Minimized windows don't restore, or restore as blank (LP: #1089779)

  [ Andrea Azzarone ]
  * TestOverlayScrollBar.TestScrollDownSignal segfaults (LP: #1089888)
  * Dash - Update Dash Launcher icon tooltip to say "Search your
    computer and online sources" (LP: #1090325)
  * TestLauncherController.GetLastIconPriorityUnStickyWithNoIconsAndUri
    segfaults (LP: #1089894)
  * TestDashController.TestShowAndHideDash fails (LP: #1089904)
  * [Regression] Tapping super key shows shortcuts overlay. (LP:
    #1090388)
  * [Regression] Unity fails to restore initially minimized windows.
    (LP: #1097686)
  * launcher does not show minimized update manager while clicked (LP:
    #1003950)
  * Dash - Update Dash Home search box hint message to say "Search your
    computer and online sources" (LP: #1090327)
  * can't quit a minimized application (LP: #1086366)
  * Unity daily-build (07.01.13) empty space between launcher and dash
    in non default launcher size (LP: #1097184)

  [ Sam Spilsbury ]
  * Fonts get chang...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers