unity dash should show legal disclaimer

Reported by Alan Pope ㋛ on 2012-10-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Gord Allott
6.0
Undecided
Unassigned
unity (Ubuntu)
Undecided
Didier Roche
Quantal
Undecided
Didier Roche

Bug Description

[Impact]
There are potential legal issues relating to sending personal data over the internet which are exposed by the new shopping lens. We should include an obvious legal disclaimer in the user interface so users are aware of what's going on.
This is a rather necessary addition to the system.

[Test Case]
Not applicable.

[Regression Potential]
Layouting issues. Backup problems.

Related branches

lp:~gordallott/unity/dash-legal-link
Merged into lp:unity at revision 2965
PS Jenkins bot: Needs Fixing (continuous-integration) on 2012-11-14
Timo Jyrinki: Approve on 2012-11-08
lp:~sil2100/unity/dash-legal-link-trunk
Merged into lp:unity at revision 2965
PS Jenkins bot: Needs Fixing (continuous-integration) on 2012-12-10
Francis Ginther: Approve on 2012-12-10
Alan Pope ㋛ (popey) on 2012-10-11
Changed in unity-lens-shopping:
importance: Undecided → Critical
affects: unity-lens-shopping → unity
Changed in unity:
importance: Critical → Undecided
summary: - Shopping lens should show legal disclaimer
+ unity dash should show legal disclaimer
Paul Larson (pwlars) wrote :

I'm taking a look at the unity 6.8.0-0ubuntu2~ppa1 package in the ppa, and see a couple of issues:
In unity-common, file: /usr/share/unity/6/searchingthedashlegalnotice.html (This is the file that comes up when you click the legal notice link).
1. The first link to the privacy policy on the page links through google to get to the privacy policy, while the second, which takes you to the same url, links directly to www.ubuntu.com/aboutus/privacypolicy
2. Last link on the page links to: "www.ubuntu.com/privacypolicy/thirdparties.html." <--- notice the . in the url at the end
3. This link is 404 both with, and without the trailing .

Changed in unity:
assignee: nobody → Gord Allott (gordallott)
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
C de-Avillez (hggdh2) wrote :

First paragraph, at the end: "(...) (and privacy policy).". The 'privacy policy should also be a direct link to Canonical's privacy policy.

Apart from that, I match what Paul described above.

Jean-Baptiste Lallement (jibel) wrote :

The Legal mention link/icon is unreachable with the keyboard only

Didier Roche (didrocks) wrote :

Fixed the above links in #1. Didn't touch that much the rest of the page.

Checked and changed the official page link on the ubuntu site. A place holder webpage will be soon created by the webteam (url confirmed and finale).

As discussed, we can fix the "keyboard part" as a SRU. It's too sensitive and regression-risky to add it right now.

Changed in unity (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

The behavior is:
- first time you start unity, you see a "Legal notice" message in the home dash
- when clicking on it, an html file opens with the legal content
- the home dash string is then replaced by an icon
- clicking on the icon opens the same legal html document
- further unity restart should still show the icon

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.8.0-0ubuntu2

---------------
unity (6.8.0-0ubuntu2) quantal; urgency=low

  * Cherry-pick a fix for having legal information in the dash. This links
    to a legal html document. The string itself in the dash is picked from
    ubuntu-online-account gnome-control-center integration and so, already
    translated and part of langpacks for 12.10. (LP: #1065652)
 -- Didier Roche <email address hidden> Fri, 12 Oct 2012 11:47:31 +0200

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Adolfo Jayme (fitoschido) wrote :

Why is the text replaced by an icon? Is the text too noisy? I find that behavior a bit weird.

Changed in unity:
status: Confirmed → In Progress
Adolfo Jayme (fitoschido) wrote :

After some days of use, I find the text noisy :) but mostly because I have removed the Shopping Lens, so the link to the disclaimer is unnecessary, right?

description: updated
Changed in unity:
status: In Progress → Fix Committed
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers