Multi-monitor - Add 'sticky edges deactivated for number of milliseconds after the user breaks the barrier' variable that works when the Launcher set to 'auto-hide' and sticky edges set to 'off'

Reported by John Lea on 2012-10-10
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

To reproduce:

1. Using a computer with two monitors, set the Launcher to 'auto-hide' and sticky edges to 'off'

2. Set the 'sticky edges deactivated for number of milliseconds after the user breaks the barrier' variable in CCSM to "1000ms"

3. Move the pointer over the boundary from the left screen to the right screen slowly, and then try to move it back again (within 1 second).

What currently happens: the pointer gets caught on the Launcher reveal edge resistance on the left edge of the right monitor

What should happen: There should be no resistance when the pointer comes back across the barrier because the barrier was already broken inside 1000ms when the pointer moved from the left monitor to the right monitor.

Also: set the value of the variable to 1000ms

--------------------------------

Add 'sticky edges deactivated for number of milliseconds after the user breaks the barrier' variable to CCSM. This variable would de-activate sticky edges for a set number of milliseconds every time after the user's pointer moves from one monitor to another.

In addition to the 1000ms barrier switch off timer, the barrier should also only be switched off for only one crossing e.g. so that if the user tries to correct an accidental crossing of the barrier they can do so with no resistance, but after correcting this accidental crossing the barrier is switched on even if 1000ms has not yet elapsed.

The idea behind this behaviour is to allow the user to course-correct after they have broken through the barrier the first time.

Tags: udp Edit Tag help

Related branches

lp:~unity-team/unity/edge-barrier-autohide-fix
Merged into lp:unity at revision 3140
Brandon Schaefer: Approve on 2013-02-08
PS Jenkins bot: Needs Fixing (continuous-integration) on 2013-02-08
John Lea (johnlea) on 2012-10-10
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in ayatana-design:
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
tags: added: udp
summary: Multi-monitor - Add 'sticky edges deactivated for number of milliseconds
after the user breaks the barrier' variable that works when the Launcher
- to 'auto-hide' and sticky edges to 'off'
+ set to 'auto-hide' and sticky edges set to 'off'
John Lea (johnlea) on 2012-10-10
Changed in unity:
importance: High → Critical
Changed in unity (Ubuntu):
importance: High → Critical
Changed in ayatana-design:
importance: High → Critical
Stephen M. Webb (bregma) on 2012-12-05
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Unity Maintainers (unity-maintainers-team)
Changed in unity (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → Unity Maintainers (unity-maintainers-team)
Changed in unity:
assignee: Unity Maintainers (unity-maintainers-team) → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: Unity Maintainers (unity-maintainers-team) → Brandon Schaefer (brandontschaefer)
Changed in unity:
importance: Critical → High
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
milestone: none → 7.0.0
Stephen M. Webb (bregma) on 2013-02-04
Changed in unity (Ubuntu):
importance: Critical → High

Hmm this already exists...and its already set to 1000ms. In CCSM its under Unityshell -> Launcher -> Duration of Sticky Edge Release After Break.

So when I slowly move my mouse to break the barrier, I can keep going back and forth between the barrier with out a problem. (Though you are stating this is broken currently?)

I only see one change needed for this bug is the fact that once the edge is broken you can keep going back until the time limit has been reached. You would like it to have the barrier come back after one crossing.

John Lea (johnlea) wrote :

@brandontschaefer; this bug is specifically about the case when:

- The Launcher is set to 'auto-hide'
- Sticky edges are set to 'off'

To reproduce first make sure the above two preconditions are true. Then:

- Move the pointer over the boundary from the left screen to the right screen slowly, and then try to move it back again (within 1 second).

What currently happens is that the pointer gets caught on the Launcher reveal edge resistance on the left edge of the right monitor

What should happen is that there should be no resistance when the pointer comes back across the barrier because the barrier was already broken inside 1000ms when the pointer moved from the left monitor to the right monitor.

Can you reproduce this issue?

Hmm heres a video of my attempts to reproduce this:
http://ubuntuone.com/4dEuyBAT1pi6JLfXgCHW85

Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: Brandon Schaefer (brandontschaefer) → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily13.02.08-0ubuntu1

---------------
unity (6.12.0daily13.02.08-0ubuntu1) raring; urgency=low

  [ Brandon Schaefer ]
  * Multi-monitor - Add 'sticky edges deactivated for number of
    milliseconds after the user breaks the barrier' variable that works
    when the Launcher set to 'auto-hide' and sticky edges set to 'off'
    (LP: #1064945)

  [ Łukasz 'sil2100' Zemczak ]
  * testapp is a bad name (LP: #1089561)

  [ Marco Trevisan (Treviño) <mail@3v1n0.net>, Brandon Schaefer ]
  * Multi-monitor - Add 'sticky edges deactivated for number of
    milliseconds after the user breaks the barrier' variable that works
    when the Launcher set to 'auto-hide' and sticky edges set to 'off'
    (LP: #1064945)

  [ Marco Trevisan (Treviño) ]
  * Alt-Tab switcher should use a very fast fade-in/out effect when
    showing/hiding (LP: #1105058)
  * Multi-monitor - Add 'sticky edges deactivated for number of
    milliseconds after the user breaks the barrier' variable that works
    when the Launcher set to 'auto-hide' and sticky edges set to 'off'
    (LP: #1064945)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 3140
 -- Automatic PS uploader <email address hidden> Fri, 08 Feb 2013 04:02:00 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints