[regression] Dash - When a drag and drop action from the Dash is abandoned by dropping the item back into the Dash, all the Launcher icons 'flicker' as they suddenly loose their tinting for a brief moment

Reported by John Lea on 2012-10-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

When a drag and drop action from the Dash is abandoned by dropping the item back into the Dash, all the Launcher icons suddenly become illuminated

To reproduce:

1. To reproduce this bug you must be using duel monitors, set up to extend the desktop (e.g. NOT mirror)
2. Open the Dash on one of the monitors, and start to drag an item
3. Drop the item back into the Dash to abandon the action.

Current incorrect behaviour in 12.10: either:
a) All the Launcher icons suddenly loose their tinting for a brief moment (e.g. all the Launcher icons flicker)
b) After the drop action has been perfomred, all the Launcher icons loose their tinting

A screencast of this bug is attached, see Launcher_flicker.ogv

Note this screencase was made on the 10th Oct 2012, with a fully up to date vanilla install of Quantal

Correct desired behaviour as currently implemented in 12.04: When the drag and drop action is abandoned, the valid drop receptacles return to the tinted state. The Launcher icons which were not valid drop receptacles do not change of flicker in any way, they remain in the tinted state.

Related branches

lp:~3v1n0/unity/multi-monitor-icon-quirks
Merged into lp:unity at revision 3578
PS Jenkins bot: Approve (continuous-integration) on 2013-10-22
Brandon Schaefer: Approve on 2013-10-22
John Lea (johnlea) on 2012-10-09
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
summary: [regression] Dash - When a drag and drop action from the Dash is
abandoned by dropping the item back into the Dash, all the Launcher
- icons suddenly loose all their tinting for a brief moment
+ icons suddenly loose their tinting for a brief moment
summary: [regression] Dash - When a drag and drop action from the Dash is
abandoned by dropping the item back into the Dash, all the Launcher
- icons suddenly loose their tinting for a brief moment
+ icons 'flicker' as they suddenly loose their tinting for a brief moment
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in ayatana-design:
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
tags: added: dashm dashs udp
Changed in ayatana-design:
status: Triaged → Fix Committed
Andrea Azzarone (andyrock) wrote :

Can you make a video of the bug. I cannot reproduce here.

Changed in unity:
status: Triaged → Incomplete
Changed in unity (Ubuntu):
status: Triaged → Incomplete
John Lea (johnlea) wrote :
description: updated
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
John Lea (johnlea) wrote :

@andyrock; I've attached a screencast. When making the screencast I discovered that this bug only occurs on multi-monitor systems, I have updated the bug description accordingly.

Changed in unity:
assignee: nobody → Nick Dedekind (nick-dedekind)
Nick Dedekind (nick-dedekind) wrote :

So, this happens because the different launchers all share the same launcher model (ie the icon backend), which is where the saturation state exists; but the "overlay enabled" & hover states exists on a per launcher basis.

1) When the use cancels a drag, we reset the saturation status to the intended value.
2) However, we do this in both launchers, one of which "overlay enabled" is false, causing the icons to saturate.
3) Which monitor you have the dash open on will give different results. First will leave the icons saturated, second will flicker them as they briefly turn saturated, then desaturated.

Question: Do we not wan the overlay on all monitors if the dash/hud is open?

Either we need to have the hover/overlay state shared between the model, or we need to have icon states (quirks) per launcher, or there needs to be some hacky-jiggery-pokery for checking which monitor we're operating on.

Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
milestone: none → 7.2.0
assignee: Nick Dedekind (nick-dedekind) → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.2.0.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers