[regression] Dash - Left separator is missing

Bug #1057798 reported by Omer Akram on 2012-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Medium
Andrea Azzarone
6.0
Fix Released
Medium
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone

Bug Description

The left separator line of the dash is gone. started after bzr2742 I guess.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.6.0+bzr2742stagingubuntu0+786 [origin: LP-PPA-unity-team-staging]
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CrashDB: unity
Date: Fri Sep 28 02:16:10 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120831)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Omer Akram (om26er) wrote :
summary: - [regression] Dash - Left white line is missing
+ [regression] Dash - Left separator is missing
Omer Akram (om26er) wrote :

Note: bzr2742 fixed bug 1043260 which I believe is more important than this one.

Daniel van Vugt (vanvugt) wrote :

The "separator" shadow was a bug. That was bug 1043260.

And I believe Unity design has intentionally removed the 1px line that was there in precise.

Changed in unity:
status: New → Invalid
Omer Akram (om26er) wrote :
Changed in unity:
status: Invalid → New
Nick Dedekind (nick-dedekind) wrote :

You are talking between the launcher and dash; not between the categories?

Nick Dedekind (nick-dedekind) wrote :

Sorry, "left separator" kind of gives that away. :)

Andrea Azzarone (azzar1) on 2012-09-28
Changed in ayatana-design:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (azzar1) on 2012-09-28
Changed in ayatana-design:
assignee: Andrea Azzarone (andyrock) → nobody
Omer Akram (om26er) wrote :

>> You are talking between the launcher and dash; not between the categories?

Yes.

Changed in unity:
status: New → Confirmed
Andrea Azzarone (azzar1) on 2012-09-28
Changed in unity:
milestone: none → 7.0.0
John Lea (johnlea) on 2012-10-01
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
Changed in unity:
status: Confirmed → Triaged
tags: added: udp
Andrea Azzarone (azzar1) on 2012-10-01
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
status: New → In Progress
Omer Akram (om26er) on 2012-10-01
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2012-10-02
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package unity - 6.8.0-0ubuntu1

---------------
unity (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Ángel Guzmán Maeso ]
  * debian/unity-crashdb.conf:
    - Update dictionary option for follow latest apport spec

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - unity 6.8 candidate segfaults on "app expose" with low gfx mode
      (LP: #1060148)
    - [regression] Dash - Left separator is missing (LP: #1057798)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() from
      atk_object_get_n_accessible_children() (LP: #913324)
    - [regression] If unity is started with maximized dash, unmaximizing the
      dash does not wrap rows (LP: #1053116)
    - Dash lens buttons don't work after changing form factor to maximize on
      desktop (LP: #1053316)
    - Clicking on Workspace Switcher icon when the expo is showing, not always
      closes it 1059759 convert files list deprecated keys (LP: #1059594)
    - Unity through llvmpipe is slow (LP: #1046497)
    - compiz crashed with SIGSEGV in unity::QuicklistView::Show() from
      unity::QuicklistManager::ShowQuicklist() (LP: #1055995)
    - compiz crashed with SIGSEGV from
      unity::dash::HomeLens::Impl::LensSearchFinished() (LP: #1054219)
    - [regression] Starting an app & then locking to launcher is not persistent
      across sessions (LP: #1054645)
    - [regression] Dash, Launcher, Menu Bar - Unintended shadows are rendered
      for the Unity Launcher and Panel, when the dash is open (LP: #1043260)
    - [Unity 6.x] Active blur doesn't update if you disable CCSM > OpenGL >
      Framebuffer object (LP: #1039999)
    - Alt+Tab/Alt+grave brings other window to the front but loses focus
      entirely. (LP: #1035628)
    - Spread - Scaling all the windows is too slow (LP: #1055643)
    - Window management - Middle clicking on a window inside the spread should
      close that window (equivalent action to clicking on the close button)
      (LP: #1052821)
    - Scale window decorations don't have properly rounded corners
      (LP: #1055610)
    - Scale window decorations text does not match theme style (Radiance)
      (LP: #1055609)
    - Spread window decorations does not match the theme when changed
      (LP: #1055605)
    - scaled window decorations are sometimes wider than the window
      (LP: #1053225)
    - Launcher should not auto-hide after dragging an icon, if mouse is still
      over it (LP: #1053978)
    - unity spread window on second click not working when ibus language panel
      is shown. (LP: #1035895)
    - windows.push_back(<uninitialized value>) in
      BamfLauncherIcon::GetFocusableWindows (LP: #1053220)
    - Category emblems are blurry (LP: #1056874)
    - Rendering flaws of the dash previews (LP: #1055455)
    - [UIFe] Social Lens doesn't have authorised and meaningful icon
      (LP: #1056191)
    - [dash] Preview fade out animation hangs occasionally (LP: #1058145)
    - Dash - rendering of ribbons shouldn't be relative (LP: #1057971)
    - Horizontal alignment search box and views below (LP: #1055544)
    - Compiz crashed in cairo_save() from
      unity::Unit...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers