Launcher - No format option for USB Storage Devices in Launcher quicklists

Bug #1057008 reported by Philipp on 2012-09-26
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Triaged
Medium
Unassigned
unity (Ubuntu)
Medium
Andrea Azzarone
Xenial
Medium
Andrea Azzarone

Bug Description

There is no more format option for mounted devices in their launcher submenu.
For further information check out the attached image.

-------------------------------
Desired solution:

- Add "Format" option to the quicklist of usb storage devices as shown below (note: also see bug #1063816):

---------------------
Open
Format
---
<b>[title of USB storage device]</b>
---
Unlock from Launcher
Eject
---------------------

- Clicking on this option should bring up the format confirmation dialogue to make sure the user really did intend to click 'format'

Related branches

lp:~azzar1/unity/format-option
PS Jenkins bot: Approve (continuous-integration) on 2016-02-25
Marco Trevisan (Treviño): Approve on 2016-02-25
Philipp (sacridex) wrote :
Omer Akram (om26er) wrote :

thanks for the bug report. the feature existed till it was possible. I am told that the lib that exposed 'format' item in the quicklist is no longer in Ubuntu so. As this feature was never requested by design team its now a feature request.

Changed in unity:
status: New → Opinion
status: Opinion → Triaged
importance: Undecided → Wishlist
Philipp (sacridex) wrote :

Ok, I can live with that.
But somewhere should be a format option available.
See my other bugreport (#1057019)

Daniel van Vugt (vanvugt) wrote :

Instead of "Format", maybe we should just have a "Properties" option which launches the Disk Utility:
    palimpsest --show-drive=/dev/whatever

summary: - No format option for usb drives in launcher
+ No format or detailed properties option for drives in launcher
John Lea (johnlea) on 2012-10-08
description: updated
tags: added: udp
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in ayatana-design:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
summary: - No format or detailed properties option for drives in launcher
+ Launcher - No format option for USB Storage Devices in Launcher
+ quicklists
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
importance: Wishlist → Medium
tags: added: rls-w-incoming
tags: added: rls-x-incoming
removed: rls-w-incoming
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20160310-0ubuntu1

---------------
unity (7.4.0+16.04.20160310-0ubuntu1) xenial; urgency=medium

  [ Andrea Azzarone ]
  * Add a "Format..." option to volume icons. (LP: #1057008)

  [ Marco Trevisan (Treviño) ]
  * DashView: ensure that we update scaling when monitor changes (LP:
    #1546690)
  * DecoratedWindow: move the shadow under the window if we've a client-
    side decorated window with corners (LP: #1516403)
  * LauncherController: add overlay shortcut to all the
    WindowedLauncherIcon's we have
  * ThemeSettings: add small class for reading gtk settings for theming
    (LP: #1543757, #1288998)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 10 Mar 2016 10:09:34 +0000

Changed in unity (Ubuntu Xenial):
status: Triaged → Fix Released
Hangman (hangman-hotmail) wrote :

I don't see it in last 16.04 beta...

~$ unity --version
unity 7.4.0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments