[FFE][UIFE]Dash - Finesse the placement, movement and behaviour of the 12.10 Dash

Reported by John Lea on 2012-09-12
28
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Music Lens
Critical
Unassigned
Photos Lens
Undecided
Unassigned
Unity
Critical
Unassigned
unity (Ubuntu)
Critical
Unassigned
unity-asset-pool (Ubuntu)
Undecided
Unassigned
unity-lens-music (Ubuntu)
Critical
Unassigned
unity-lens-photos (Ubuntu)
Critical
Unassigned

Bug Description

= Proposed Change =

At the London 12.10 dash sprint we are working on finessing the placement, movement and behaviour of elements in the 12.10 Dash. This bug is requesting a FFE and UIFE to land these fixes.

-------------
Changes include:
- remove preview containers
- default button (normally mapped to same action as left-click) should be focused
- left/right arrows go 20% opc and move further apart, go fully opaque on mouseover
- Clicking outside of dash region does not stop a song preview from playing
- Clicking on the main left hand side preview image in a Dash Preview should close the Preview and return the user to the results view
- Users should be able to exit the Preview and return to the results by right clicking anywhere inside the preview
- tab to move focus between buttons
- Fix display of star ‘Rating’ in App Previews
- Buttons are in 34px height, with 1px inside stroke for unselected, 2px inside stroke for selected
- Buttons should also render the extra_text property of PreviewAction
- add correct category header icons for Dash home
- adjust spacing between categories so the implementation matches design
- category headers should only be focusable if they can be expended
- Dash is not dismissed when something in the other display is clicked
- Dash jumps from one monitor to another in a multi-monitor environment
- On a fresh install, the "filter results" section of all Lenses should be collapsed by default
- update highlight focus to a 106px * 106px square with 2px round corner, 20% opc white
- Files deleted by dragging and dropping from the Dash to the Trash are not removed from the Dash
- Height of lenses nav bar is 40px
- Removing ‘rating’ star filter from app lens
- All results other than app and file icons should become 96px * 96px
- app icons and icons of files that cannot be previewed become 64px * 64px
- When an application is installed direct from a Dash Preview, the Software Centre should not be launched and the Software Centre window should not be opened
- All applications which are a dependency of Ubuntu Desktop should not have an uninstall button in their preview

= Effects on Quantal =

This FFe captures a lot of small bugs/fixes and a couple larger ones. Though we don't expect any issues, the reason there are so many branches linked is that, if there are issues found, we can revert out the individual 'fixes' rather than having to revert out everything.

This should hopefully make it more palatable for getting into Ubuntu. Amongst the branches linked, there are only a couple with large code changes, and they have been developed in isolation of the rest, ready to be reverted out should they cause any issues for beta 2.

= Translations =

unity-lens-applications, unity-lens-music and unity-lens-videos have one new string: "More suggestions"

(this might be captured in another report but just to be absolutely sure adding it here per dpm's request)

Related branches

lp:~gordallott/unity/newbg
Merged into lp:unity at revision 2692
Omer Akram: Approve on 2012-09-14
Andrea Azzarone: Approve on 2012-09-14
John Lea: Approve (design) on 2012-09-14
Gord Allott: Pending requested 2012-09-13
lp:~nick-dedekind/unity/lp923657.dash-dismiss
Merged into lp:unity at revision 2684
Brandon Schaefer: Approve on 2012-09-12
Christopher Lee: Needs Fixing on 2012-09-11
Andrea Azzarone: Needs Fixing on 2012-09-11
lp:~nick-dedekind/unity/preview-navigation-button-opacity
Merged into lp:unity at revision 2691
Michal Hruby: Approve on 2012-09-14
John Lea: Approve (design) on 2012-09-14
lp:~nicolas-doffay/unity/preview-click-exit
Merged into lp:unity at revision 2701
Neil J. Patel (community): Approve on 2012-09-19
Nick Dedekind: Pending requested 2012-09-17
lp:~nick-dedekind/unity/dash-results.focus+size
Merged into lp:unity at revision 2687
Andrea Azzarone: Needs Fixing on 2012-09-13
John Lea: Approve (design) on 2012-09-13
Michal Hruby: Approve on 2012-09-13
lp:~unity-team/unity/match-designed-sizings
Merged into lp:unity at revision 2681
Andrea Azzarone: Approve on 2012-09-12
Xi Zhu (community): Approve (design) on 2012-09-12
John Lea: Pending (design) requested 2012-09-11
lp:~stolowski/unity/missing-music-video-icons
Merged into lp:unity/6.0 at revision 2685
Neil J. Patel: Pending requested 2012-09-17
Merged into lp:unity at revision 2686
Michal Hruby: Approve on 2012-09-13
lp:~nick-dedekind/unity/preview-button-navigation
Merged into lp:unity at revision 2708
Michal Hruby: Approve on 2012-09-14
John Lea: Approve (design) on 2012-09-14
lp:~mhr3/unity/icon-loader-width-and-height
Merged into lp:unity at revision 2690
Omer Akram: Approve on 2012-09-14
John Lea: Approve (design) on 2012-09-13
Nick Dedekind: Approve on 2012-09-13
lp:~unity-team/unity/see-you-later-flow
Merged into lp:unity at revision 2685
Andrea Azzarone: Approve on 2012-09-13
John Lea: Approve (design) on 2012-09-13
John Lea (johnlea) on 2012-09-12
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in ayatana-design:
status: Triaged → Fix Committed
tags: added: dashm udp
Changed in unity:
milestone: none → backlog
importance: Undecided → Critical
Changed in unity (Ubuntu):
importance: Undecided → Critical
Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
description: updated
Iain Lane (laney) wrote :

Can we have some more information about what changes you're making?

You'll be asking the doc team to retake their screenshots of the dash for this feature, so please consider again whether they are all crucial to include in 12.10, given where we are in the release cycle, then reply with information so that we can be better informed about what's being requested here.

Is there any chance of regressions? If so, what's the plan to deal with them?

When will you be able to land this, if approved?

Iain Lane (laney) wrote :

I'm setting this to Incomplete, but please reset to New once you've supplied the information asked for. Thanks!

Changed in unity (Ubuntu):
status: Triaged → Incomplete
Changed in unity-lens-music (Ubuntu):
status: New → Incomplete
Changed in unity-lens-photos (Ubuntu):
status: New → Incomplete
David Callé (davidc3) wrote :

For unity-lens-photos: icon path changes.
It's not affecting the interface, as similar icons were provided by the lens package itself, the lens now depends on Unity for them.

Changed in unity-lens-photos (Ubuntu):
status: Incomplete → New
Iain Lane (laney) wrote :

photos> Is it already in the current Unity in Quantal? Don't forget to update the packaging to have the correctly versioned Depends.

Iain Lane (laney) wrote :

17/09 17:28:41 <Laney> davidcalle: you said it depends on some change in Unity
17/09 17:28:51 <Laney> I want to know if that change is already in or if it's in a future Unity version
17/09 17:29:55 <davidcalle> Laney, the changes are in the Unity branches linked to the report, so not yet in Quantal.

So this depends on the rest of this FFe.

John Lea (johnlea) on 2012-09-18
description: updated
Neil J. Patel (njpatel) wrote :

Moving back to triaged as John updated the description with the changes as requested.

Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in unity-lens-music (Ubuntu):
status: Incomplete → Triaged
Neil J. Patel (njpatel) on 2012-09-18
Changed in unity (Ubuntu):
status: Triaged → New
Changed in unity-lens-music (Ubuntu):
status: Triaged → New
John Lea (johnlea) on 2012-09-18
Changed in unity-lens-music (Ubuntu):
importance: Undecided → Critical
Changed in unity-lens-photos (Ubuntu):
importance: Undecided → Critical
Changed in unity-lens-music:
importance: Undecided → Critical
Changed in unity (Ubuntu):
milestone: none → ubuntu-12.10-beta-2
Changed in unity-lens-music (Ubuntu):
milestone: none → ubuntu-12.10-beta-2
Changed in unity-lens-photos (Ubuntu):
milestone: none → ubuntu-12.10-beta-2
Neil J. Patel (njpatel) on 2012-09-18
description: updated
Neil J. Patel (njpatel) wrote :

Doc team and Translation team notifications by John Lea:

https://lists.ubuntu.com/archives/ubuntu-doc/2012-September/016861.html
https://lists.ubuntu.com/archives/ubuntu-translators/2012-September/005590.html

Jeremy's reply is correct, this sprint was at a bad time and we were hit by the gsettings etc bits slowing down the landing of the previews. We'll fix this for 13.04 and have the sprint much earlier, sorry for the extra work at this time to both docs and translations team.

Changed in unity:
milestone: none → 6.6
Changed in unity:
milestone: 6.6 → 7.0
status: Triaged → Fix Committed
John Lea (johnlea) wrote :

Matt Price (the lead copywriter at Canonical) has agreed to update the documentation with the latest Dash changes. A member of the documentation team will need to contact him to show him where the documentation lives andbrief him on the process for contributing to the documentation.

Jeremy Bicha (jbicha) wrote :

-1 from Docs for the reasons I stated at https://lists.ubuntu.com/archives/ubuntu-doc/2012-September/016862.html

I don't think that the Docs Team or the Release Team really have the time to evaluate 24 additional UI freeze exception items the day before DocumentationStringFreeze, Beta2Freeze, and 3 weeks after UI Freeze. A lot of our documentation work cannot start until the UI stops changing, and having the UI stop changing on the day that we have to stop writing docs puts us in an impossible situation.

I did talk with Matt and look forward to working with him in the future when we have more time available.

Kate Stewart (kate.stewart) wrote :

Have been in discussion with jbicha and dpm, plan agreed to is:
- Documentation String Freeze is going to move to 9/28 (Tuesday)
- Matt Price is going to help write the text to describe the new features, and docs team will edit into right places.
- David Planella will be sending out email summary to translation team summarizing areas NOT to focus on until after the new docs string freeze date.

Based on discussion with Laney, Didier, Neil, Alan, Olli plan is:
- Land this in PPA today, Alan's team testing today/tomorrow and providing feedback prior to upload.
- Neil has checked that all of the branches with "Needs fixing" have in fact been resolved.
- If no blockers found during testing, this will be uploaded to archive for beta 2 freeze.
- If significant issues found after upload, feature specific reversion will be done.
- Post mortem will be held to make sure this sort of situation does not reoccur in future.

Approved, subject to no significant issues being found in testing and it can land by beta 2 freeze.

Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity-lens-music (Ubuntu):
status: New → Triaged
Changed in unity-lens-photos (Ubuntu):
status: New → Triaged
Jeremy Bicha (jbicha) wrote :

Yes, +1 from the Docs Team if this can land by Beta2Freeze and we'll wrap up the screenshots this weekend.

Omer Akram (om26er) on 2012-09-20
no longer affects: unity/6.0
Changed in unity:
milestone: 7.0 → 6.6
Neil J. Patel (njpatel) on 2012-09-20
description: updated

Al 18/09/12 19:12, En/na John Lea ha escrit:
> Hi Documentation and Translation teams,
>
> We are currently in the process of finally landing the Dash work from
> this cycle. I know this is very late, but we are now making the final
> push to get everything landed into 12.10. The new 12.10 Dash will
> update some aspects of the overall Dash appearance.
>
> Ideally great if we could take new screenshots of the Dash and do a
> translation review of these changes when Beta2 arrives. However even if
> if is not possible to take new screenshots the structure of the Dash and
> the copy is broadly similar to the current Dash, so even if it is not
> possible to update the screenshots there should still not be any major
> issues.
>
> The bug that is landing these changes is
> https://bugs.launchpad.net/ayatana-design/+bug/1049593
>
> Apologies again for how late this is landing in the cycle, and thanks
> for your understanding.
>
> cheers,
> John
>

After a chat with Neil, the impact for translators will be just the
addition of the "More suggestions" string, which I think is ok in terms
of translations, considering the amount of changes. So +1 from translations.

I fully agree with Jeremy on his reply, though, in that these changes
should a) be properly be communicated in advance and b) land much
earlier in the cycle.

Working at Canonical myself, I have full understanding for everyone
working hard to meet the deadlines and provide the best OS experience
with the best features to our users. But in line with our philosophy and
our values, we should also make an additional effort to have plans in
place to avoid or mitigate any extra work from our awesome and dedicated
volunteer contributors.

Cheers,
David.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Didier Roche (didrocks) on 2012-09-20
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity-lens-music (Ubuntu):
status: Triaged → Fix Released
Changed in unity-lens-photos (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-asset-pool - 0.8.24-0ubuntu2

---------------
unity-asset-pool (0.8.24-0ubuntu2) quantal-proposed; urgency=low

  * New upstream release:
    - [FFE][UIFE]Dash - Finesse the placement, movement and behaviour
      of the 12.10 Dash (LP: #1049593)
 -- Didier Roche <email address hidden> Thu, 20 Sep 2012 20:45:29 +0200

Changed in unity-asset-pool (Ubuntu):
status: New → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-music:
status: New → Fix Released
Changed in unity-lens-photos:
status: New → Fix Released
John Lea (johnlea) on 2012-10-10
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers