[non-GLSL hardware] Unity crashed with SIGSEGV in nux::IOpenGLPixelShader::IOpenGLPixelShader() from nux::GpuDevice::CreatePixelShader() from nux::GpuDevice::CreatePixelShader() from nux::Coverflow::Impl::Impl() from nux::Coverflow::Coverflow()

Bug #1040628 reported by Omer Akram on 2012-08-23
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
Invalid
Critical
Unassigned
Unity
Fix Released
Critical
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Unassigned

Bug Description

unity bzr2613
nux bzr650

When i start unity from the staging ppa on my netbook, it crashes just a after a few seconds.

GPU is: 00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)

Related branches

Omer Akram (om26er) wrote :
Omer Akram (om26er) wrote :

om26er@1215P:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) IGD
OpenGL version string: 1.4 Mesa 8.0.2

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

Changed in unity:
milestone: none → 6.4
importance: Undecided → Critical
description: updated
summary: - [non-GLSL hardware] Unity crashes instantly when interacting with any of
- its component.
+ [non-GLSL hardware] Unity crashed with SIGSEGV in
+ nux::IOpenGLPixelShader::IOpenGLPixelShader() from
+ nux::GpuDevice::CreatePixelShader() from
+ nux::GpuDevice::CreatePixelShader() from nux::Coverflow::Impl::Impl()
+ from nux::Coverflow::Coverflow()
Changed in nux:
importance: Undecided → Critical
Bilal Akhtar (bilalakhtar) wrote :

Seems like a driver issue. My laptop with Intel HD 3000 graphics is just fine.

tags: added: hwsps
Omer Akram (om26er) wrote :

its not a driver bug. its somewhere in our code.

Plus please use that tag for bug report that we(triagers) ourselves can't test due to lack of hardware, I do have a netbook to test.

tags: removed: hwsps
no longer affects: xserver-xorg-video-intel (Ubuntu)
Omer Akram (om26er) on 2012-08-24
Changed in nux:
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

As far as I know, the "N10" refers to 2nd gen Atom CPU:s (Atom N450/N455/N470), which do have vertex and pixel shader support and also GLSL. They don't advertise OpenGL 2.0 support, though.

Timo Jyrinki (timo-jyrinki) wrote :

I have access to similar N10/N470 laptop, where I have among else: GL_ARB_fragment_shader, GL_ARB_shader_objects, GL_ARB_vertex_shader and GL_ARB_shading_language_100. Is there something else required for GLSL still, or from Unity point of view?

tags: added: 1210b1blockers
Changed in nux:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in nux:
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in nux:
status: In Progress → New
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Changed in unity:
status: In Progress → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2012-09-03
Changed in nux:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Fix Released
Daniel van Vugt (vanvugt) wrote :

Update: Unity 6.4 is revision 2632, so this is actually fix committed for Unity 6.6.

Changed in unity:
status: Fix Released → Fix Committed
milestone: 6.4 → 6.6
Changed in unity:
milestone: 6.6 → 7.0
Omer Akram (om26er) on 2012-09-20
no longer affects: unity/6.0
Changed in unity:
milestone: 7.0 → 6.6
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments