[regression] Week 34: Ctrl+Alt+T shortcut (open terminal) fails to work

Bug #1040081 reported by Nice Testhouse on 2012-08-22
62
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Compiz
High
Sam Spilsbury
GNOME Settings Daemon
Invalid
Wishlist
Unity
Invalid
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 12.10 Quantal with ppa:timo-jyrinki/prerelease on machines with GPU (Intel, Radeon, Nvidia)
Test case ID: Can 26 - UNITY_ Test Alt+F1 KeyNavMode Shortcuts

Shortcut Ctrl+Alt+t fails to open a new terminal window. Using this shortcut does not do anything.

Action:
#. Press Alt+F1
#. Press Ctrl + Alt + t

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.2.0-0ubuntu3~test4 [origin: LP-PPA-timo-jyrinki-prerelease]
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic i686
ApportVersion: 2.4-0ubuntu9
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CrashDB: unity
Date: Wed Aug 22 15:04:02 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120713.1)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Nice Testhouse (testhouse) wrote :
description: updated
Bilal Akhtar (bilalakhtar) wrote :

This works on my system. When I press Ctrl+Alt, the launcher exits keynav, and then when I press t too, the terminal opens as normal. Can you check if this issue happens on archive packages too (you're using a third-party PPA) ?

Changed in unity:
status: New → Incomplete
Daniel van Vugt (vanvugt) wrote :

Confirmed with the latest quantal updates today. Though I'm pretty sure this should not be assigned to Unity...

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: Incomplete → Confirmed
summary: - Week 34: Ctrl +Alt + t shortcut fails to work
+ [regression] Week 34: Ctrl+Alt+T shortcut (open terminal) fails to work
tags: added: regression-update
Ingo Gerth (igerth) wrote :

1) Is #1040954 a duplicate of this?

2) There is another key-combination that is not working which I used a lot. Alt + Left Mouse Button to move windows does not work anymore. *Very* annoying.

description: updated
Ingo Gerth (igerth) on 2012-08-24
description: updated
Edward Donovan (edward.donovan) wrote :

Ingo, the window dragging problem is bug 1041105. Already fixed! :-)

description: updated
Edward Donovan (edward.donovan) wrote :

And I think this is the same as bug 1040954. I guess I'll dupe this one to that, since that's assigned to gnome-settings-daemon, and I think that's right. Since downgrading g-s-d, alone, fixed the problem. Correction welcome.

Omer Akram (om26er) wrote :

regression-release is mainly used for the case where an regression is introduced due a SRU.

Omer Akram (om26er) wrote :

sorry not for SRU. But the case where bug is not present in an old release and appears in the new release(Quantal have not been out yet)

tags: removed: regression-update
Edward Donovan (edward.donovan) wrote :

Allow me to repeat what I said in one of the dupes:

I went through the changelogs, of the update where this bug arrived. This seems the most likely part:

  gnome-settings-daemon (3.4.2-0ubuntu9) quantal-proposed; urgency=low

    debian/patches/revert_git_use_gsetting_keybindings.patch:
    - drop the gconf to gsettings migration reverts (LP: #1035261)

I've tested it, and you can see this bug come and go, switching between versions 0ubuntu8 and 0ubuntu9.

So it looks like g-s-d is the place to assign this bug. Perhaps that's wrong, say, if g-s-d is fine, and it's compiz that needs to be patched to match. I don't know the code.

For now, I'm going to change the assignment from Unity, to g-s-d and compiz. I think that has to be closer, and people who know better can improve it from there, as needed. Thanks.

affects: unity (Ubuntu) → gnome-settings-daemon (Ubuntu)
Changed in unity:
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

I've also proposed, on bug 1041169, that these reports are the same problem.

This report is about losing Ctrl-Alt-T, that one is about losing custom keybindings. It looks to me like Ubuntu implements Ctrl-Alt-T by installing it as a custom keybinding. And all those shortcuts are lost in the same upgrade gnome-settings-daemon 3.4.2-0ubuntu8 to 3.4.2-0ubuntu9. And they reappear if you downgrade to -0ubuntu8.

Jeremy B. thought it looked like a separate problem, so I didn't change the duplicate status any more, but made this argument, there, too.

Ok, that's what I think I know about this bug. Thanks for listening!

Jeremy Bicha (jbicha) wrote :

Omer, according to https://wiki.ubuntu.com/QATeam/RegressionTracking regression-release applies to development releases too.

I have a gnome-settings-daemon and a gnome-control-center patch which can fix this. It recreates the missing schema I'm going to try a bit more to see if I can get a default custom keyboard shortcut working but I couldn't that to work yesterday.

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Jeremy Bicha (jbicha)
status: Confirmed → In Progress
tags: added: regression-release
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.2-0ubuntu10

---------------
gnome-settings-daemon (3.4.2-0ubuntu10) quantal; urgency=low

  * 64_restore_terminal_keyboard_shortcut_schema.patch:
    - The "Launch Terminal" schema was dropped in the gconf>gsettings
      switch. Bring it back. (LP: #1010558, LP: #1040081)
 -- Jeremy Bicha <email address hidden> Sun, 26 Aug 2012 12:44:27 -0400

Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Fix Released
no longer affects: compiz (Ubuntu)
Jeremy Bicha (jbicha) on 2012-08-26
Changed in gnome-settings-daemon (Ubuntu):
assignee: Jeremy Bicha (jbicha) → nobody
Changed in gnome-settings-daemon:
importance: Unknown → Wishlist
status: Unknown → New
Jeremy Bicha (jbicha) on 2012-08-26
Changed in unity:
status: Invalid → Confirmed
Jeremy Bicha (jbicha) wrote :

There is still a Compiz/Unity bug as Ctrl+Alt+t works fine in GNOME Shell.

In Unity I believe the Ctrl+Alt+t listed in org.compiz.integrated.gschema.xml conflicts with the Ctrl+Alt+t I added to gnome-settings-daemon. The integrated schemas are for those that don't have a GNOME gsettings equivalent.

Thanks for all this good work, Jeremy.

Daniel van Vugt (vanvugt) wrote :

Works now with the gnome-settings-daemon update. Thanks Jeremy.

If the conflict issue (comment #14) is causing anyone grief, please log it as a separate bug using this command:
    ubuntu-bug compiz

Changed in unity:
status: Confirmed → Invalid
Changed in gnome-settings-daemon:
status: New → Invalid
Changed in compiz:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.8.2
Changed in compiz:
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz at revision 3344

Changed in compiz:
status: In Progress → Fix Committed
Changed in compiz:
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu):
status: New → Triaged
Nice Testhouse (testhouse) wrote :

Week 37 - Same issue observed with Alt+tab, the alt+tab switcher fails to appear when in workspace 2.

Action:
#. Start terminal on workspace 1
#. Start firefox on workspace 2

Move to workspace 1:
#. Hold Alt, press tab
#. Observe

Move to workspace 2:
#. Hold Alt, press tab
#. Observe

Nice Testhouse (testhouse) wrote :

Week 38 - Same issue observed with Alt+Tab, switcher fails to appear. Workspace 1 Alt+tab switcher appears and in workspace 2 switcher fails to appear.
Ubuntu 12.10 with ppa:unity-team/staging

Nice Testhouse, that sounds like a separate bug. Please open a new bug for
that.

Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package compiz - 1:0.9.8.2+bzr3377-0ubuntu1

---------------
compiz (1:0.9.8.2+bzr3377-0ubuntu1) quantal-proposed; urgency=low

  [ Sam Spilsbury ]
  * debian/python-compizconfig.install
    - Install compizconfig-python.pc
  * debian/patches/100_expo_layout.patch
    - re-add the expo layout that used to be in precise (LP: #1047067)
    - add some testcases

  [ Timo Jyrinki ]
  * New upstream snapshot.
    - Fix multiple window placement bugs (LP: #974242) (LP: #976032)
    - Don't waste CPU looping through and looking at all the windows if you're
      rendering an output that has no damage on it. (LP: #1014986)
    - Updated convert files to fix some typos in the key names. (LP: #1041631)
    - Fix crash when imgsvg is loaded, due to missing symbol
      (decor_apply_gravity from libdecoration). (LP: #956986)
    - Treat unresolved symbols at link time as an error, rather than letting
      them through and cause strange crashes later. (LP: #1043143)
    - Refactors a little bit of the upgrade code and gets it under test to
      prepare to fix (LP: #1042537)
    - Updated AUTHORS from the full bzr log, and re-sort the list.
      (LP: #1042095)
    - Fixes FTBFS for kde4-window-decorator (LP: #1041310)
    - Fix obvious omissions from the introduction of unminimize_*,
      which were causing the unminimize animation settings to be ignored
      (LP: #1040455)
    - resize plugin: don't crash if resize wasn't initiated externally
      (LP: #1045191)
    - Clean up capitalization (LP: #1045652)
    - Avoid division by zero, if plugins try to deform a window down to size
      zero. (LP: #1045235)
    - Make "Unredirect Fullscreen Windows" more reliable. This fixes the
      problem with unredirection failing to engage at all (LP: #1041066) when
      gtk-window-decorator creates offscreen windows that are stacked on top.
      This also fixes the problem with unredirect hiding all windows,
      because it thinks the desktop window should be stacked on top
      (LP: #980663).
    - Ensure unredirected windows don't stay unredirected if they're no longer
      on top. (LP: #1041047)
    - Fix launching terminal functionality and make show-hud default key
      visible. Update the defaults to org.compiz.integrated to reflect the
      actual gnome values pre-gnome-3. (LP: #1040081) (LP: #1046199)
      (LP: #1046190)
    - Fix show-hud, bump COMPIZ_GNOME_INTEGRATED_SETTINGS_LIST_SIZE.
      (LP: #1046212)
    - Fixed: Windows with an alpha-channel, like gnome-terminal, were not
      being considered as possibly covering fullscreen windows. But they most
      certainly can. This ensures such RGBA windows are visible if they're
      stacked above a fullscreen window. (LP: #1046661)
    - Remove ListToStringList (LP: #1046184)
    - Fix typo causing CMake Error (LP: #1045665)
    - Transitions gtk-window-decorator over to use GSettings. Add a testing
      framework for the options code. (LP: #1042323)
    - Also need kdeworkspace since kdecorationbridge.h is there
      (LP: #1046770)
    - Implements some cleanup that was suggested on the merge for the original
      port to gsettings. Other issues fixed as wel...

Read more...

Changed in compiz (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.