Cannot move window with Alt+Left click

Bug #1039730 reported by Fabio Marconi on 2012-08-21
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Hallo
Unity pre-release test running on Quantal 20120821 amd64

I cannot move the window with the Alt+Right click combination.
Attached screenshot

Thanks
Fabio

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.2.0-0ubuntu3~test4 [origin: LP-PPA-timo-jyrinki-prerelease]
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.4-0ubuntu8
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CrashDB: unity
Date: Tue Aug 21 22:31:34 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.18, 3.5.0-10-generic, x86_64: installed
 virtualbox, 4.1.18, 3.5.0-11-generic, x86_64: installed
 virtualbox-guest, 4.1.18, 3.5.0-10-generic, x86_64: installed
 virtualbox-guest, 4.1.18, 3.5.0-11-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0042] (rev 12) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:d000]
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120525)
MachineType: Gigabyte Technology Co., Ltd. H55M-S2H
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-11-generic root=UUID=d67c1af9-7e7b-4f8a-87b3-ef1574169722 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/20/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7
dmi.board.name: H55M-S2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7:bd08/20/2010:svnGigabyteTechnologyCo.,Ltd.:pnH55M-S2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnH55M-S2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: H55M-S2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.8+bzr3308+merged-0ubuntu1~ccsgnomeintegrationgsettings3
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.38-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-1ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-1ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.904-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

Fabio Marconi (fabiomarconi) wrote :
Changed in unity:
status: New → Confirmed
summary: - Cannot move window with Alt+Right click
+ Cannot move window with Alt+Left click
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1039730

tags: added: package-qa-testing
Nicholas Skaggs (nskaggs) wrote :

This appears fixed now in the newer version of compiz/unity

Peter Clifton (pcjc2) wrote :

Which version fixes this?

I'm on Qauntal, and when entering Alt+Button1 binding for "move window" in CCSM, it always resets back to Super+Button1.

Joseph Swick (ubuntu-decoy) wrote :

I think the user settings for this action are getting stored in two different places and it ends up fighting over which setting takes precidence (and resets the other). The default for 12.04 and prior (from what I know) was '<Alt>Button1' to initiate window move when enabled. On one of my machines I had changed it to '<Super>Button1' in 12.04, but on updating the machine to 12.10b1, it changed it back to <Alt>Button1 for me.

I've tried changing it in CCSM, GConf & DConf and it still goes back to <Alt>Button1 for me. I belive my issue is related to this, so I won't file a seperate bug report unless necessary.

I have not tried this mytself on a fresh install of Quantal yet.

Omer Akram (om26er) wrote :

anyone facing the issue try. dconf reset -f /org/compiz then logout and login again and see if that changes anything for you. I saw a similar issue few weeks ago but the issue have vanished since

Joseph Swick (ubuntu-decoy) wrote :

Running the reset didn't change anything for me, I can go into CCSM and change an option in a plugin, but as soon as I back out of it and go back into the plugin, it's set back to the default. My guess CCSM is writing the new plugin values to the correct location. Is this something I could try setting by hand in dconf to see if it respects the new setting?

If I open up the gconf editor, it has the setting I expect for the option, so in my uneducated opinion, this is a gconf to dconf transition issue.

arno_b (arno.b) wrote :

The dconf reset does not work for me. On 12.04 alt-click moved a window. Now it is Windows-click...

arno_b (arno.b) wrote :

Ok now it works: I just launch gconf-editor and all came back (I can move windows using alt-click, I can select on the dkstop, etc.).
One precision: I upgraded from 12.04.

Changed in unity (Ubuntu):
status: New → Confirmed
Andrea Azzarone (azzar1) wrote :

@Fabio, is this still a problem?

Changed in unity:
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Fabio Marconi (fabiomarconi) wrote :

I can see it is fixed in Vivid.
Many thanks and sorry to forget about follow up...

Changed in unity:
status: Incomplete → Fix Released
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers