[regression] Unity trunk not redrawing properly with NVIDIA

Bug #1037872 reported by Daniel van Vugt on 2012-08-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Invalid
Critical
Daniel van Vugt

Bug Description

From email:

as we were merging all the preview branches we noticed that there are
some issues with unity - it wasn't redrawing properly, we narrowed the
problem down to lp:unity r2566, reverting that fixed the issues. I was
seeing the problem with proprietary nvidia + opengl3, Gord had the same,
although Neil didn't (Intel). Adding also some thoughts from Sam from IRC:

<smspillaz> mhr3: could you let duflu know that its these three lines in
the #ifndef USE_MODERN_COMPIZ_GL path that are likely causing problems ?
<smspillaz> glDepthRange(0, 1); //glViewport(-1, -1, 2, 2);
gScreen->resetRasterPos();
 I just compared the two revisions and mentally parsed what was going on
 #ifdefs
 argh
<-- tvoss has quit (Ping timeout)
<smspillaz> also running python under valgrind copying gconf trees
recursively is not fun
<smspillaz> mhr3: they should be inside of #else USE_MODERN_COMPIZ_GL
<smspillaz> ... #ifndef USE_GLES

Daniel van Vugt (vanvugt) wrote :

Oops. Already reverted in r2573.

Changed in unity:
status: In Progress → Fix Committed
status: Fix Committed → Invalid
Changed in unity:
milestone: 6.4 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers