Dash, Software Centre - List all Lenses and Scopes in new "Dash Search Plugins" category

Reported by John Lea on 2012-07-16
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

All Lenses and Scopes should be displayed in the software centre, the change request is as follows:

1. Add all the default Lenses to a 'Dash search plugins' category inside 'Themes & tweaks'. The current default Lenses are:

unity-lens-applications
unity-lens-files
unity-lens-music
unity-lens-video
unity-lens-photos

They are currently hidden as 'technical items', this needs to be switched off.

Note unity-lens-gwibber will also hopefully become default lenses this cycle.

2. Add graphical assets to represent the Lenses in the Software Center. A icon for each Lens is available, and screenshots with the default wallpaper also need to be attached to each Lens.

3. All other Lenses currently listed in the software centre should also be added to this "Dash Search Plugins" category inside 'Themes & tweaks'. Note that there are quite a number of 3rd party Lenses that need to be categorised in this way.

4. All scopes should be listed as 'add-ons' for specific Lenses, e.g. unity-scope-musicstores should be a add-on for the Music Lens. Double check that all scopes are correctly listed as add-ons, and none are visible in the "Dash Search Plugins" category.

5. Check that a user can both install and un-install all of these Lenses and Scopes, including those shipped by default.

Implementing this requires an icon for the subcategory, bug 1036217.

John Lea (johnlea) on 2012-07-16
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
tags: added: udp
David Pitkin (dpitkin) wrote :

In addition I am curious about how to turn unity-muisc-lens not into a "technical item" in USC and the web, is this something that simply has to change in the package?

https://apps.ubuntu.com/cat/applications/unity-lens-music/

A more comprehensive list of Lenes can be found:
https://apps.ubuntu.com/cat/search/?q=lens&op=

tags: added: ca-escalated
David Pitkin (dpitkin) wrote :

unity-lens-applications
unity-lens-files
unity-lens-music
unity-lens-video

Lenses need desktop files, exec lines and not include "NoDisplay=True"

John Lea (johnlea) on 2012-07-17
description: updated
John Lea (johnlea) wrote :

@dpitkin; I have broken the new category creation request into another bug, see https://bugs.launchpad.net/software-center/+bug/1025579

Popey has agreed to do the packaging updates, could you liaise with him to make sure all the points in the bug description are covered.

thanks,
John

John Lea (johnlea) on 2012-07-17
description: updated
David Pitkin (dpitkin) wrote :

The debtag rules to show up in Dash Search Plugins can be found on the spec
https://wiki.ubuntu.com/SoftwareCenter#lenses

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Omer Akram (om26er) on 2012-07-18
Changed in unity:
importance: Wishlist → Undecided
Changed in unity (Ubuntu):
importance: Wishlist → Undecided
John Lea (johnlea) on 2012-07-23
description: updated
John Lea (johnlea) wrote :

@dpitkin; Hyia, what is the current status on this change request, can we expect it to land soon? Many thanks!

Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
description: updated
Michael Vogt (mvo) on 2012-08-27
tags: removed: ca-escalated
John Lea (johnlea) on 2012-09-03
tags: added: dashm
description: updated
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
description: updated
Ricardo Mendoza (ricmm) on 2012-09-03
Changed in unity (Ubuntu):
assignee: nobody → Ricardo Mendoza (ricmm)
status: Triaged → In Progress
Michael Vogt (mvo) on 2012-09-10
tags: added: ca-esalated
Stephen M. Webb (bregma) wrote :

This functionality in Unity is now fully provided by the Smart Scopes feature, available since unity 7.1. Selecting the Applications lens and the Search Plugins filter will display all search plugins available (local or through the Software Centre).

This bug has been fixed and released.

Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
assignee: Ricardo Mendoza (ricmm) → nobody
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers