panel and launcher blinks when using libreoffice presenter/spreadsheet

Bug #1024459 reported by Didier Roche on 2012-07-13
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Daniel van Vugt
unity (Ubuntu)
High
Unassigned

Bug Description

Latest version (6.0), intel graphics:
1. open libreoffice presenter
2. double click on the presenter edit view
-> you can see that the panel and launcher becomes transparent
There is no crash and if you get the cursor back to the libreoffice *menu* area, the panel/launcher reappears.

See the beginning of this video (panel will disappear). As you can see, it doesn't on each double click for selecting the content, but on most of them.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-4.4-generic 3.5.0-rc6
Uname: Linux 3.5.0-4-generic x86_64
ApportVersion: 2.3-0ubuntu4
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Fri Jul 13 18:14:50 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Didier Roche (didrocks) wrote :
Didier Roche (didrocks) wrote :
Changed in unity:
milestone: none → 6.2
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2012-07-13
summary: - panel and launcher blinks when using libreoffice spreadsheet
+ panel and launcher blinks when using libreoffice presenter/spreadsheet
description: updated
Thomas Bechtold (toabctl) wrote :

i recognized the same behavior (on quantal, all updates installed) without any libreoffice app opened. the launcher gets transparent when i scrolled in emacs.

Edward Donovan (edward.donovan) wrote :

I see similar problems, when scrolling through a long buffer in emacs (both v. 23 and the newly arrived 24). It seems likely to be the same bug. I've only seen it with the window maximized.

Try:

1. open Gnu Emacs
2. maxmize the window
3. open directory /var/log
4. navigate to a good-sized file like kern.log. Hit 'v' to view the file.
5. Scroll down with the space bar, or the Page Down key, or the mouse.

See the Launcher and Panel disappear.

The panel seems to come back sooner, on its own sometimes. It looks like I need to move the mouse over the Launcher, to see it again. Thanks.

Edward Donovan (edward.donovan) wrote :

Oh - in my Emacs scenario, Alt-Tabbing restores the Launcher as well. Thanks.

Edward Donovan (edward.donovan) wrote :

More info, to be clear:

This is under Unity 6.0 on my up-to-date Quantal box. Intel drivers also. Thanks. (Probably remember something else in two minutes; excuse me :-)

Edward Donovan (edward.donovan) wrote :

I've marked bug 1024720 a duplicate. Nils is running Intel graphics also. But his problem is on a 12.04 system, so I could be wrong. Thanks.

Nils Frank (gordon-frank) wrote :

Yes, i had the same problem.

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
tags: added: regression-regionaldamage
Changed in unity:
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

Good news. I couldn't reproduce this bug because whatever it is seems to have been fixed in lp:compiz somewhere after r3249. Not sure which revision fixed it but I can confirm the bug occurs with lp:compiz r3249 but does not with r3285.

I have not bisected it completely yet.

Didier Roche (didrocks) wrote :

I confirm this is fixed now in compiz trunk.

Changed in unity:
status: In Progress → Fix Committed
affects: unity → compiz
Changed in compiz:
milestone: 6.2 → none
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: Confirmed → Fix Committed
Changed in compiz:
milestone: none → 0.9.8.0
Daniel van Vugt (vanvugt) wrote :

Found it. lp:compiz r3265 seems to be the fix/workaround. Branch linked.

But it *shouldn't* fix this bug :(

I will try to find a workaround for unity without changing compiz.

Changed in unity:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Daniel van Vugt (vanvugt)
milestone: none → 6.2
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

I have linked and am proposing a proper fix for lp:unity. It seems lp:compiz-r3265 is more of an accidental workaround.

no longer affects: compiz
no longer affects: compiz (Ubuntu)
Changed in unity:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.0.0-0ubuntu2

---------------
unity (6.0.0-0ubuntu2) quantal; urgency=low

  * Cherry pick upstream fixes.
    - [regression] [unity 6.0] Fullscreen windows flicker and/or never redraw
      properly if panel_opacity<1.0 or dash is opened (LP: #1024911)
    - panel and launcher blinks when using libreoffice presenter/spreadsheet
      (LP: #1024459)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Mon, 16 Jul 2012 14:48:14 +0200

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity at revision 2504

Didier Roche (didrocks) on 2012-08-10
Changed in unity:
status: Fix Committed → Fix Released

This bug also happens in Ubuntu 12.04, running latest unity for that version (5.20).
Is it possible to backport the fix? We have about 200 laptops showing this behaviour when editing a LibreOffice Writer document and changing the text color. Launcher and top panel disappear.

The bug was already reported for unity version 5, but marked as duplicate (bug 1024720)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers