Regression in Launcher keyboard navigation (with Alt+F1)

Bug #1021549 reported by Jay Taoko on 2012-07-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Daniel van Vugt
unity (Ubuntu)
Undecided
Unassigned

Bug Description

When pressing Alt+F1, the Launcher gets the keyboard focus and the user can move through it with the arrow keys. Following the merge of this branch

 http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/2470

in Unity , the following behavior occurs:
  * Alt+F1 activate the key navigation focus in the Launcher
  * Moving up/down, the Launcher rendering is not updated accordingly. The focused launcher item is not visible. You can't distinguish it from other items.
  * Moving the right arrow keys open the quicklist of the focused item but key navigation up/down does not work in the quicklist.

Note that you should minimize all windows before attempting to reproduce the problem. When other parts of the desktop are being rendered, the problem is less visible.

Related branches

Jay Taoko (jaytaoko) wrote :

I will add that I have reproduced the bug on Precise.

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
Tim Penhey (thumper) wrote :

Note that I wasn't able to reproduce on intel.

Changed in unity:
status: New → In Progress
Tim Penhey (thumper) on 2012-07-06
Changed in unity:
status: In Progress → Triaged
importance: Undecided → High
Jay Taoko (jaytaoko) wrote :

If it can help, I reproduced the issue with and NVidia GPU. Also, I don't get the issue if I revert to the revision before http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/2470

Changed in unity:
status: Triaged → In Progress

I can reproduce the issue on Intel/Quantal.

Changed in unity:
milestone: none → 6.0
tags: added: regression-regionaldamage
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity at revision 2472

Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

---------------
unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing setup.py
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    debian/control:
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers