Desktop Cube: Unity's top panel shadow gets deformed also and rendered on the desktop cube instead of sticking with the top panel when the cube gets activated

Bug #1011120 reported by MC Return on 2012-06-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Daniel van Vugt
unity (Ubuntu)
Low
Daniel van Vugt

Bug Description

The shadow of the main Unity panel on top should stay untouched, like the panel does, when using the desktop cube, instead of being rendered onto the cube.
The situation gets even worse visually when "Cube Reflection and Deformation" is used additionally, because now the shadow does not deform with the cube, but stays in the same position of the original cube.

Ubuntu 12.04, Compiz 0.9.7.8-0ubuntu1vvpreproposed2

Related branches

MC Return (mc-return) wrote :

I attached a screenshot showing the Unity Top Panel Shadow being rendered onto the face of the unfolded cube.

Daniel van Vugt (vanvugt) wrote :

I suspect unity should be checking the paint mask and not drawing the panel shadow is the screen is transformed. However I also suspect the expo plugin is failing to set the screen transformed flag, based on other work I've done this week.

affects: compiz → unity
Omer Akram (om26er) wrote :

I am going to set it as confirmed since its clearly an issue. As we are not sure if its actually a bug in unity feel free to set it back to NEW.

Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
mehmet.nural (zxcq14) wrote :

i've got same problem. really frustrating

mehmet.nural (zxcq14) wrote :

Replace /usr/share/unity/3/panel-shadow.png with an invisible image.

MC Return (mc-return) wrote :

I do not want to eliminate the panel-shadow completely, but I might do that, because the shadow showing everywhere (Stack Switcher, Cube, etc.) is making things really ugly.
mnrl, thanks for pointing to a possible workaround, I did not think about the shadow being a simple texture one could simply make transparent :)

Daniel van Vugt (vanvugt) wrote :

I think we might have fixed this with bug 1012956.

MC Return (mc-return) wrote :

Daniel, I got Compiz 1:0.9.8+bzr3249+bzr3278ubuntu0+3273 installed, but the shadow is still rendered on the cube and stack switcher...

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in unity (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in unity:
milestone: none → 7.0.0
status: Confirmed → In Progress
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in unity:
status: In Progress → Fix Committed
MC Return (mc-return) wrote :

Great job, Daniel. Works perfectly in recent trunk :)

Changed in unity (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Daniel van Vugt (vanvugt)
milestone: none → ubuntu-13.04-month-2
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers