Activity log for bug #1001621

Date Who What changed Old value New value Message
2012-05-19 12:29:28 Jactry Zeng bug added bug
2012-05-19 12:29:28 Jactry Zeng attachment added little program https://bugs.launchpad.net/bugs/1001621/+attachment/3153572/+files/unitytest32bit.tar.gz
2012-05-19 13:03:08 Jactry Zeng description When I run a software which it write with and build in 32bit system in a 64bit system. It can't work a global meun and the HUD. I test this in Ubuntu 12.04 64bit,and the version of unity is 5.12.0. And we can reappear it run the little program (attachment) in 64bit sysytem which I write it with Qt and build in 32 bit system. (You may should install ia32-libs to support 32bit software in 64bit system) And this is the output information: Unable to load library icui18n "Cannot load library icui18n: (libicui18n.so.48: 错误 ELF 类: ELFCLASS64)" /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: 错误 ELF 类: ELFCLASS64 (unitytest32bit:8755): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: 错误 ELF 类: ELFCLASS64 (unitytest32bit:8755): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: 错误 ELF 类: ELFCLASS64 (unitytest32bit:8755): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: 错误 ELF 类: ELFCLASS64 (unitytest32bit:8755): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so When I run a software which it write with and build in 32bit system in a 64bit system. It can't work a global meun and the HUD. I test this in Ubuntu 12.04 64bit,and the version of unity is 5.12.0. And we can reappear it run the little program (attachment) in 64bit sysytem which I write it with Qt and build in 32 bit system. (You may should install ia32-libs to support 32bit software in 64bit system) And this is the output information: Unable to load library icui18n "Cannot load library icui18n: (libicui18n.so.48: wrong ELF class: ELFCLASS64)" /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
2012-05-19 13:06:01 Jactry Zeng attachment added run it in a 32bit system https://bugs.launchpad.net/unity/+bug/1001621/+attachment/3153604/+files/0.png
2012-05-19 13:06:37 Jactry Zeng attachment added in 32bit system https://bugs.launchpad.net/unity/+bug/1001621/+attachment/3153605/+files/1.png
2012-05-19 13:07:06 Jactry Zeng attachment added in 64bit system https://bugs.launchpad.net/unity/+bug/1001621/+attachment/3153606/+files/2.png
2012-05-19 13:07:32 Jactry Zeng attachment added in 64bit system https://bugs.launchpad.net/unity/+bug/1001621/+attachment/3153607/+files/3.png
2012-05-20 02:51:52 Jactry Zeng description When I run a software which it write with and build in 32bit system in a 64bit system. It can't work a global meun and the HUD. I test this in Ubuntu 12.04 64bit,and the version of unity is 5.12.0. And we can reappear it run the little program (attachment) in 64bit sysytem which I write it with Qt and build in 32 bit system. (You may should install ia32-libs to support 32bit software in 64bit system) And this is the output information: Unable to load library icui18n "Cannot load library icui18n: (libicui18n.so.48: wrong ELF class: ELFCLASS64)" /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so When I run a software which it write with and build in 32bit system in a 64bit system. It can't work a global meun and the HUD. I test this in Ubuntu 12.04 64bit,and the version of unity is 5.12.0. And we can reproduce it run the little program (attachment) in 64bit sysytem which I write it with Qt and build in 32 bit system. (You may should install ia32-libs to support 32bit software in 64bit system) And this is the output information: Unable to load library icui18n "Cannot load library icui18n: (libicui18n.so.48: wrong ELF class: ELFCLASS64)" /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so: wrong ELF class: ELFCLASS64 (unitytest32bit:12486): Gtk-WARNING **: Failed to load type module: /usr/lib/gtk-2.0/2.10.0/menuproxies/libappmenu.so
2012-05-30 22:10:08 Bilal Akhtar bug task added appmenu-qt (Ubuntu)
2012-05-30 22:10:16 Bilal Akhtar bug task added appmenu-qt
2012-06-07 23:04:32 Bilal Akhtar unity: status New Incomplete
2012-06-07 23:04:34 Bilal Akhtar appmenu-qt: status New Incomplete
2012-06-07 23:04:39 Bilal Akhtar appmenu-qt (Ubuntu): status New Incomplete
2012-08-07 04:18:01 Launchpad Janitor appmenu-qt (Ubuntu): status Incomplete Expired
2012-08-07 04:18:05 Launchpad Janitor unity: status Incomplete Expired
2012-08-17 04:13:22 Jactry Zeng unity: status Expired New
2012-08-17 04:13:25 Jactry Zeng appmenu-qt: status Incomplete New
2012-08-17 04:13:28 Jactry Zeng appmenu-qt (Ubuntu): status Expired New
2012-08-20 14:44:45 Bilal Akhtar tags multiarch
2012-09-11 00:29:36 Bilal Akhtar appmenu-qt: importance Undecided Wishlist
2012-09-11 00:29:38 Bilal Akhtar appmenu-qt (Ubuntu): importance Undecided Critical
2012-09-11 00:29:40 Bilal Akhtar appmenu-qt (Ubuntu): importance Critical Wishlist
2012-09-11 00:29:47 Bilal Akhtar appmenu-qt (Ubuntu): status New Triaged
2012-09-11 00:29:49 Bilal Akhtar appmenu-qt: status New Triaged
2012-09-11 00:29:51 Bilal Akhtar unity: status New Confirmed
2012-09-11 00:30:31 Bilal Akhtar summary 32bit Qt software run in ubuntu 64bit can't get global menu and HUD appmenu-qt doesn't work with 32-bit apps on 64-bit system
2013-08-19 09:46:40 Rick Pontefract bug added subscriber Rick Pontefract
2014-07-24 20:35:43 Marco Trevisan (Treviño) unity (Ubuntu): status New Confirmed
2014-08-24 11:52:44 Miklos Juhasz attachment added Multiarch support for appmenu-qt https://bugs.launchpad.net/unity/+bug/1001621/+attachment/4185901/+files/appmenu-qt.debdiff
2014-08-24 11:53:38 Miklos Juhasz bug added subscriber Miklos Juhasz
2014-08-24 12:29:25 Ubuntu Foundations Team Bug Bot tags multiarch multiarch patch
2014-08-24 12:29:34 Ubuntu Foundations Team Bug Bot bug added subscriber Ubuntu Sponsors Team
2014-09-09 09:46:56 Didier Roche unity (Ubuntu): status Confirmed Invalid
2014-09-09 09:47:29 Didier Roche unity: status Confirmed Invalid
2014-09-09 09:48:45 Didier Roche appmenu-qt: status Triaged Fix Released
2014-09-09 09:53:12 Launchpad Janitor branch linked lp:~ubuntu-branches/ubuntu/utopic/appmenu-qt/utopic-proposed
2014-09-09 10:14:29 Launchpad Janitor appmenu-qt (Ubuntu): status Triaged Fix Released