Telegram Web app opens in default browser

Bug #1407275 reported by Christer on 2015-01-03
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity-Webapps-Telegram
Undecided
Unassigned

Bug Description

Telegram app opens in default browser instead of in its own window.
When I launch Telegram it opens its own window that turns white/gray/blank and then launches the Telegram interface in my default browser Firefox. If Firefox isn't running it will launch Firefox.

I am running Ubuntu 14.04 64bit.

Christer (laserpirate) on 2015-01-03
description: updated
summary: - Telegram opens in default browse
+ Telegram opens in default browser
description: updated

Hi Christer! In Ubuntu 14.10 the default webapp browser is not Firefox, I'm thinking you have a system setting changed.

Changed in unity-webapps-telegram:
status: New → Invalid
Christer (laserpirate) wrote :

Dear costales,
As I said if you READ i am running 14.04 NOT 14.10.
I have no idea what you are talking about...

Changed in unity-webapps-telegram:
status: Invalid → New
costales (costales) on 2015-01-05
summary: - Telegram opens in default browser
+ Webapp opens in default browser
no longer affects: unity-webapps-telegram
Christer (laserpirate) on 2015-01-05
summary: - Webapp opens in default browser
+ Telegram Web app opens in default browser
Jaffels (jaffels) wrote :

I have the same issue on Ubuntu 14.04 LTS 32bit. I have attached the screen grab of the bug.

aleandro (aleandrodasilva) wrote :

Same here. The program opens the browser and then you can use telegram from it.

no longer affects: libunity-webapps

The manifest.json file needs to be updated to account for https schemes. In this file, the "includes" line describes the url patterns that are valid and that can be browsed to. Any other URL (not matching the pattern) will open in the default browser,

    "includes": ["http://zhukov.github.io/webogram/*"],

one need to add "http://zhukov.github.io/webogram/*" to the list,

costales (costales) on 2015-01-06
Changed in unity-webapps-telegram:
status: New → In Progress
costales (costales) wrote :

Hi! :) Could you update the app and try it again? Thanks in advance!
Just run these commands in a Terminal:
sudo apt-get update
sudo apt-get install unity-webapps-telegram

Changed in unity-webapps-telegram:
status: In Progress → Fix Committed
Jaffels (jaffels) wrote :

There was an update through the PPA for Telegram today. It resolved the bug for me. Thank you for the speedy bug fix

Christer (laserpirate) wrote :

Updated today and after a restart of my computer it is fixed :)

Great! Thanks for your feedbacks!!!

costales (costales) on 2015-01-07
Changed in unity-webapps-telegram:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers