unity webapps don't work in Ubuntu 14.10

Bug #1395524 reported by Ervin on 2014-11-23
130
This bug affects 46 people
Affects Status Importance Assigned to Milestone
Unity-Webapps-Telegram
Undecided
Unassigned
unity-webapps-gmail (Ubuntu)
High
Alexandre Abreu
unity-webapps-qml (Ubuntu)
Undecided
Unassigned
Utopic
Undecided
Unassigned
unity-webapps-reddit (Ubuntu)
Undecided
Unassigned

Bug Description

[Impact]

No webapp will start in 14.10.

[Test Case]

- install a webapp (e.g. unity-webapps-gmail),
- click on the launcher/dash icon for gmail,
- make sure that the GMail webapp starts and that a gmail loging prompt appears,

[Regression Potential]

None

-------------------------

Original bug description:

I have tested webapps even after the latest updates in Ubuntu 14.10
The result is the same: Blank screen to all, always reproducible, in any condition, even after a fresh installation
even after the last updates.
I have not modified my system in any way to affect webapps and all default packages are there.
It applies to all webapps, youtube, gmail, livemail, reddit, etc.

Technical Info,
Ubuntu 14.10
Package - Unity Webapps Webapps - Unity integration
Webapps should open normally
Result: Blank screen

Related branches

Changed in unity-webapps-gmail (Ubuntu):
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → High
status: New → In Progress
no longer affects: unity-webapps-gmail
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-webapps-qml - 0.1+15.04.20141202-0ubuntu1

---------------
unity-webapps-qml (0.1+15.04.20141202-0ubuntu1) vivid; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Alexandre Abreu ]
  * Make sure that the content hub bindings are fail safe since the
    content hub package is a suggests (which is fine since it is not
    there by default on desktop). (LP: #1395524)
  * The content hub has been updated with some changes that caused the
    getPeers() fonction to break on the HTML5 API side.
 -- Ubuntu daily release <email address hidden> Tue, 02 Dec 2014 02:19:15 +0000

Changed in unity-webapps-qml (Ubuntu):
status: New → Fix Released
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-webapps-qml (Ubuntu Utopic):
status: New → Confirmed
twoelz (twoelz) on 2014-12-25
summary: - unity webapps don't work in Ubuntu 14.10
+ unity webapps don't work in Ubuntu 14.10
Hairo R. Carela (hairocr8) wrote :

Installing the vivid .deb seems to work fine on utopic (as a temporary fix).

Chris Coulson (chrisccoulson) wrote :

What's the status of the SRU for utopic?

José Serra (serrajv) wrote :

I'm not sure if it is related to this bug... I have a PyQt5 QML App that works in ubuntu 14.04 but I'm having problems in another machine with 14.10

With Oxide: I get a blank screen, but With QtWebkit the application closes.

gmail webapp and webbrowser-app are working.

This is the standard output: http://paste.ubuntu.com/9786477/

Hello Ervin, or anyone else affected,

Accepted unity-webapps-qml into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity-webapps-qml/0.1+14.10.20141205-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-webapps-qml (Ubuntu Utopic):
status: Confirmed → Fix Committed
tags: added: verification-needed
Michael Satke (n9447354) wrote :

Hi Brian,

this worked!! Thank you very much, the problem the problem seems to be solved soon. BUT: not all the webapps available in the Ubuntu Software-Center work. After installing:

     unity-webapps-qml_0.1+14.10.20141205-0ubuntu1_amd64.deb

I tested the following webapps (ordered alphabetically):

Amazon: works
BBC News: DOES NOT WORK - real nice blank window as known from this bug - blame the Britons for that ;-)
cnn-news: works
Deezer: DOES NOT WORK - blank window as known from this bug
DeviantArt: works
Facebook"Messenger": works, but shows the normal fb website in Ubuntu's webbrowser-app
Gmail: works
Google+: works
GoogleCalendar: works
GoogleDocs: works
Launchpad: works
LibreFm: works
Linkedln: works
Newsblur: works
Reddit: works
Tublr: works
Twitter: works
wordpress: works
YahooMail: works
YahooNews: seems to connect with server news.yahoo.com, but DOES NOT WORK fully. A message "Error in showing file:///usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/UnityWebApps/news.yahoo.com" is shown.
YandexMail: works
YouTube: works

Thank you for your efforts! Cheers, Michael

Michael Satke (n9447354) wrote :

Rem.: YouTube does not play video or sound neither started as Unity-webapp not started in Ubuntu's webbrowser-app.

tags: added: utopic
Changed in unity-webapps-qml (Ubuntu Utopic):
status: Fix Committed → Fix Released
Changed in unity-webapps-reddit (Ubuntu):
status: New → Fix Released
Changed in unity-webapps-gmail (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers