ibus input doesn't work

Bug #1312534 reported by Gino Zhao on 2014-04-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity-Webapps-Telegram
Undecided
Unassigned

Bug Description

Using Chinese language pinyin input method by ibus, I can't input Chinese word in this app.
Please fix this bug.

costales (costales) wrote :

I think is an issue for the web. Is this URL working for you? http://zhukov.github.io/webogram/#/

Changed in unity-webapps-telegram:
status: New → Invalid
Gino Zhao (ginozhao2010) wrote :

I can input Chinese word in website client(http://zhukov.github.io/webogram/#/) via ibus and still can't input Chinese word in this app.
So I think this is an issue for this app. Please check again.
Please fix it.

Changed in unity-webapps-telegram:
status: Invalid → Incomplete
Pablo Capeluto (pablocapeluto) wrote :

Gino Zhao (ginozhao2010), test this command in console...

unity-webapps-runner -n 'R21haWw=' -d 'mail.google.com' --store-session-cookies %u

Check if works imput Chinese.

Gino Zhao (ginozhao2010) wrote :

Pablo Capeluto (pablocapeluto) , I tested your command, output in terminal:

gino@gino-x220:~$ unity-webapps-runner -n 'R21haWw=' -d 'mail.google.com' --store-session-cookies %u
** Message: Launching webapp 'Gmail' with the webapp container (command line 'webapp-container --app-id='Gmailmailgooglecom' --webapp='R21haWw=' --enable-back-forward --store-session-cookies')
gino@gino-x220:~$ Could not open manifest file: "/usr/share/unity-webapps/userscripts/unity-webapps-amazon/manifest.json"
Invalid webapps installation found: "/usr/share/unity-webapps/userscripts/unity-webapps-amazon"
Using Oxide as the web engine backend
Setting session cookie mode to "restored"
QQmlExpression: Expression file:///usr/share/webbrowser-app/webcontainer/WebApp.qml:115:25 depends on non-NOTIFYable properties:
    unity::action::qml::ActionManager::globalContext
Empty path in webapps model search path update request
libEGL warning: failed to create a pipe screen for i965
[0426/104700:WARNING:proxy_service.cc(903)] PAC support disabled because there is no system implementation
Loaded 1 UA override(s) from file:///usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/Extras/Browser/ua-overrides-desktop.js

And open a new windows, but shows nothing.

Of course, I can visit mail.google.com website in Chrome and Firefox.
My system is Ubuntu 14.04 64bit
Please give me more your analysis, thanks.

Gino Zhao (ginozhao2010) wrote :

I found same issue in unity-webapps-amazon, so I thinks this is not only for this app.

Changed in unity-webapps-telegram:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers