Unity System Compositor

Screen never sleeps; missing power management

Reported by Daniel van Vugt on 2013-06-21
106
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Mir
Critical
Robert Carr
The Ubuntu Power Consumption Project
Undecided
Robert Carr
Unity System Compositor
Critical
Robert Carr
XMir
Critical
Robert Carr
powerd
Undecided
Ricardo Mendoza
touch-preview-images
Undecided
Unassigned
unity-mir
Critical
Gerry Boland
mir (Ubuntu)
Critical
Unassigned
powerd (Ubuntu)
Undecided
Unassigned

Bug Description

Effect Touch as well

Using XMir under unity-system-compositor I notice the screen never goes to sleep. I guess it's to be expected right now, but that's something we really need to fix.

Test case:
xset dpms force off

Related branches

lp:~robertcarr/mir/dpms-support-api
Merged into lp:~mir-team/mir/trunk at revision 1054
Daniel van Vugt: Needs Fixing on 2013-09-06
PS Jenkins bot: Approve (continuous-integration) on 2013-09-05
Alan Griffiths: Approve on 2013-09-05
Robert Ancell: Approve on 2013-09-02
lp:~gerboland/unity-mir/add-screen-blank
Merged into lp:unity-mir at revision 91
PS Jenkins bot: Approve (continuous-integration) on 2013-09-25
Ricardo Mendoza: Approve on 2013-09-24
lp:~ricmm/powerd/support-mir-toggled
Merged into lp:powerd at revision 94
PS Jenkins bot: Approve (continuous-integration) on 2013-09-26
Ricardo Salveti: Approve on 2013-09-26
Seth Forshee: Approve on 2013-09-25
Gerry Boland: Approve on 2013-09-25
Changed in mir:
importance: Undecided → Medium
Changed in unity-system-compositor:
importance: Undecided → Medium
Changed in mir:
status: New → Triaged
Changed in unity-system-compositor:
status: New → Triaged
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1193222

tags: added: package-qa-testing
tags: added: multimonitor
tags: added: xmir
Changed in xmir:
status: New → Triaged
importance: Undecided → Medium
Ritesh Khadgaray (khadgaray) wrote :

XMir crashes on resume ( using pm-suspend) .

kevin gunn (kgunn72) wrote :

critical for 13.10

Changed in xmir:
importance: Medium → Critical
Changed in unity-system-compositor:
importance: Medium → Critical
Changed in mir:
importance: Medium → Critical
Robert Carr (robertcarr) on 2013-07-16
Changed in mir:
assignee: nobody → Robert Carr (robertcarr)
Robert Carr (robertcarr) wrote :

I see 3 steps:

1. In mir, expose API from graphics platform for powering on and off CRTCs. Expose to client API, i.e. mir_connection_request_display_power_mode (WIP :p). Likely this should be gated by a component:

msh::PowerManagementPolicy

Which receives messages like

bool session_is_allowed_to_turn_off_displays()

2. The system compositor gains a PowerManagementPolicy to allow XMir to turn off displays.

3. xmir gains a DPMS impl in terms of the new mir client API.

Changed in xmir:
assignee: nobody → Robert Carr (robertcarr)
Changed in unity-system-compositor:
assignee: nobody → Robert Carr (robertcarr)
Daniel van Vugt (vanvugt) wrote :

See also bug 1189770 where we are turning off the monitor by accident :)

tags: added: pm
Changed in ubuntu-power-consumption:
assignee: nobody → Robert Carr (robertcarr)
Changed in mir:
status: Triaged → In Progress
kevin gunn (kgunn72) on 2013-08-26
Changed in xmir:
status: Triaged → In Progress
Changed in unity-system-compositor:
status: Triaged → In Progress
Changed in ubuntu-power-consumption:
status: New → In Progress
kevin gunn (kgunn72) on 2013-09-04
tags: added: make-xmir-default
Seth Forshee (sforshee) wrote :

I don't see that this has anything at all to do with powerd, so marking that task invalid.

Changed in powerd:
status: New → Invalid
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision None, scheduled for release in mir, milestone 0.0.11

Changed in mir:
status: In Progress → Fix Committed
Changed in mir (Ubuntu):
status: New → Fix Committed
assignee: nobody → Robert Carr (robertcarr)
no longer affects: mir (Ubuntu)
tags: added: avengers
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mir (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package mir - 0.0.11+13.10.20130924.1-0ubuntu1

---------------
mir (0.0.11+13.10.20130924.1-0ubuntu1) saucy; urgency=low

  [ kg ]
  * bump version for ABI break (LP: #1229212)

  [ Robert Ancell ]
  * Allow an application to override the options being populated.
  * Pass the program options to parse_options().
  * Add missing include for std::cerr.
  * Report when paused and resumed via configuration. (LP: #1192843)
  * Add missing directory separator when searching for a config file to
    parse.

  [ Kevin Gunn ]
  * change test timeouts and fix fence.

  [ Alexandros Frantzis ]
  * examples: Only check key information for key events This fixes a
    memory error reported by valgrind for examples that use eglapp.
  * shell: Apply the base configuration on a hardware change only if no
    per-session configuration is active.
  * graphics: consolidated fixed for nested code and examples on android
    stack.

  [ Eleni Maria Stea ]
  * graphics: Pull in Eleni's changes to get the DRM fd to init GBM from
    the host Mir instance.

  [ Didier Roche ]
  * remove (unused in the ppa as we have libmirserver3) hack to force
    depending and building against the exact same version.

  [ Robert Carr ]
  * Add DPMS configuration API. (LP: #1193222)
  * Deduplicate mtd::NullDisplayConfig and
    mtd::NullDisplayConfiguration.
  * Fix multiple internal client surfaces on android. (LP: #1228144)
  * change test timeouts and fix fence.
  * Add DPMS API and GBM/android impls.

  [ Kevin DuBois ]
  * platform, graphics: support nested (mir-on-mir) rendering on the
    Android platform.

  [ Michael Terry ]
  * Change how Mir chooses socket locations to make it simpler for a
    nested-Mir world, by using MIR_SOCKET as the host socket if no other
    host socket is provided and passing MIR_SOCKET on to any children.
    Also, change --nested-mode to --host-socket for clarity and add --
    standalone to force standalone mode.

  [ Daniel d'Andrada ]
  * android-input housekeeping - Updated README - Removed some dead
    code.

  [ Daniel van Vugt ]
  * Add DPMS configuration API. (LP: #1193222)
  * Add a "flags" field to MirBufferPackage so that clients can find out
    if the buffer they've been given is scanout-capable. This is
    normally something a client should never need to know. However there
    are two specialized cases where it's required to fix bugs in the
    intel and radeon X drivers:   LP: #1218735, LP: #1218815 The intel
    fix (already landed) contains a hack which will be updated after
    this branch lands. (LP: #1218815, #1218735)
  * GBM: Ensure that we don't create scanout buffers if bypass is
    explicitly disabled from the environment. (LP: #1227133) . (LP:
    #1227133)

  [ Alan Griffiths ]
  * graphics: Pull in Eleni's changes to get the DRM fd to init GBM from
    the host Mir instance.
  * input: Separate the code for dispatching input from that reading it.
  * graphics: Hook up nested surfaces events to input.
  * input: Connect nested input relay to input dispatch.
  * graphics: Simplify NativeAndroidPlatform out of existence.
  * tests: Fixes to get the tests "passing" on android/arm stack. (LP...

Read more...

Changed in mir (Ubuntu):
status: Confirmed → Fix Released

I got mir 0.0.11+13.10.20130924.1-0ubuntu1 with the latest update and after that I have still the problem that the screen does not get into sleep mode.

Changed in mir (Ubuntu):
status: Fix Released → Confirmed
kevin gunn (kgunn72) on 2013-09-25
Changed in unity-mir:
assignee: nobody → Gerry Boland (gerboland)
importance: Undecided → Critical
status: New → Triaged
description: updated
Changed in xmir:
status: In Progress → Fix Committed
Changed in unity-system-compositor:
status: In Progress → Fix Committed
Changed in mir (Ubuntu):
importance: Undecided → Critical
status: Confirmed → In Progress
Changed in touch-preview-images:
status: New → In Progress
Changed in unity-mir:
status: Triaged → In Progress
Changed in mir:
milestone: none → 0.0.11
status: Fix Committed → Fix Released
Gerry Boland (gerboland) on 2013-09-26
Changed in unity-mir:
status: In Progress → Fix Committed
Michał Sawicz (saviq) on 2013-09-26
Changed in powerd:
status: Invalid → In Progress
assignee: nobody → Ricardo Mendoza (ricmm)
Changed in mir (Ubuntu):
status: In Progress → Fix Released
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:powerd at revision 94, scheduled for release in powerd, milestone ubuntu-13.05

Changed in powerd:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package powerd - 0.13+13.10.20130926-0ubuntu1

---------------
powerd (0.13+13.10.20130926-0ubuntu1) saucy; urgency=low

  [ Ricardo Mendoza ]
  * Allow powerd to work with unity-mir's DBus API for screen power
    control, selective using the backend available according to the
    running display server. (LP: #1193222)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 94
 -- Ubuntu daily release <email address hidden> Thu, 26 Sep 2013 18:34:30 +0000

Changed in powerd (Ubuntu):
status: New → Fix Released
Eduardo (ludentico) wrote :

Installing powerd solved the bug... So, I guess this has to be a «recommended» package when installing mir

kevin gunn (kgunn72) on 2013-09-27
Changed in unity-mir:
milestone: none → phone-v1-freeze
kevin gunn (kgunn72) on 2013-09-27
Changed in unity-system-compositor:
status: Fix Committed → Fix Released
Changed in powerd:
status: Fix Committed → Fix Released
Changed in touch-preview-images:
status: In Progress → Fix Released
Changed in ubuntu-power-consumption:
status: In Progress → Fix Released
Changed in xmir:
status: Fix Committed → Fix Released
Changed in unity-mir:
status: Fix Committed → Fix Released
Joseph Wakeling (webdrake) wrote :

Screen still not turning off -- this is on a ThinkPad T420 with Intel graphics [Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)].

Is powerd now considered necessary also for Ubuntu Desktop? If so as Eduardo says it should probably be added as a recommend or dependency of mir.

Daniel van Vugt (vanvugt) wrote :

Joseph,

Please join bug 1231857 if that's what you see.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers