unity-scopes-shell build problems when building against Qt 5.2

Bug #1267831 reported by Timo Jyrinki on 2014-01-10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Michał Sawicz

Bug Description

There is a combination of build failures (on armhf and amd64) and a success (i386) with unity-scopes-shell when built against Qt 5.2:



To upgrade to the Qt 5.2 easily (now possible on desktop where all dependencies are built):
apt-add-repository ppa:canonical-qt5-edgers/qt5-beta2
apt-get update
apt-get dist-upgrade

See/describe dependencies of packages at http://pad.ubuntu.com/qt52-dependencies

Michal Hruby (mhr3) wrote :

The build shows that unity-scopes-shell was building against old versions of unity-api and unity-scopes-api, unfortunately right now trunk -shell will not build against trunk unity-scopes-api because of some changes in the latter, but that's FTBFS and will be fixed asap.

Michał Sawicz (saviq) on 2014-01-10
Changed in unity-scopes-shell:
assignee: nobody → Michał Sawicz (saviq)
status: New → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

A related unity-scopes-api bug is bug #1267917

description: updated
Michal Hruby (mhr3) wrote :

There's no unity-scopes-shell task here, correct build deps are now in distro, and the temporary FTBFS was fixed.

Changed in unity-scopes-shell:
status: In Progress → Invalid
Timo Jyrinki (timo-jyrinki) wrote :

It seems this was fixed now since yesterday's daily build failed because of the dependencies and finally today the recipe is building (https://launchpadlibrarian.net/163092210/buildlog.txt.gz). Thanks, great!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers