HTTP tests failing when built with Qt5.2

Bug #1267917 reported by Michal Hruby on 2014-01-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-scopes-api
Fix Released
Critical
Marcus Tomlinson
unity-scopes-api (Ubuntu)
Critical
Marcus Tomlinson

Bug Description

There are failing asserts:
ASSERT failure in QCoreApplication::sendEvent: "Cannot send events to objects owned by a different thread. Current thread 33abf0. Receiver '' (of type 'QNetworkAccessManager') was created in thread 4220b460", file kernel/qcoreapplication.cpp, line 502

See for example https://launchpadlibrarian.net/162128583/buildlog_ubuntu-trusty-armhf.unity-scopes-api_1%3A0.1.7-0~125%2B201401101436~ubuntu14.04.1_FAILEDTOBUILD.txt.gz

To upgrade to the Qt 5.2 easily (now possible on desktop where all dependencies are built):
apt-add-repository ppa:canonical-qt5-edgers/qt5-beta2
apt-get update
apt-get dist-upgrade

Downgrade with ppa-purge ppa:canonical-qt5-edgers/qt5-beta2

See/describe dependencies of packages at http://pad.ubuntu.com/qt52-dependencies

Related branches

Michal Hruby (mhr3) on 2014-01-10
Changed in unity-scopes-api:
assignee: nobody → Marcus Tomlinson (marcustomlinson)
importance: Undecided → High
Changed in unity-scopes-api:
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-scopes-api at revision 130, scheduled for release in unity-scopes-api, milestone Unknown

Changed in unity-scopes-api:
status: In Progress → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :
Changed in unity-scopes-api:
status: Fix Committed → Confirmed
tags: added: qt5.2
Changed in unity-scopes-api:
importance: High → Critical
Changed in unity-scopes-api:
status: Confirmed → In Progress
Bill Filler (bfiller) on 2014-01-21
Changed in unity-scopes-api (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Marcus Tomlinson (marcustomlinson)
Launchpad Janitor (janitor) wrote :
Download full text (4.7 KiB)

This bug was fixed in the package unity-scopes-api - 0.2.0+14.04.20140120-0ubuntu1

---------------
unity-scopes-api (0.2.0+14.04.20140120-0ubuntu1) trusty; urgency=low

  [ Michi Henning ]
  * Added ability for scope to push an exception (as an exception_ptr). On the client side,
    the exception is delivered as the what() string (if the exception is a std::exception) and
    as "unknown exception", otherwise.
  * Disabled running the tests in parallel for CI. They are not written
    to run concurrently because the different tests try to bind to the
    same network endpoints. This should almost certainly fix the failure
    reported here:
    https://launchpadlibrarian.net/159997415/buildlog_ubuntu-saucy-
    i386.unity-scopes-api_0.1.5-0~94~ubuntu13.10.1_FAILEDTOBUILD.txt.gz.
  * Got rid of chatter from helgrind. (Needs helgrind 3.9.0 or later--
    3.8.1 generates bogus errors.) Added public destroy() method so it
    is possible to shut down the reaper explicitly. Fixed race condition
    on setting the self_ weak_ptr.
  * Changed code to match macro change here:
    https://code.launchpad.net/~michihenning/unity-api/noncopyable-
    fix/+merge/200084 Also removed remaining remnants of deprecated
    NonCopyable class.
  * Added CMake option to build with -fsanitize=thread. Fixed a bunch of
    warnings when building with clang.
  * Fixed valgrind error in HttpClient_test.cpp: execv was using
    deallocated memory. Updated CTestCustom.cmake.in to correctly
    suppress the tests that should not be run under valgrind.
  * Fixed shutdown in ObjectAdapter and added proper exception handling
    if the broker thread or a worker thread encounters an exception.
  * Disabled code generation for stand-alone header compilation tests.
    This makes the tests run marginally faster.
  * Added locate() remote method to the Registry, for the scope
    activation logic.
  * Changed ScopeLoader to not run the scope in a separate thread. (This
    is done by scoperunner anyway.) This fixes the problem of an
    exception being thrown by start(), but the scoperunner not realizing
    this. (LP: #1262536)
  * Added suppressions file for thread sanitizer issues in zmq.
  * Fixed race on registry start-up: registry was answering incoming
    requests too early. Other minor cosmetic changes: replaced
    factory()->create() call with factory()->find() because RuntimeImpl
    already instantiates the middleware. Removed redundant #includes.
    (LP: #1267026)
  * Minor fix: got rid of unnecessary unique_ptr. No functional changes.
  * Added formatcode target to CMakeLists.txt. This runs all source and
    header files through a pretty-printer.
  * Updated code for API changes in latest Cap'n Proto. (LP: #1268538)
  * Added check to prevent two servers from binding to the same ipc
    endpoint. Added coverage test for double-bind. Removed attempts to
    deal with servant destructors that throw. It turns out that this
    doesn't work because the destructor is called in the context of the
    map destructor, which calls the shared_ptr destructors, so we end up
    in terminate(). I might theoretically be possible to do this with a
    custom deleter for the...

Read more...

Changed in unity-scopes-api (Ubuntu):
status: In Progress → Fix Released
description: updated
description: updated
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-scopes-api at revision 144, scheduled for release in unity-scopes-api, milestone Unknown

Changed in unity-scopes-api:
status: In Progress → Fix Committed
Michal Hruby (mhr3) wrote :

Reverting the distro task to Confirmed as the second fix didn't land yet.

Changed in unity-scopes-api (Ubuntu):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scopes-api - 0.2.4+14.04.20140124-0ubuntu1

---------------
unity-scopes-api (0.2.4+14.04.20140124-0ubuntu1) trusty; urgency=low

  [ Michi Henning ]
  * Added ability for scope to push an exception (as an exception_ptr). On the client side,
    the exception is delivered as the what() string (if the exception is a std::exception) and
    as "unknown exception", otherwise.
  * Added abstract bases for all the *Object classes.
  * Remove redundant noexcept specifications from destructors.

  [ Jussi Pakkanen ]
  * Version bump due to namespace peeling.
  * Forward doxygen warnings into a file.

  [ Michal Hruby ]
  * Added preview and activation APIs.

  [ Michi Henning ]
  * Added default servants for Scope and QueryCtrl interfaces.

  [ Pawel Stolowski ]
  * Added set_category to CategorisedResult, removed Variant-based ctor.

  [ Marcus Tomlinson ]
  * Ensure that manager_ and reply_ objects are created and destroyed
    from within the same Qt thread. (LP: #1267917)
  * Added valgrind suppressions for memory leak false positives in Qt.
    (LP: #1262496)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 151
 -- Ubuntu daily release <email address hidden> Fri, 24 Jan 2014 10:03:35 +0000

Changed in unity-scopes-api (Ubuntu):
status: Confirmed → Fix Released
Michal Hruby (mhr3) on 2014-02-03
Changed in unity-scopes-api:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers