Dash crashes when trying to authenticate soundcloud scope with google, empty auth page

Bug #1428591 reported by Paweł Stołowski on 2015-03-05
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
Unity SoundCloud Scope
Undecided
Unassigned
webapps-sprint
High
Alberto Mardegan
ubuntu-system-settings-online-accounts (Ubuntu)
High
Alberto Mardegan
unity-scopes-shell (Ubuntu)
Undecided
Unassigned

Bug Description

1. Go to Soundcloud scope
2. Hit Log-in to SoundCloud button
3. Choose 'Sign in with Google' on the SoundCloud auth page
4. Fill in google account credentials, confirm soundcloud permissions

Result: a blank page with 'Cancel' button, no way to navigate back, hitting it crashes the dash (I couldn't get a usable backtrace).

NB, this works fine when authenticating using a genuine Soundcloud account. It seems like authenticating via Google is causing the problem.

Related branches

summary: - Dash crashes when trying to authenticate soundcloud scope with google
+ Dash crashes when trying to authenticate soundcloud scope with google,
+ empty auth page
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in signon-ui (Ubuntu):
status: New → Confirmed
Changed in unity-scopes-shell (Ubuntu):
status: New → Confirmed
erikonthenet (erik-loosman) wrote :

Same here, an blank page with a Cancel button is all I get after authenticating with a Google account

Jean-Baptiste Lallement (jibel) wrote :

This is still an issue with

current build number: 72
device name: arale
channel: ubuntu-touch/rc-proposed/meizu.en

Changed in canonical-devices-system-image:
status: New → Confirmed
tags: added: testcase
baj (benjamin-vallin) wrote :

I have the exact same problem on my bq aquaris E5.

TenLeftFingers (tenleftfingers) wrote :

Todays update did not fix the problem. I still cant login with this scope. I'm using 2 factor authentication. Is that part of the problem?

baj (benjamin-vallin) wrote :

I confirm that the update has not fixed the bug on my BQ e5.

TenLeftFingers (tenleftfingers) wrote :

Todays update did not fix the problem, although I get a bit farther now. I get to enter my account details and receive an ams with a code. I enter the code and get a white screen with a cancel button. I still cant log in.

Pat McGowan (pat-mcgowan) wrote :

@dbarth ideas?

Changed in canonical-devices-system-image:
assignee: nobody → David Barth (dbarth)
Alberto Mardegan (mardy) on 2016-03-29
affects: signon-ui (Ubuntu) → ubuntu-system-settings-online-accounts (Ubuntu)
Alberto Mardegan (mardy) wrote :

A few observations after a quick investigation:

1) This is probably not a regression, I doubt that this ever worked
2) Logging in via facebook works
3) The URL we open to start the authentication is https://soundcloud.com/connect?client_id=eadbbc8380aa72be1412e2abe5f8e4ca&redirect_uri=https://wiki.ubuntu.com/&response_type=token&scope=non-expiring
4) If you open this link in webbrowser-app and click on "Sign in with Google", nothing happens
5) If you open the link in Firefox on the desktop, the Google authentication page is opened inside a popup window

My understanding is that the Google authentication completes successfully, but since Google assumes that the authentication happened in a popup window, after the authentication is completed Google tells the browser to close the popup window in order to return control to soundcloud; however, since we didn't open Google inside a popup window, this operation closes the main webview.

Chris Coulson (chrisccoulson) wrote :

Web content should not be able to close the main webview. Are you sure that's happening? window.close() is only allowed on script opened views.

Chris Coulson (chrisccoulson) wrote :

.... unless you've changed WebPreferences::allowScriptsToCloseWindows

David Barth (dbarth) wrote :

The OA webview could add support for popups, or rather webiew overlays, similar to those introduced in webapp-container.

Alberto Mardegan (mardy) wrote :

After some hacking on the Online Accounts webview, I've come to believe that this is probably a bug in oxide: our navigationRequestedDelegate() handler gets a request with disposition set to DispositionCurrentTab.

I'm adding Oxide to the bug report, for investigation.

Alberto Mardegan (mardy) on 2016-03-29
no longer affects: oxide-qt (Ubuntu)
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → High
status: Confirmed → In Progress
David Barth (dbarth) on 2016-03-29
Changed in webapps-sprint:
milestone: none → sprint-20
assignee: nobody → Alberto Mardegan (mardy)
status: New → Confirmed
status: Confirmed → In Progress
importance: Undecided → High
David Barth (dbarth) on 2016-04-26
Changed in webapps-sprint:
milestone: sprint-20 → sprint-21
milestone: sprint-21 → sprint-22
David Barth (dbarth) on 2016-05-24
Changed in webapps-sprint:
status: In Progress → Fix Committed
Changed in unity-scopes-shell (Ubuntu):
status: Confirmed → Invalid
Changed in unity-scope-soundcloud:
status: New → Invalid
Changed in canonical-devices-system-image:
milestone: none → 12
importance: Undecided → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings-online-accounts - 0.7+16.10.20160610-0ubuntu1

---------------
ubuntu-system-settings-online-accounts (0.7+16.10.20160610-0ubuntu1) yakkety; urgency=medium

  [ Alberto Mardegan ]
  * Immediately accept degenerate requests from unconfined processes
    (LP: #1582824)
  * Replace incorrect usage of UbuntuColors (LP: #1581047)
  * Update pot file for translations (LP: #1533091)
  * Open popups in an overlaid webview (LP: #1428591)
  * Skip tests on arm64 (LP: #1585942)

  [ Alberto Mardegan, Timo Jyrinki ]
  * Stop depending on transitional packages. (LP: #1583079)

 -- Alberto Mardegan <email address hidden> Fri, 10 Jun 2016 09:46:37 +0000

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Alberto Mardegan (mardy) on 2016-07-28
Changed in webapps-sprint:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers