scope-runner-dbus.py crashed with signal 5 in g_variant_new_va()

Bug #1274669 reported by Bruce Pieterse on 2014-01-30
168
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Unity Calculator Scope
Undecided
Unassigned
Unity Devhelp Scope
Undecided
Unassigned
Unity Manpages Scope
High
David Callé
Unity Texdoc Scope
Undecided
Unassigned
libunity
Confirmed
High
Unassigned
libunity (Ubuntu)
High
Unassigned
unity-scope-calculator (Ubuntu)
Undecided
Unassigned
unity-scope-devhelp (Ubuntu)
Undecided
Unassigned
unity-scope-manpages (Ubuntu)
Undecided
Unassigned
unity-scope-texdoc (Ubuntu)
Undecided
Unassigned

Bug Description

Typed "disks" in the dash and the crash occured shortly after opening disks.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: unity-scopes-runner 7.1.3+14.04.20131106-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-14.21-generic 3.11.7
Uname: Linux 3.11.0-14-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Jan 30 21:20:26 2014
Dependencies:

ExecutablePath: /usr/share/unity-scopes/scope-runner-dbus.py
InstallationDate: Installed on 2013-08-30 (153 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
InterpreterPath: /usr/bin/python3.3
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/share/unity-scopes/scope-runner-dbus.py -s code/manpages.scope
Signal: 5
SourcePackage: libunity
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_variant_new_va () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_variant_builder_add () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: scope-runner-dbus.py crashed with signal 5 in g_variant_new_va()
UpgradeStatus: Upgraded to trusty on 2014-01-30 (0 days ago)
UserGroups: adm cdrom dip lp lpadmin plugdev sambashare sudo vboxusers www-data

Related branches

Bruce Pieterse (octoquad) wrote :

StacktraceTop:
 g_variant_valist_new_nnp (str=0x7ffdef7fc498, ptr=0x0) at /build/buildd/glib2.0-2.39.3/./glib/gvariant.c:4245
 g_variant_valist_new_leaf (app=0x7ffdef7fc4c8, str=0x7ffdef7fc498) at /build/buildd/glib2.0-2.39.3/./glib/gvariant.c:4387
 g_variant_valist_new (str=str@entry=0x7ffdef7fc498, app=app@entry=0x7ffdef7fc4c8) at /build/buildd/glib2.0-2.39.3/./glib/gvariant.c:4569
 g_variant_valist_new (str=str@entry=0x7ffdef7fc498, app=app@entry=0x7ffdef7fc4c8) at /build/buildd/glib2.0-2.39.3/./glib/gvariant.c:4621
 g_variant_new_va (format_string=0x7ffe08b20f09 "*}", endptr=0x0, app=0x7ffdef7fc4c8) at /build/buildd/glib2.0-2.39.3/./glib/gvariant.c:4778

Changed in libunity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity (Ubuntu):
status: New → Confirmed
information type: Private → Public
vijayakrishna (krishna2642) wrote :

I get this bug when I type any thing into Dash. For example, I click on dash and type "syst" to open system settings and I immediately get this bug.

z3z (z3z) wrote :

I clicked on the Dash launcher button and started to type "Chro" for Chromium, and this error came up.

I know I've seen it before, but I need to test further, but I think the error appears the first time you use the Dash after logging in. Once it's appeared the first time, it seems to go away until you reboot again.

David Callé (davidc3) on 2014-03-20
Changed in unity-scope-manpages:
assignee: nobody → David Callé (davidc3)
importance: Undecided → High
status: New → Confirmed
Changed in libunity (Ubuntu):
importance: Medium → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-manpages - 3.0+14.04.20140324-0ubuntu1

---------------
unity-scope-manpages (3.0+14.04.20140324-0ubuntu1) trusty; urgency=low

  [ David Callé ]
  * Remove references to provider credits. Build results properly. Add
    "man" keyword (LP: #1274669)
 -- Ubuntu daily release <email address hidden> Mon, 24 Mar 2014 16:51:01 +0000

Changed in unity-scope-manpages (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-calculator - 0.1+14.04.20140328-0ubuntu1

---------------
unity-scope-calculator (0.1+14.04.20140328-0ubuntu1) trusty; urgency=low

  [ David Callé ]
  * Don't crash Unity bindings when building results. (LP: #1274669)
 -- Ubuntu daily release <email address hidden> Fri, 28 Mar 2014 09:18:45 +0000

Changed in unity-scope-calculator (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-devhelp - 0.1+14.04.20140328-0ubuntu1

---------------
unity-scope-devhelp (0.1+14.04.20140328-0ubuntu1) trusty; urgency=low

  [ David Callé ]
  * Don't crash Unity bindings when building results. (LP: #1274669)
 -- Ubuntu daily release <email address hidden> Fri, 28 Mar 2014 09:16:27 +0000

Changed in unity-scope-devhelp (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-texdoc - 0.1+14.04.20140328-0ubuntu1

---------------
unity-scope-texdoc (0.1+14.04.20140328-0ubuntu1) trusty; urgency=low

  [ David Callé ]
  * Don't crash Unity bindings when building results. (LP: #1274669)

  [ Mark Tully ]
  * Fix copyright attributions. (LP: #1260105)
 -- Ubuntu daily release <email address hidden> Fri, 28 Mar 2014 09:13:54 +0000

Changed in unity-scope-texdoc (Ubuntu):
status: New → Fix Released
Changed in libunity:
importance: Undecided → High
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers