HELP! It doesn't work!!

Reported by Alessio Linares on 2011-10-02

This bug report was converted into a question: question #173022: HELP! It doesn't work!!.

16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Google Documents Lens
Undecided
Alberto Mardegan

Bug Description

I found this cool lens today here: http://www.webupd8.org/2011/09/unity-google-docs-lens-for-ubuntu-1110.html. I followed the tutorial and when I execute the unity-lens-gdocs.py it returns this:
"(process:18468): libunity-DEBUG: unity-scope-factory.vala:57: Searching for Scopes in /usr/share/unity/lenses/gdocs
Search changed to: 'None'
Searching for: /feeds/default/private/full?showfolders=true
Violación de segmento (`core' generado)"
Last line says "Segmentation Violation (`core' generated)"
And then the lens appears but there's nothing in it.

This is how it looks

Changed in unity-lens-gdocs:
status: New → Invalid
summary: - It doesn't work!!
+ HELP! It doesn't work!!
Changed in unity-lens-gdocs:
status: Invalid → Confirmed
Markus Birth (mbirth) wrote :

Same here. Output is:

(process:28588): libunity-DEBUG: unity-scope-factory.vala:57: Searching for Scopes in /usr/share/unity/lenses/gdocs
Search changed to: 'None'
Searching for: /feeds/default/private/full?showfolders=true
[1] 28588 segmentation fault (core dumped) unity-lens-gdocs.py

This is on oneiric as of today.

I'm using Google's 2-factor-authentication and set an application-specific password for this lens.

Peter Goeree (poppo1974) wrote :

Ditto on Oneiric with "normal" Google authentication. Output:

(process:2838): libunity-DEBUG: unity-scope-factory.vala:57: Searching for Scopes in /usr/share/unity/lenses/gdocs
Search changed to: 'None'
Searching for: /feeds/default/private/full?showfolders=true
Segmentatiefout

Sagar Chalise (chalisesagar) wrote :

(process:4881): libunity-DEBUG: unity-scope-factory.vala:57: Searching for Scopes in /usr/share/unity/lenses/gdocs
Search changed to: 'None'
Searching for: /feeds/default/private/full?showfolders=true
Segmentation fault

Same for me doesnot work.

ullgren (ullgren) wrote :

On a freshly installed 11.10 I get the same Segmentation fault.
I installed using the deb package from nilarimogard's webupd8 PPA.
So I have all deps from there.

Some print-debugging showed that it is the call to model.append(..) that generates the segmentaion fault.
To me this indicated that the real issue is not in "unity-lens-gdocs" but somewhere in gir/libdee/libunity.
Perhaps some missing packages ?

My python skills are poor, and my gir skills non existent, but if you can give me some pointers I'm willing to help debug this issue.

It suddenly worked for me... I did nothing!
I just tried it and it is working fine =)

ullgren (ullgren) wrote :

Strange I still get the same segmentation fault.
I'm on the latest updated Ubuntu 11.10.

Did you install any packages or any updates ?
Are you on a 64- or 32bits architecture ?

I have installed all the updates the update manager told me to install (Ubuntu 11.10). I am on a 64bits architecture. I also changed the gmail account password, for other reasons. And it eventually worked.

Alin Andrei (nilarimogard) wrote :

This crash was caused by a bug in Unity (that caused most or all python lenses to stop working). It was fixed by the latest Unity available in the Ubuntu 11.10 Oneiric Ocelot proposed repositories so if you enable that repository, this lens should work again.

Tadeáš Pařík (pariktadeas) wrote :

I have the same problem:

(process:6191): libunity-DEBUG: unity-scope-factory.vala:57: Searching for Scopes in /usr/share/unity/lenses/gdocs
Search changed to: 'None'
Searching for: /feeds/default/private/full?showfolders=true

I am working on 11.10 32bits with all available updates.

I have the same problem on a 11.10 32bits:

(process:10035): libunity-DEBUG: unity-scope-factory.vala:57: Searching for Scopes in /usr/share/unity/lenses/gdocs
Search changed to: 'None'
Searching for: /feeds/default/private/full?showfolders=true
Unhandled icon type: application/x-zip
Unhandled icon type: image/jpeg
Unhandled icon type: application/msword

It don't return me control of the terminal so I cannot execute "setsid unity"

Alberto Mardegan (mardy) wrote :

This bug has been fixed in Quantal: the google document lens has been almost completely rewritten (now it's a scope for the Files lens).

Changed in unity-lens-gdocs:
assignee: nobody → Alberto Mardegan (mardy)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions