[notifications] Can't dismiss notification bubbles

Bug #1355422 reported by Alan Pope  on 2014-08-11
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Kevin Gunn
Ubuntu UX
High
James Mulholland
unity-notifications
Undecided
Unassigned
unity-notifications (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
High
Mirco Müller
unity8 (Ubuntu RTM)
Medium
Michał Sawicz

Bug Description

On a phone with accounts setup for twitter, facebook and 2x google accounts I get a fair number of notifications.
Often times these notifications appear while I'm actually using the phone.
This presents issues in multiple areas:-

* If I'm in the dash I am blocked from using the search function because a notification covers the search button
* If I'm in the dash and already searching, having typed something, I'm blocked from seeing what I'm typing by the notification
* In apps I can't go "back" because the notification blocks the button

You get the idea. Basically notifications slow me down, because I have to wait for them to disappear. I'd like to be able to dismiss them. On iOS you swipe up which is indicated with a horizontal bar to grab and swipe away.

-------------------------------------------------------

Desired solution

We've added in the latest specification for notifications bubbles (or clickable notifications) the ability to dismiss a notification via swiping left to right. Link to the spec: https://docs.google.com/a/canonical.com/document/d/1ehZGFePGmy8pnyAGsgWYDeBgr45Cc8jE2mTb2Qz-oeM/edit#

Related branches

lp:~macslow/unity8/swipe-dismiss-snap-decisions
Merged into lp:unity8 at revision 1599
Michał Sawicz: Approve (tests) on 2015-02-09
PS Jenkins bot: Approve (continuous-integration) on 2015-02-09
Albert Astals Cid: Approve on 2015-01-27
Michael Zanetti: Abstain on 2014-11-24
Antti Kaijanmäki: Needs Information on 2014-11-08
Alan Pope  (popey) on 2014-08-11
summary: - Can't dismiss notifications
+ Can't dismiss notification bubbles

An idea I've had is to have the notification area act slightly similarly to an app. For example if you have a busy gmail account and are trying to watch a movie you don't to be interrupted by it. The possible solution would be to be able to click on the app you had open and have it sticky to the foreground until the app is closed or swipe and then have the notifications continue to appear. If you swipe the app away to open another you can then tap the Scope (as it is an app) and then that gets foreground attention freezing up the notifications again.

Another possibly easier solution would be to add a cross or swipe action similar to Alan suggestion to just get rid of the notification.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ux:
assignee: nobody → Daniela Ferrai (dferrai)
importance: Undecided → High
summary: - Can't dismiss notification bubbles
+ [notifications] Can't dismiss notification bubbles
Daniela Ferrai (dferrai) on 2014-08-18
description: updated
Changed in ubuntu-ux:
status: New → Fix Committed
description: updated
Alan Pope  (popey) wrote :

Daniela, as this is a public bug could you please make that document publicly visible if there is no reason not to.

Mirco Müller (macslow) on 2014-09-08
Changed in unity8 (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → High
status: Confirmed → In Progress
Changed in ubuntu-ux:
assignee: Daniela Ferrai (dferrai) → James Mulholland (jamesjosephmulholland)
kevin gunn (kgunn72) on 2014-11-06
Changed in unity8 (Ubuntu RTM):
importance: Undecided → High
assignee: nobody → Mirco Müller (macslow)
tags: added: ota-1 rtm14
Mirco Müller (macslow) on 2014-11-07
Changed in unity8 (Ubuntu RTM):
status: New → In Progress
no longer affects: unity-notifications (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-notifications (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2015-02-02
Changed in unity8 (Ubuntu RTM):
status: In Progress → Triaged
status: Triaged → New
assignee: Mirco Müller (macslow) → nobody
importance: High → Undecided
tags: added: usability
Changed in canonical-devices-system-image:
importance: Undecided → Medium
milestone: none → ww09-2015
status: New → Confirmed
Michał Sawicz (saviq) on 2015-02-05
Changed in unity8 (Ubuntu RTM):
status: New → Triaged
importance: Undecided → Medium
milestone: none → 14.09-ota-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150211-0ubuntu1

---------------
unity8 (8.02+15.04.20150211-0ubuntu1) vivid; urgency=medium

  [ Michael Terry ]
  * Redesign tutorial to match latest spec (just removing obsolete pages
    and redesigning look, no new pages yet)
  * Add new right-edge and bottom-edge screens to the first-boot edge
    tutorial (LP: #1383297)
  * Support switching the indicator profile on the fly, as the greeter
    appears and disappears. (But don't use it yet, not until the
    settings panel to control this is in place.)
  * Clip the infographic to its bounding box, instead of letting it
    bleed past the welcome page (visible when dragging the welcome page
    to the side).

  [ Michael Zanetti ]
  * Add an AccountService based launcher model to be used with split
    greeter
  * Launcher fixes for windowed mode
  * save and restore window size and position
  * Fix resizing windows when making it smaller than minSize and then
    larger again.

  [ handsome_feng<email address hidden> ]
  * makes the header fully reveal when tapping the search icon. (LP:
    #1379327)

  [ Mirco Müller ]
  * Allow swipe-to-dismiss for contracted snap-decision notifications,
    interactive notifications and ephemeral notifications. (LP:
    #1355422, #1334855)

  [ Daniel d'Andrada ]
  * Make indicators bar eat all events
  * Improve Launcher tests, making them more reliable
  * Tapping on a surface gives it active focus
 -- Ubuntu daily release <email address hidden> Wed, 11 Feb 2015 17:13:16 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
assignee: nobody → Kevin Gunn (kgunn)
Michał Sawicz (saviq) on 2015-02-13
Changed in unity8 (Ubuntu RTM):
assignee: nobody → Michał Sawicz (saviq)
Michał Sawicz (saviq) on 2015-02-13
Changed in unity8 (Ubuntu RTM):
status: Triaged → In Progress
assignee: Michał Sawicz (saviq) → nobody
assignee: nobody → Michał Sawicz (saviq)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150217~rtm-0ubuntu1

---------------
unity8 (8.02+15.04.20150217~rtm-0ubuntu1) 14.09; urgency=medium

  [ Albert astals ]
  * Preserve the aspect ratio for the card attribute images

  [ Andrea Cimitan ]
  * support background on horizontal cards with summary (LP: #1393008)
  * Background needs to be specified to be visible in horizontal cards
  (LP: #1411748)

  [ Daniel d'Andrada ]
  * Don't show() the lockscreen if it's already being shown

  [ Joshua Arenson ]
  * Create a PhysicalKeyMapper to handle all physical/hardware keys

  [ Michał Sawicz ]
  * Create a PhysicalKeyMapper to handle all physical/hardware keys

  [ Mirco Müller ]
  * Allow swipe-to-dismiss for contracted snap-decision notifications,
    interactive notifications and ephemeral notifications. (LP:
    #1355422, #1334855)
 -- CI Train Bot <email address hidden> Tue, 17 Feb 2015 10:47:19 +0000

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
milestone: ww09-2015 → ww13-ota
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers