can't swipe away keyboard or use extended keys on top row

Bug #1343639 reported by Bill Filler on 2014-07-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-mir
Critical
Nick Dedekind
unity-mir (Ubuntu)
Undecided
Unassigned

Bug Description

build 136 is ok, but in build 137 you can no longer swipe the keyboard away. Also, if you press and hold a key on the top row of the keyboard, you can no longer press on the displayed key and have it enter the character in a text field.

Both of these things work in build 136.

I'm testing with the messaging-app with autocomplete, word prediction and spellchecking turned off (the default)

Related branches

kevin gunn (kgunn72) wrote :

just some irc chat from this afternoon

<Elleo> kgunn: looks like alf's patch has been reverted somehow: http://bazaar.launchpad.net/~mir-team/unity-mir/trunk/view/head:/src/modules/Unity/Application/inputarea.cpp#L183 <-- was changed to use relativeGeometry in alf's patch here: https://code.launchpad.net/~afrantzis/unity-mir/fix-1332624-input-area/+merge/224768

don't know why we would have reverted this?

Bill Filler (bfiller) wrote :

previous patch apparently has not been applied that fixes this issue:

<Elleo> kgunn: looks like alf's patch has been reverted somehow: http://bazaar.launchpad.net/~mir-team/unity-mir/trunk/view/head:/src/modules/Unity/Application/inputarea.cpp#L183 <-- was changed to use relativeGeometry in alf's patch here: https://code.launchpad.net/~afrantzis/unity-mir/fix-1332624-input-area/+merge/224768

Michał Sawicz (saviq) wrote :

Something really weird happened here...

The revision that this got changed in is http://bazaar.launchpad.net/~mir-team/unity-mir/trunk/revision/241#src/modules/Unity/Application/inputarea.cpp

But the MP that this got merged from does not show this change... https://code.launchpad.net/~nick-dedekind/unity-mir/unity-mir.trusted_sessions/+merge/208324

This calls for a review of that (and newer) revisions for unintentional changes.

Changed in unity-mir:
status: New → Triaged
Changed in unity-mir (Ubuntu):
status: New → Confirmed
Changed in unity-mir:
importance: Undecided → Critical
assignee: nobody → Nick Dedekind (nick-dedekind)
kevin gunn (kgunn72) on 2014-07-17
Changed in unity-mir:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-mir - 0.5+14.10.20140717.1-0ubuntu1

---------------
unity-mir (0.5+14.10.20140717.1-0ubuntu1) utopic; urgency=low

  [ Kevin Gunn ]
  * this is a fix for bug 1343639 (LP: #1343639)
 -- Ubuntu daily release <email address hidden> Thu, 17 Jul 2014 22:51:01 +0000

Changed in unity-mir (Ubuntu):
status: Confirmed → Fix Released
Michał Sawicz (saviq) on 2014-07-18
Changed in unity-mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers