After screen blanks unable to unblank on Qt 5.2

Bug #1258064 reported by Timo Jyrinki on 2013-12-05
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ricardo Salveti
Gerry Boland
qtbase-opensource-src (Ubuntu)
unity8 (Ubuntu)

Bug Description

Steps to reproduce on device (mako):

1. Upgrade. Instructions on upgrading should be always visible at page.

2. Let the device blank its screen, try to push power button to wake it up again. Nothing seems to happen, and nothing also crashes.

tags: added: qt5.2
kevin gunn (kgunn72) wrote :

think this might be more unity-mir than unity

Changed in unity8:
status: New → Opinion
Albert Astals Cid (aacid) wrote :

Isn't this happening on non Qt 5.2 too?

Bill Filler (bfiller) on 2014-01-21
Changed in unity-mir:
assignee: nobody → Gerry Boland (gerboland)
importance: Undecided → Critical
Timo Jyrinki (timo-jyrinki) wrote :

Yes, it seems so this still happens with Qt 5.2. Once I let the screen blank itself, I can't lit it again via powerbutton or powerd-cli display on bright. Processes look continuing running fine.

See current upgrade instuctions on device to Qt 5.2 at:

description: updated
Timo Jyrinki (timo-jyrinki) wrote :

Adding powerd to the bug. From Saviq 'it's really weird how Qt could influence that, when it's powerd alone that handles all of that stuff by calling ioctls directly'.

rsalveti, could you upgrade to Qt 5.2 and see what's happening over there when the screen blanks? You reportedly (maybe) took over powerd.

Changed in powerd:
assignee: nobody → Ricardo Salveti (rsalveti)
Bill Filler (bfiller) wrote :

note, stopping powerd by running "sudo stop powerd" will prevent the screen from blanking which is useful for testing

Leo Arias (elopio) wrote :

I couldn't reproduce this issue, on mako, freshly flashed and upgraded as instructed here:

Can somebody else try to reproduce it?

Timo Jyrinki (timo-jyrinki) wrote :

I believe this was awesomely fixed with Qt 5.2.1!

Changed in powerd:
status: New → Invalid
Changed in unity-mir:
status: New → Invalid
Changed in qtbase-opensource-src (Ubuntu):
status: New → Fix Released
Michał Sawicz (saviq) on 2017-03-13
affects: unity8 → unity8 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers