No message count

Bug #990689 reported by Lolwhites
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity Mail
Fix Released
Medium
Dmitry Shachnev
unity-mail (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

(See bug 1002802 for SRU request).

== Description ==
Users that have installed Unity Mail from the Software Center, do not see the count badge on the Launcher item. This can be fixed by removing UM from the Launcher and re-adding it from the Dash.

This is really a bug in Software Center (bug 996690).

== Development Fix ==
This has been fixed in r263 of lp:unity-mail branch.

== Stable Fix ==
This has been backported to r10 of lp:~mitya57/ubuntu/precise/unity-mail/trunk branch.

== Test Case ==
- Install unity-mail from the Ubuntu Software Center
- Make sure that the Software Center has added the launcher item
- Launch unity-mail
- It should display the count badge on the launcher item

== Regression Potential ==
This shouldn't cause any regressions.

== Original Description ==
Running in a clean install of 12.04. The mail count never shows in the launcher icon, and messages appear twice in the Me menu.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Thanks for reporing this!

Does it happen immediately after startup/login, or it dissapears some time after it?
Did you modify any configuration options?
Can you please paste here output of these commands (wait for a minute after running these, and press Ctrl+C to stop the process):
  pkill -f unity-mail
  unity-mail

In future, please report bugs using "ubuntu-bug unity-mail" command.

Changed in unity-mail:
status: New → Incomplete
importance: Undecided → High
Revision history for this message
Lolwhites (lolwhites) wrote :

It happens immediately. I didn't change any configuration options, just installed and added my contact details.

Here's the output:

unity-mail: Connection #0 established
unity-mail: Connection #1 established

At this point, I get a notification of 2 emails (actually, only one), and still no number in the launcher icon.

I don't know if this is important, but the issue doesn't arise in my laptop, which I upgraded rather than doing a fresh install.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

I've attached a script with some more debug output added, I hope it will help me to debug this.
Can you please run it and paste its output? (cd to your downloads directory and run "python3 ./unity-mail-tst.py").

Revision history for this message
Lolwhites (lolwhites) wrote :

Output here:

unity-mail: Connection #0 established
unity-mail: Connection #1 established
notinit is [False, False]
hide_count is True
setting count_visible property to 2
count_visible is now True

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

The script outputs that the count_visible is True, that's quite strange...
Can you please test the current UM version from trunk?

- go to http://bazaar.launchpad.net/~mitya57/unity-mail/unity-mail/view/head:/unity-mail
- download that file
- run "pkill -f unity-mail" to stop running instances
- cd to your downloads directory
- run the downloaded file using "python3 ./unity-mail"

Also, the script reports that you have option "Hide count when it's zero" enabled — is that true? Can you please attach your ~/.config/unity-mail.conf file?

Thanks in advance!

Revision history for this message
Lolwhites (lolwhites) wrote :

Running the new script has the same result.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

That configuration file reports that you actually changed two options. Can you please delete that file ("rm ~/.config/unity-mail.conf"), relogin and check if the issue still exists?

Also, do you use regular Unity or Unity 2D? Are you sure you have the latest unity-mail ("apt-cache policy unity-mail" should say 0.92.2)?

You also say that "messages appear twice". Does *every* message appear twice? Can you please provide a screenshot? (You can use "gnome-screenshot -i -d 10" to take a screenshot of messaging menu).

I really can't find anything this issue may be caused by…

Revision history for this message
Lolwhites (lolwhites) wrote :

The issue persists even after deleting the config file, and occurs in both Unity and Unity- 2D, but not on my laptop running 2D

Am running latest version.

Screenshot here: http://ubuntuone.com/0pvzTfNoVozuwRjL5Hspkv

Revision history for this message
Lolwhites (lolwhites) wrote :

I tried copying the config file across from my laptop but even that didn't solve the problem.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Can you please try to remove Unity Mail from the launcher, and then add it again (drag it from the Dash)? Will that help?

Concerning your second problem ("messages appear twice in the Me menu"): I've attached a test script for that.
Can you please ensure that you have some unread mails (non-private), run it (the usual way, as in comment #3) and paste here its output?

Thanks for helping me to resolve this bug!

Revision history for this message
Lolwhites (lolwhites) wrote :

Removing and adding Unity Mail from the launcher resolves the issue of the number not appearing, but messages are still counted twice.

Interestingly, when I woke up the PC from suspend, messages were only being counted once. On restarting Unity Mail, it was back to counting everything twice.

Here's the output from the script:

=========== update() called ===========
unity-mail: Connection #0 established
Connection 0 unread messages:
[22432, 22601, 22606, 22607, 22615]
Processing message 22432
  requested msg_indicator with title humour
Processing message 22601
  requested msg_indicator with title FLE teacher needed for private student in Saint-Cloud
Processing message 22606
  requested msg_indicator with title [enseignants_eco] Pindyk/Rubinfeld
Processing message 22607
  requested msg_indicator with title [enseignants_eco] Pindyk/Rubinfeld
Processing message 22615
  requested msg_indicator with title Rencontrez votre conseiller SFR dans votre FNAC favorite
unity-mail: Connection #1 established
Connection 1 unread messages:
[22432, 22601, 22606, 22607, 22615]
Processing message 22432
  requested msg_indicator with title humour
Processing message 22601
  requested msg_indicator with title FLE teacher needed for private student in Saint-Cloud
Processing message 22606
  requested msg_indicator with title [enseignants_eco] Pindyk/Rubinfeld
Processing message 22607
  requested msg_indicator with title [enseignants_eco] Pindyk/Rubinfeld
Processing message 22615
  requested msg_indicator with title Rencontrez votre conseiller SFR dans votre FNAC favorite
=========== update() called ===========
Connection 0 unread messages:
[22432, 22601, 22606, 22607, 22615]
Processing message 22432
Processing message 22601
Processing message 22606
Processing message 22607
Processing message 22615
Connection 1 unread messages:
[22432, 22601, 22606, 22607, 22615]
Processing message 22432
Processing message 22601
Processing message 22606
Processing message 22607
Processing message 22615

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

You have two identical accounts registered.
Please open to the accounts dialog, select the second account using the "+" key of the spinbox, and press Remove button, then apply the changes. This should resolve your issue.

Again about the first issue: it seems that you had the wrong desktop file attached to the panel. Was it automatically added by the Software Center or did you add it manually?

Changed in unity-mail:
importance: High → Medium
Revision history for this message
Lolwhites (lolwhites) wrote :

Thanks, removing the duplicate account resolved the second issue.

Regarding the first, I think it was added by the Software Centre rather than manually. On booting up this morning, the count didn't show again, so I removed the icon and added it again. The count now shows, even after rebooting.

Revision history for this message
Dmitry Shachnev (mitya57) wrote :

Removing incomplete status; I'll look at it later.

Changed in unity-mail:
status: Incomplete → Triaged
assignee: nobody → Dmitry Shachnev (mitya57)
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

This is a bug in the Software Center (it adds the wrong desktop file to the Launcher, I've reported it as bug 996690), however I've added a work-around to Unity Mail that should solve the issue for users that've already the wrong desktop file added. I will include this fix in the first SRU for Precise.

Changed in unity-mail:
status: Triaged → Fix Committed
description: updated
description: updated
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-mail (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-mail - 0.92.3

---------------
unity-mail (0.92.3) quantal; urgency=low

  * New bugfix release (LP: #1002802)
    - Use #!/usr/bin/python3 instead of #!/usr/bin/env python3
    - Do not use "<int> or <bool>" construction when updating the
      launcher item status
    - Use any desktop file that contains "unity-mail" in the name
      (work-around for SC issue; LP: #990689)
  * debian/control:
    - Rewrite the long description, now it is more clear and displays
      correctly in the Software Center (LP: #1004433)
    - Set priority to optional instead of extra
  * debian/clean: Remove, not needed
  * Update translations for desktop files
 -- Dmitry Shachnev <email address hidden> Fri, 25 May 2012 15:07:39 +0400

Changed in unity-mail (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-mail:
status: Fix Committed → Fix Released
Revision history for this message
Clint Byrum (clint-fewbar) wrote : Please test proposed package

Hello Lolwhites, or anyone else affected,

Accepted unity-mail into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-mail (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

@Lolwhites (or anybody else):
Can you please remove unity-mail, then re-install it from precise-proposed (or from https://launchpad.net/ubuntu/+archive/primary/+files/unity-mail_0.92.3~12.04_all.deb), and confirm that this bug is fixed for you?

Thanks!

Revision history for this message
Lolwhites (lolwhites) wrote :

Seems to be working fine now. Will keep you posted if there are any more problems.

Thanks!

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-mail - 0.92.3~12.04

---------------
unity-mail (0.92.3~12.04) precise-proposed; urgency=low

  * New bugfix release (LP: #1002802)
    - Use #!/usr/bin/python3 instead of #!/usr/bin/env python3
    - Do not use "<int> or <bool>" construction when updating the
      launcher item status
    - Use any desktop file that contains "unity-mail" in the name
      (work-around for SC issue; LP: #990689)
  * debian/control:
    - Rewrite the long description, now it is more clear and displays
      correctly in the Software Center (LP: #1004433)
    - Set priority to optional instead of extra
  * debian/clean: Remove, not needed
  * Update translations for desktop files
 -- Dmitry Shachnev <email address hidden> Fri, 25 May 2012 15:07:39 +0400

Changed in unity-mail (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers