Unity Mail does not display e-mail notifications

Bug #1711442 reported by Alexandre Huff on 2017-08-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity Mail
Undecided
Robert Tari

Bug Description

Hi,

I am using Unity Mail version 1.7.6 on Ubuntu 16.04.3.

This very useful application does not display e-mail notifications in my system anymore.

To try detect this problem I ran it in the gnome-terminal to see messages from the log.
I used the command ($unity-mail) in the terminal and the notifications appeared.
When Unity Mail is launched from the Unity Dash the messages don't appear.

So, I open the unity-mail.desktop file in the /usr/share/applications/ directory and I change the line at the [Desktop Entry] section from:

-> Exec=unity-mail-url Home
to:
-> Exec=unity-mail

Now, the application works fine!!!

I don't know if this can be considered as a bug, but this little trick solved the problem.

Thanks.

Robert Tari (robert-tari) wrote :

I cannot confirm this at this point, since it works for me as expected.

This is also a bit strange, since "unity-mail-url Home" is the default action for the Unity Mail icon. If the application is running, it will do what you tell it to do in settings - otherwise, it will call "unity-mail" for you.

It seems to me that in your case "unity-mail-url Home" does not start the application. Could you please try the following from the terminal (make sure you have at least one unread message in your inbox):

1. killall unity-mail
2. unity-mail-url Home

The second command should start Unity Mail and exit immediately, but leave the application running, so there should be no output, just a clean command prompt.

Changed in unity-mail:
assignee: nobody → Robert Tari (robert-tari)
status: New → Incomplete
Robert Tari (robert-tari) wrote :

Another thing has just occurred to me: /usr/share/applications/unity-mail.desktop is not normally meant to start the application (perhaps only for the first time immediately after installation). It merely holds the desktop entries for the Messaging Menu and the Launcher/Dock.

What really starts Unity Mail is /etc/xdg/autostart/unity-mail-autostart.desktop. This one calls "unity-mail" directly when you log in.

There is another thing you could also try:

1. Change your /usr/share/applications/unity-mail.desktop back to "unity-mail-url Home"
2. Open "Startup Applications", and make sure you have the "Unity Mail (service)" entry and it is active
3. Restart the computer

Unity Mail should now be running, you can check it with "pgrep -x unity-mail". If it is running, you'll get a number, otherwise nothing.

Alexandre Huff (alexandrehuff) wrote :

Hi,

1. I changed /usr/share/applications/unity-mail.desktop back to "unity-mail-url Home".
2. The "Unity Mail (service)" entry is active in "Startup Applications".

When the computer is restarted "Unity Mail" works fine (it shows notifications). But, when "Unity Mail" is launched from Dash (e.g. first run after installation) it doesn't show notifications.

For example, I ran these commands:
1. killall unity-mail
2. unity-mail-url Home
After the second command Unity Mail does not shows notifications.

And,
1. killall unity-mail
2. unity-mail &
Now after second command (like in "Startup Applications") the notifications appeared.

I believe now (after your reply) that this can't be a bug, but only a mistake I did because I thought the Unity Mail launched from Dash was the same as the "Unity Mail (service)" in "Startup Applications".

Thanks for the reply.

Robert Tari (robert-tari) wrote :

I am glad we solved the mystery, I will now have to mark the report as invalid to make it go away :)
If you have any questions in the future, just ask.

Changed in unity-mail:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers