GMail Blocks Unity Mail

Bug #1391646 reported by Sascha on 2014-11-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity Mail
Undecided
Unassigned

Bug Description

IN the security settings for the gmail Account

https://www.google.com/settings/security?hl=de

There is an option " Access for less secure Applications" default is Disabled
I don't know why but Unity Mail notifications is considered as less secure and will not work as long as you dont enable this "unsafe" gmail feature.

The error message from unity is:
Unity-Mail: ERROR: Exception occured: b'[ALERT] Please log in via your web browser: http://support.google.com/mail/accounts/bin/answer.py?answer=78754 (Failure)'
Unity-Mail: CRITICAL: Invalid account data provided for connection #0; exiting

I think this is a bug, an unity mail should also check for mails with the option " Access for less secure Applications" disabled.

Sascha (sascha-kolb) on 2014-11-11
description: updated
Dmitry Shachnev (mitya57) wrote :

That is because Unity Mail uses plain SMTP authentification, not OAuth or two-factor.

Did you try to follow instructions at the page you linked? Like visiting http://www.google.com/accounts/DisplayUnlockCaptcha and trying again?

Changed in unity-mail:
status: New → Incomplete
Andrew Allen (allen832008) wrote :

I am having the same issue on Ubuntu 14.10, no matter the account settings on Gmail. It blocks me access every time.

Launchpad Janitor (janitor) wrote :

[Expired for Unity Mail because there has been no activity for 60 days.]

Changed in unity-mail:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers