CUPS recommends incorrect driver for Samsung ML-1670

Bug #1102001 reported by James Tait on 2013-01-20
This bug affects 5 people
Affects Status Importance Assigned to Milestone
splix (Ubuntu)
splix (Unity Linux)

Bug Description


1) From the Printers dialogue, select Add Printer.
2) Select "Samsung ML-1670" from the devices list (connected via USB)
3) Select "Select printer from database" and "Samsung (recommended)"
4) Select "ML-1660 (recommended)" from the Models, and "Samsung ML-1660, 2.0.0 [en] (recommended)" from Drivers
5) Click through and Apply
6) Print a test page

The test page isn't printed. Instead a plain text page is printed that says:

INTERNAL ERROR - Please use the proper driver.

     POSITION : 0x0 (0)
     SYSTEM : h6fw_5.49/xl_op
     LINE : 180
     VERSION : SPL 5.49 10-20-2010

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: cups 1.6.1-0ubuntu11.3
ProcVersionSignature: Ubuntu 3.5.0-22.33-generic
Uname: Linux 3.5.0-22-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu9
Architecture: amd64
CheckboxSubmission: dd3689fa6394f60ec14dbe98d0bab891
CheckboxSystem: b633b4f40868d491c2ae5b50030ce6f3
Date: Sun Jan 20 10:25:54 2013
EcryptfsInUse: Yes
InstallationDate: Installed on 2010-08-23 (880 days ago)
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
 Jan 20 09:59:31 sixtymilesmile kernel: [54885.307388] ata1.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
 Jan 20 09:59:31 sixtymilesmile kernel: [54885.308453] ata1.00: ACPI cmd f5/00:00:00:00:00:00 (SECURITY FREEZE LOCK) filtered out
 device for Phaser-6100: usb://Xerox/Phaser%206100?serial=REP167734.......
 device for Samsung-ML-1670-Series: usb://Samsung/ML-1670%20Series?serial=Z6GEBKFB502893V.
 device for Xerox-Phaser-6100: ipps://xerox/printers/raw
 device for Xerox-Xerox-Phaser-6100DN: dnssd://Xerox%20Phaser%206100DN%20(XRX0000f0ae4d08)._printer._tcp.local/
MachineType: Sony Corporation VPCF11J0E
MarkForUpload: True
Papersize: a4
 Samsung-ML-1670-Series: Samsung ML-1660, 2.0.0
 Xerox-Xerox-Phaser-6100DN: Xerox Phaser 6100, 2.0.0
 Phaser-6100: Xerox Phaser 6100 Foomatic/Postscript
 Xerox-Phaser-6100: Xerox Phaser 6100, 2.0.0
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-22-generic root=/dev/mapper/hostname-root ro acpi_sleep=nonvs splash quiet nomodeset xbmc=autostart,nodiskmount loglevel=0
SourcePackage: cups
UpgradeStatus: Upgraded to quantal on 2012-11-05 (75 days ago) 02/26/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0260Y6
dmi.board.asset.tag: N/A VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0260Y6:bd02/26/2010:svnSonyCorporation:pnVPCF11J0E:pvrC604LLNJ:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A: VPCF11J0E
dmi.product.version: C604LLNJ
dmi.sys.vendor: Sony Corporation

James Tait (jamestait) wrote :
James Tait (jamestait) wrote :
Norbert (asterix52) wrote :

You can use your printer with the printer-driver-splix package. It works with the CLP-310 driver! Setting must be monocrome instead of color and max. 600dpi.

Or the samsung drivers:

James Tait (jamestait) wrote :

This is great news! Unfortunately I'm now ~10,000km from the printer, so I can't test this myself.

Now, how do we go about fixing the recommendation?

Can you try if you are 0.000 km away from your printer if either the splix or foo2qpdl driver works for your printer, let us know.
To get it recommended it should get officially added to any of these projects, you can start by dropping them a message that it works for you.

Changed in cups (Ubuntu):
status: New → Incomplete

Ubuntu provides only support/recommendations for open source printer drivers like splix and foo2qpdl, proprietary/closed source printer drivers support you obviously need to obtain from your printer driver manufacturer in this case Samsung.

Paul Sokolovsky (pfalcon) wrote :

In Ubuntu 14.04, I had the same error page trying to use ML-1660 driver. As suggested, I used CLP-310 driver, and there were actually two of them, one marked "foomatic" and one not. I chose foomatic and indeed, it works (I set resolution to 600x600 as was suggested, didn't try 1200).

One difference I can see against Samsung drivers which I used on my previous install is that there're no toner saving settings.

Till Kamppeter (till-kamppeter) wrote :

Can someone try whether the ML-1670 also works when one ML-1630 driver?

affects: cups (Ubuntu) → splix (Ubuntu)
eggymatrix (eggymatrix) wrote :

have a samsung ML-1670 and no driver was available for it on kubuntu 15.04, tried the 1660 driver and it did not work.

after fast googling came here and tried the CLP-310 foomatic driver and it works like a charm :-)

Ricky Ray (ganghero) wrote :

Guys, any link to a driver that works? I found the CLP-310 driver in the official samsung page, but I couldn't get it to work.
Where do I find the foomatic driver?

I had been using my ML-1675 printer no problem until a few months ago on my two machines with Ubuntu 14.04 installed and right now, after perhaps a few updates, it has stopped working all together.
It only prints a page saying the driver is not the right one.

Sil (sil1) wrote :

@Paul Sokolovsky (pfalcon)

I just created an account to thank you.
My printer (ML-1670) works now. Even support from samsung was unhelpful.

Thank you very much!

leonidas (l-wallner) wrote :

FYI: For me the foomatic-driver for CLP310 works when printing something with gimp, but not with inkscape...
I haven't yet found a problem with the non-foomatic driver.

Kostadin Stoilov (kmstoilov) wrote :

This bug is still present on Ubuntu 16.04 and Samsung ML-1675. The workaround to use the foomatic driver for CLP310 works though.

Arun Peter (kurisinkal) wrote :

@Paul Sokolovsky (pfalcon)
Thank you
Thank you
Thank you
Thank you
Thank you
Thank you

Nitin Mirg (mirgnitin269) wrote :

For seven Days i banged my head to print from Samsung 1676p laser printer, i was about to switch to Windows but read this post, CLP 310 works absolutely fine so THANK YOU

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers