"On this Computer" does not follow symlinks

Reported by kroq-gar78 on 2012-02-17
68
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Unity Videos Lens
Medium
David Callé

Bug Description

I have a bunch of videos on my Windows partition, and I symlink to those videos in my Videos folder. With nothing typed in the search field, I'm assuming this shows all videos on my machine under the "On this Computer" section. With nothing typed, no videos from the symlink'd folder are shown in the "On this Computer" folder. I would assume that they would since those files are still in that folder (from an end-user perspective, at least), and because of those reasons I'm filing those bugs reports.

David Callé (davidc3) on 2012-02-18
Changed in unity-lens-videos:
status: New → Confirmed
assignee: nobody → David Callé (davidc3)
zarquon42 (zarquon42) wrote :

same here: I'm symlinking my personal folders containing large amount of data (Music, Video) to another partition (easier for reinstalling the system for example). The music however is found by the music lens, Video is not found by the video lens (both on the same partition)

David Callé (davidc3) wrote :

Hi,
I'm aware of the issue and looking for the best way to solve this.
Thank you for your patience, as I can't promise it will be fixed for 12.04.

Changed in unity-lens-videos:
importance: Undecided → Wishlist
kroq-gar78 (kroq-gar78) wrote :

Thanks David. Hope it'll come in an update if not in the intial release! Thanks for your work! It's pretty nice ;)

@zarquon42,

Just a correction I would lieke to make to your comment. Music Lens actually doesn't follow symlinks. It searches a database created by the music player (whether it be Rhythmbox, Banshee, Clementine, etc.), which IN TURN might follow symlinks, but the lens itself doesn't. What I think would be a better example and worth noting wouldbe the new (or old? not sure) Files Lens. It does follow symlinks.

David,
Maybe looking into the Files Lens would offer a clue on how to fix this bug.

Hope it helps! :)

Markus Gonaus (magonaus) wrote :

This is also true for mountet ext4 Filesystems.
As I run my system from ssd, I mount my data like this
sudo mount --bind /srv/markus/Videos /home/markus/Videos
unity-lens-video shows nothing. It refuses indexing.

I marked this bug as affecting me, although I'm not interested in following symlinks. I am however interested in having the lens show a public, shared video folder as well as my ~/Videos/ folder.

Derek,

In my opinion, the way to do that would be to create a symlink to the public video inside your personal Video folder.

Sincerely,
kroq-gar78

montini (montini) wrote :

The main part of my videos are always stored in "~/Downloads". Video lens should at least index and show results also from "Downloads" folder in "My Videos" section of the lens. It is a big lack of productivity as it is now.

David Callé (davidc3) on 2012-06-03
Changed in unity-lens-videos:
importance: Wishlist → Medium
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers