unity-scope-video-remote crashed with SIGSEGV in g_object_ref()

Bug #1133696 reported by Paul Greindl on 2013-02-26
This bug affects 248 people
Affects Status Importance Assigned to Milestone
Unity Videos Lens
High
Paweł Stołowski
unity-lens-video (Ubuntu)
High
Unassigned

Bug Description

Just got this crashreport without doing anything. I didn't use the video-lens nor had I used it before (this session).

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: unity-scope-video-remote 0.3.14daily13.02.26-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-7.15-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Tue Feb 26 23:32:36 2013
ExecutablePath: /usr/lib/x86_64-linux-gnu/unity-lens-video/unity-scope-video-remote
InstallationDate: Installed on 2013-01-21 (35 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130121)
MarkForUpload: True
ProcCmdline: /usr/lib/x86_64-linux-gnu/unity-lens-video/unity-scope-video-remote
SegvAnalysis:
 Segfault happened at: 0x7f047d063451 <g_object_ref+17>: cmpq $0x50,(%rax)
 PC (0x7f047d063451) ok
 source "$0x50" ok
 destination "(%rax)" (0x00000001) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: unity-lens-video
StacktraceTop:
 g_object_ref () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libsoup-2.4.so.1
 ?? () from /usr/lib/x86_64-linux-gnu/libsoup-2.4.so.1
 ?? () from /usr/lib/x86_64-linux-gnu/libsoup-2.4.so.1
Title: unity-scope-video-remote crashed with SIGSEGV in g_object_ref()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Paul Greindl (paul-greindl) wrote :
information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-video (Ubuntu):
status: New → Confirmed
Mark Kelley (mcellius) wrote :

I don't know what happened. I was using another computer on my desk, and looked over at this one and saw the error, so it occurred without my intervention.

gray (info-graydesigns) wrote :

I was also not doing anything connected to the video lens - I had just sent an email and happened to notice the crash icon in the launcher - I am not sure at which point the crash happened - I had left the machine to it's own devices while I went shopping. At no point did I actually go near the dash or any lens...

Stuart Bishop (stub) wrote :

I notice that the crash is in unity-scope-video-remote, which is concerning as online search results are disabled in System Settings.

SignedAdam (signedadam) wrote :

did nothing, and got the error, it came up with the error as i was having my dinner, away from the computer, lol

SignedAdam (signedadam) wrote :

right, it just did it again, its really annoying now!

tags: added: rls-r-incoming
Changed in unity-lens-video (Ubuntu):
importance: Undecided → High
omarly666 (omarly666) wrote :

also on 386 arcitecture

dustin mantei (dustinamantei) wrote :

this seems to happen to whatever version of ubuntu or linux mint/cinnamon that I use. Maybe its systemic of my laptop...after I run the apport stop script in term it runs fine with no other errors and my video continues to work as advertised. please fix this annoying problem

David Callé (davidc3) on 2013-02-28
Changed in unity-lens-video:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Pawel Stolowski (stolowski)
Lazaro Alejo (habanany) wrote :

At start up

Changed in unity-lens-video:
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity-lens-video at revision 108, scheduled for release in unity-lens-video, milestone 0.1

Changed in unity-lens-video:
status: In Progress → Fix Committed
lord42 (lvdlee) on 2013-03-03
Changed in unity-lens-video (Ubuntu):
assignee: nobody → lord42 (lvdlee)
Karma Dorje (taaroa) on 2013-03-04
Changed in unity-lens-video (Ubuntu):
assignee: lord42 (lvdlee) → nobody
Kov3n4nT (cove888) wrote :

Also happened to me. I was just navigating through folders and suddenly crash box popped up

Lacyc3 (lacyc3) wrote :

Hmm.. is that fix merged with upstream? Exactly this bug happend while my PC leaved alone.

Paweł Stołowski (stolowski) wrote :

This fix was just commited, but hasn't been released yet.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-video - 0.3.14daily13.03.04-0ubuntu1

---------------
unity-lens-video (0.3.14daily13.03.04-0ubuntu1) raring; urgency=low

  [ Pawel Stolowski ]
  * unity-scope-video-remote crashed with SIGSEGV in g_object_ref() (LP:
    #1133696)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 108
 -- Automatic PS uploader <email address hidden> Mon, 04 Mar 2013 04:01:16 +0000

Changed in unity-lens-video (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers