[UIFE] Previews: Unable to preview banshee songs in the dash

Bug #1054720 reported by Owais Lone on 2012-09-22
78
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Music Lens
Medium
Paweł Stołowski
unity-lens-music (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned
Raring
Medium
Unassigned

Bug Description

I removed Rhythmbox and installed Banshee. My music collection does show up in the music lens and it opens the albums in banshee but I'm not able to preview individual tracks inside dash. The play/pause icons toggle but the music doesn't play.

====== UIFE ====
Banshee preview was displayed before, but wasn't functional (no play/show in folder button, track playback via music-preview-player wasn't working). This change fixes that so that banshee preview looks/behaves just like existing rhythmbox preview.

This change is isolated and only activated if Banshee is installed.

= Translations are not affected =

= This does not defer from the other music previews so the existing documentation should work =

Related branches

Omer Akram (om26er) on 2012-09-23
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-lens-music:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Pawel Stolowski (stolowski)
Nick Dedekind (nick-dedekind) wrote :

Problem is in lens, not unity.

no longer affects: unity
Omer Akram (om26er) on 2012-09-25
no longer affects: unity (Ubuntu)
Changed in unity-lens-music (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Omer Akram (om26er) on 2012-09-25
Changed in unity-lens-music:
status: Confirmed → Triaged
Changed in unity-lens-music (Ubuntu):
status: Confirmed → Triaged
tags: added: amd64 apport-bug package-qa-testing quantal running-unity third-party-packages
summary: - Previews: Unable to preview music in dash after uninstalling rhythmbox
+ Previews: Unable to preview banshee songs in the dash
Changed in unity-lens-music:
status: Triaged → In Progress
summary: - Previews: Unable to preview banshee songs in the dash
+ [UIFE] Previews: Unable to preview banshee songs in the dash
description: updated
Changed in unity-lens-music:
status: In Progress → Fix Committed
Neil J. Patel (njpatel) on 2012-09-28
description: updated
description: updated
Dave Walker (davewalker) wrote :

Could a screenshot of before and after be attached please? I think that will help demonstrate the requested change.

Thanks.

Neil J. Patel (njpatel) wrote :

Hi Dave, this doesn't defer from the other Music previews (like: http://cloudfront.omgubuntu.co.uk/wp-content/uploads/2012/08/music-player-preview-in-unity.jpg), uses the same code just we had to write the smarts to send the right data from Banshee.

I dont' run Banshee but if it's still desirable to have a shot of an album that is in Banshee, I'll ask the devs to make one. Thanks.

Scott Kitterman (kitterman) wrote :

As discussed with popey on #ubuntu-release, this does not appear to be a critical bug that should be allowed to break U/I freeze post beta 2. Adding functionality that is merely missing and not broken for integration with a non-default application is the kind of polish that should land much earlier if it's going to land.

Changed in unity-lens-music (Ubuntu Quantal):
status: Triaged → Won't Fix
nuttzo33 (slucas1979) wrote :

I have the same problem with banshee installed and no rhythmbox, clicking on the song will make it play in banshee as expected but the play preview button doesn't work. Also the track length of the songs is messed up
 i have attached a screenshot.

With rhythmbox installed it works as expected and track times are correct.

Oier Mees (oier) wrote :

Just upgraded to 12.10 and I can confirm shaynes issue, I also only use Banshee and the preview doesn't work and the track length is also messed up.

Raymond Wells (rfw2nd) wrote :

I think it should be reviewed again, because it broke things on my desktop with both banshee and rhythmbox installed. It will confuse a user who has upgraded from 12.04 and expects things to just work. If it isn't going to be fixed, I think the music previews should just be disabled or made to show only the album art, track and artist name when Banshee is the default music player.

Jeremy Bicha (jbicha) wrote :

I don't think this actually changes the UI; it just allows Banshee to be used as the backend in addition to Rhythmbox. If so, this doesn't need a UIFe. Whether it needs a feature freeze exception is debatable.

I think the Release Team should reconsider, if their assumption that this was yet another UIFe.

Iain Lane (laney) wrote :

For the avoidance of doubt, I consider this fine to upload into Raring if it can be done before UIF (assuming it has not been already). I'm unsubscribing the release team now.

Changed in unity-lens-music (Ubuntu Raring):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers