[regression] Music Lens is empty after login, requires a few attempts for it to show anything

Bug #1049075 reported by Omer Akram on 2012-09-11
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Music Lens
High
Paweł Stołowski
unity-lens-music (Ubuntu)
High
Paweł Stołowski
Quantal
High
Paweł Stołowski

Bug Description

unity-lens-music 6.6.0+bzr100ubuntu0+92

I have a few songs added to rhythmbox. When I login music lens is empty, I search for a song it show nothing. I close the dash and open it again, no results. After 4th or 5th attempt however it would work. (in some cases more attempts are required)

Related branches

Omer Akram (om26er) on 2012-09-11
Changed in unity-lens-music:
assignee: nobody → Pawel Stolowski (stolowski)
summary: - Music Lens is empty after login, requires a few attempts for it to show
- anything
+ [regression] Music Lens is empty after login, requires a few attempts
+ for it to show anything
Changed in unity-lens-music (Ubuntu Quantal):
importance: Undecided → High
status: New → Triaged
milestone: none → ubuntu-12.10-beta-2
assignee: nobody → Pawel Stolowski (stolowski)
Omer Akram (om26er) wrote :

this happens if there are radio stations in rhythmbox, more like if you click on the 'radios' item in the sidebar after starting rhythmbox. Then the issue will happen everytime music lens is started. If i remove the rhythmdb.xml then the issue does not happen, since removing that also removes all the default radio stations #profit

Changed in unity-lens-music:
importance: Critical → High
Neil J. Patel (njpatel) on 2012-09-18
Changed in unity-lens-music (Ubuntu Quantal):
milestone: ubuntu-12.10-beta-2 → ubuntu-12.10
Paweł Stołowski (stolowski) wrote :

Finally reproduced it. Will investigate it.

Changed in unity-lens-music:
status: Triaged → In Progress
Paweł Stołowski (stolowski) wrote :

After saying I reproduced it in the above comment I realised it just takes a few extra seconds for songs to show up after unity / lens restart (a few seconds after spinner stops). And then I found out that if you block outgoing internet traffic (it's enough to block http or musicsearch.ubuntu.com with iptables), you get not results at all (even for local songs). So, perhaps connectivity issues affect entire unity-lens-music.

Changed in unity-lens-music:
status: In Progress → Fix Committed
Changed in unity-lens-music:
milestone: none → 6.10.0
Omer Akram (om26er) on 2012-09-27
Changed in unity-lens-music (Ubuntu Quantal):
status: Triaged → Fix Committed
Nice Testhouse (testhouse) wrote :

Week 40 - Same issue as reported in https://bugs.launchpad.net/unity-lens-music/+bug/1045920 observed on Ubuntu Chinese Edition 12.10 (Quantal Quetzal) Daily Build

Issue: - Music Lens does not auto-refresh.

Changed in unity-lens-music:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-music - 6.8.1-0ubuntu1

---------------
unity-lens-music (6.8.1-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Ignore iradio tag (radio stations) when parsing Rhythmbox database;
      check if track uri is a local file, this prevents unexpected network
      queries when radio stations are enabled back in the future
      (LP: #1049075)
    - Add conditional search activation to the remote scope (LP: #1054746)
  * Bump libunity-dev dependency
 -- Timo Jyrinki <email address hidden> Mon, 01 Oct 2012 16:10:51 +0300

Changed in unity-lens-music (Ubuntu Quantal):
status: Fix Committed → Fix Released
Nice Testhouse (testhouse) wrote :

Week 42 - Music lens auto-refresh works fine on Ubuntu 12.10 Quantal with ppa:unity-team/sru

It is showing the newly downloaded file after playing it in Rythmbox straightaway without any need for manual refresh.

Nice Testhouse (testhouse) wrote :

Week 46 - Music lens fails to auto-refresh on 12.04 Precise with ppa:unity-team/sru (Nvidia machine)

The music lens did not auto-refresh and the activity indicator on the search bar of music lens remained constant indicating that it was not trying to auto-refresh.

Nice Testhouse (testhouse) wrote :

Week 49 - Music lens fails to auto-refresh on Ubuntu 12.10 Quantal with ppa:unity-team/sru

The music lens did not auto-refresh and the activity indicator on the search bar of music lens remained constant indicating that it was not trying to auto-refresh.

Also old deleted music files were still showing in music lens, only after manual refresh the deleted files were taken off.

Nice Testhouse (testhouse) wrote :

Week 50 - Music lens fails to auto-refresh on 12.04 Precise with ppa:unity-team/sru (Intel, Radeon, Nvidia)

The music lens did not auto-refresh and the activity indicator on the search bar of music lens remained constant indicating that it was not trying to auto-refresh.

Paweł Stołowski (stolowski) wrote :

@testhouse I think the problem you described in the last 3 comments is a different issue than the original one reported with this bug. Could you please file a new bug for it? Thank you.

Nice Testhouse (testhouse) wrote :

@Pawel - We have reported a bug here https://bugs.launchpad.net/unity-lens-music/+bug/1045920 but this was marked as duplicate of the current bug, hence all further occurrences of the issue in 1045920 have been reported here. Please have a look and clarify. Thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers