Low quality of search results

Reported by Mikkel Kamstrup Erlandsen on 2012-07-06
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Music Lens
High
Mikkel Kamstrup Erlandsen
5.0
High
Unassigned
unity-lens-music (Ubuntu)
Undecided
Timo Jyrinki
Precise
Undecided
Timo Jyrinki

Bug Description

This bug is aiming for SRU as well, after it has went into quantal.

[Impact]

The quality of the search results is sadly not very high in the Music lens right now. Fx. typing "spears" gives exactly 1 result (!!!). Typing "britney spears" gives something more expected.

[Test case]

Testing for the bug:
 * Go to the music lens (hit super-m)
 * Search for "spears"
 * Observe 1 result called "Spear"
 * Search for "britney spears" and observe lots of results

Testing the fix:
 * Go to the music lens (hit super-m)
 * Search for "spears"
 * Observe lots of relevant results (>> 1 result :-))

[Regression Potential]

Getting more results perhaps resulting in getting worse first results, but in the case of this patch it seems unlikely.

Changed in unity-lens-music:
status: In Progress → Fix Committed
Changed in unity-lens-music:
milestone: none → 5.14.0
description: updated
Alan Pope ㋛ (popey) wrote :
Timo Jyrinki (timo-jyrinki) wrote :

Tested from https://launchpad.net/~timo-jyrinki/+archive/unity-lens-music-sru - seems to improve the search results indeed.

description: updated
description: updated
affects: ubuntu → unity-lens-music (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-lens-music (Ubuntu):
status: New → Confirmed
Changed in unity-lens-music (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Changed in unity-lens-music (Ubuntu Precise):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-music - 6.0.0-0ubuntu3

---------------
unity-lens-music (6.0.0-0ubuntu3) quantal; urgency=low

  * Cherry-pick a search result fix:
    - lp:~unity-team/unity-lens-music/improved-result-quality
      Fix u1 search results to not seem too random. Lowers mem churn in
      musicstore scope quite a bit. (LP: #1021656)
  * Restore tests/assertions.vapi that was missed from the release
 -- Timo Jyrinki <email address hidden> Thu, 12 Jul 2012 15:26:35 +0300

Changed in unity-lens-music (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-lens-music (Ubuntu Precise):
status: New → Confirmed

Hello Mikkel, or anyone else affected,

Accepted unity-lens-music into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity-lens-music/5.12.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity-lens-music (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

I can confirm that the update gives extra results as described

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-music - 5.12.0-0ubuntu2

---------------
unity-lens-music (5.12.0-0ubuntu2) precise-proposed; urgency=low

  * Add a backported patch to improve search results:
    - Backport from trunk: Fix u1 search results to not seem too random.
      Lowers mem churn in musicstore scope quite a bit.
      (LP: #1021656)
 -- Timo Jyrinki <email address hidden> Thu, 12 Jul 2012 10:31:52 +0300

Changed in unity-lens-music (Ubuntu Precise):
status: Fix Committed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Set up bug targets properly. This was released as a cherry-pick in precise, even though no new upstream release was made.

Changed in unity-lens-music:
milestone: 5.14.0 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers