lens process keep running after logout

Bug #1072508 reported by Lucas Capalbo Lavezzo on 2012-10-28
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Music Lens
High
Unassigned
The Ubuntu Power Consumption Project
Undecided
Unassigned
Unity
Invalid
High
Unassigned
gvfs
Fix Released
Medium
unity-lens-applications
High
Unassigned
unity-lens-files
High
Unassigned
gvfs (Ubuntu)
High
Unassigned
Quantal
High
Unassigned
unity-lens-applications (Ubuntu)
High
Unassigned
Quantal
Undecided
Unassigned
unity-lens-files (Ubuntu)
High
Unassigned
Quantal
Undecided
Unassigned
unity-lens-music (Ubuntu)
High
Unassigned
Quantal
Undecided
Unassigned

Bug Description

* Impact:
Some process, like unity-{application,files,music}-daemon, keep running after user log out.

* Test Case:
1) login on Unity session
2) open the dash
3) check in system monitor: one instance per process -eg, 1 unity-application-daemon
4) logout
5) repeat steps 1-3. Now there's 2 proccess called unity-application-daemon

if you keep repeating the steps, the number of process increase.

* Regression potential:
the update which contains the fix has a few changes, check that gvfs keeps working file (try browsing different remote locations from nautilus, use the dash to search for online music and videos, ...)

------------

This also affects some other process, like 3rd party unity-lens-{torrents, wikipedia}. Scopes are not affected.
As a result, memory footprint after login in increases.
I'm running Ubuntu 12.10, up-to-date. Unity 6.8.0-0ubuntu2.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity 6.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu6
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Sun Oct 28 20:14:25 2012
InstallationDate: Installed on 2012-10-19 (9 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
summary: - lens process keep running after login out
+ lens process keep running after logout
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
status: New → Confirmed
Changed in ubuntu-power-consumption:
status: New → Confirmed
Changed in unity:
milestone: none → 7.0.0
Changed in unity-lens-music:
status: New → Confirmed
importance: Undecided → High
Changed in unity-lens-applications:
importance: Undecided → High
Changed in unity-lens-files:
importance: Undecided → High
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in unity-lens-files (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in unity-lens-music (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in unity-lens-files:
status: New → Confirmed
Changed in unity-lens-applications:
status: New → Confirmed
gutigen (gutigen) wrote :

Confirmed here, Ubuntu 12.10, Unity 6.10, kernel 3.5.0-21.

papukaija (papukaija) on 2013-01-10
tags: added: battery-power-consumption
Changed in unity-lens-files:
assignee: nobody → Pawel Stolowski (stolowski)
Changed in unity-lens-applications:
assignee: nobody → Pawel Stolowski (stolowski)
Changed in unity-lens-music:
assignee: nobody → Pawel Stolowski (stolowski)
Paweł Stołowski (stolowski) wrote :

The bug is caused by regression in gvfs, that changes the value of exit-on-close property of DBusConnection object to false. It only affects gvfs in Quantal. The version in Raring already has the new upstream version which corrects it.
See https://bugzilla.gnome.org/show_bug.cgi?id=687074

The only proper fix is to backport the fix for gvfs.

Changed in unity-lens-music:
assignee: Pawel Stolowski (stolowski) → nobody
Changed in unity-lens-applications:
assignee: Pawel Stolowski (stolowski) → nobody
Changed in unity-lens-files:
assignee: Pawel Stolowski (stolowski) → nobody
Changed in gvfs:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in gvfs (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Changed in gvfs (Ubuntu Quantal):
importance: Undecided → High
status: New → In Progress
description: updated

Hello Lucas, or anyone else affected,

Accepted gvfs into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gvfs/1.14.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gvfs (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Quantal):
status: New → Confirmed
Changed in unity-lens-applications (Ubuntu Quantal):
status: New → Confirmed
Changed in unity-lens-files (Ubuntu Quantal):
status: New → Confirmed
Changed in unity-lens-music (Ubuntu Quantal):
status: New → Confirmed
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Brian Murray (brian-murray) wrote :

There is a crash reported on errors.ubuntu.com that only occurs with the version of gvfs from quantal-proposed it can be found at:

https://errors.ubuntu.com/bucket/?id=/usr/lib/gvfs/gvfsd-network%3A11%3Arecompute_files%3Amount_smb_done_cb%3Ag_simple_async_result_complete%3Ag_daemon_file_mount_enclosing_volume%3Ag_simple_async_result_complete

Please investigate this to see if it is in fact a new crash and if not it is not remove the verification-failed tag.

tags: added: verification-failed
removed: verification-needed
Brian Murray (brian-murray) wrote :

The error from above actually looks a lot like:

https://errors.ubuntu.com/problem/dde12359537328c0f861f105245447d190e183bf

so I'm removing the verification-failed tag. However, this bug could still use verification in quantal.

tags: added: verification-needed
removed: verification-failed

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of gvfs from quantal-proposed was performed and bug 1197328 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1197328 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Stephen M. Webb (bregma) wrote :

Verified this bug no longer occurs in Unity 7

Changed in unity:
milestone: 7.0.1 → none
status: Confirmed → Invalid
Stephen M. Webb (bregma) wrote :

Verified this bug does not occur in Ubuntu 13.04 or later.

Changed in unity (Ubuntu):
status: Confirmed → Invalid
tags: removed: verification-failed
Changed in unity-lens-applications:
status: Confirmed → Invalid
Steve Langasek (vorlon) wrote :

This SRU has remained unverified after 231 days in the -proposed queue. I've removed it now from quantal-proposed and am marking the task 'wontfix'.

Changed in gvfs (Ubuntu Quantal):
status: Fix Committed → Won't Fix
Adolfo Jayme (fitojb) on 2014-05-04
no longer affects: unity (Ubuntu)
no longer affects: unity (Ubuntu Quantal)
Changed in unity-lens-applications (Ubuntu Quantal):
status: Confirmed → Won't Fix
Changed in unity-lens-files (Ubuntu Quantal):
status: Confirmed → Won't Fix
Changed in unity-lens-music (Ubuntu Quantal):
status: Confirmed → Won't Fix
tags: removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.