[UIFe] Add filesystem icons to unity-lens-files

Bug #1046774 reported by Andrea Azzarone on 2012-09-06
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-lens-files
Medium
Andrea Azzarone
unity-lens-files (Ubuntu)
Low
Andrea Azzarone

Bug Description

Add filesystem icons to unity-lens-files.

Justification:
Unity launcher changed the way it handles the file system/devices icons (see bug 713423): by default all file systems are displayed in the launcher.
You can blacklist them using a quick-list item.
By design you can un-blacklist a file system dragging and dropping the file system icon from dash to launcher. So right now there is no easy way to un-blacklist a file system.

Link to mailing list posts:
# Documentation: https://lists.ubuntu.com/archives/ubuntu-doc/2012-September/016808.html
# Translation: https://lists.ubuntu.com/archives/ubuntu-translators/2012-September/005557.html

Related branches

Andrea Azzarone (azzar1) on 2012-09-06
Changed in unity-lens-files:
assignee: nobody → Andrea Azzarone (andyrock)
importance: Undecided → Medium
status: New → In Progress
no longer affects: ubuntu
Andrea Azzarone (azzar1) on 2012-09-06
description: updated
Iain Lane (laney) wrote :

Fine from the release team, as long as you get +1s from the doc and translators for the UIFe.

Changed in unity-lens-files (Ubuntu):
status: New → Triaged
importance: Undecided → Low

Al 06/09/12 13:00, En/na Andrea Azzarone ha escrit:
> Hi,
>
> I'd like to add file-system icons to the "Folder" section of the
> unity-lens-files.
>
> Unity Launcher changed the way it handles the file-system icons (see
> bug 713423): by default all file-systems are displayed in the
> launcher.
> You can blacklist them using a quick-list item.
> By design you can un-blacklist a file-system dragging and dropping the
> file-system icon from dash to launcher.
> So right now there is no easy way to un-blacklist a file-system.
>
> Can we please make a ui freeze exception for this?
>
> UIFe bug report: https://bugs.launchpad.net/unity-lens-files/+bug/1046774
>

If it doesn't change any translatable strings, then no objections from
the translations team.

Cheers,
David.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Andrea Azzarone (azzar1) wrote :

2012/9/13 David Planella <email address hidden>:
> Al 06/09/12 13:00, En/na Andrea Azzarone ha escrit:
>> Hi,
>>
>> I'd like to add file-system icons to the "Folder" section of the
>> unity-lens-files.
>>
>> Unity Launcher changed the way it handles the file-system icons (see
>> bug 713423): by default all file-systems are displayed in the
>> launcher.
>> You can blacklist them using a quick-list item.
>> By design you can un-blacklist a file-system dragging and dropping the
>> file-system icon from dash to launcher.
>> So right now there is no easy way to un-blacklist a file-system.
>>
>> Can we please make a ui freeze exception for this?
>>
>> UIFe bug report: https://bugs.launchpad.net/unity-lens-files/+bug/1046774
>>
>

> If it doesn't change any translatable strings, then no objections from
> the translations team.
>

It adds other translatable strings

148 + preview.subtitle = _("Total capacity %s").printf
(GLib.format_size(total_capacity));
149 + preview.add_info (new InfoHint ("filesytem_type",
_("Filesystem type"), null, filesystem_type));
150 + preview.add_info (new InfoHint ("contents", _("Contents"),
null, _("%s, %u items").printf (GLib.format_size (contents_size),
contents_count)));
151 +
152 + var open_action = new Unity.PreviewAction ("open", _("Open"), null);

> Cheers,
> David.
>
> --
> David Planella
> Ubuntu Translations Coordinator
> www.ubuntu.com / www.davidplanella.wordpress.com
> www.identi.ca/dplanella / www.twitter.com/dplanella
>

--
Andrea Azzarone
http://launchpad.net/~andyrock
http://wiki.ubuntu.com/AndreaAzzarone

David Planella (dpm) wrote :

Al 13/09/12 16:23, En/na Andrea Azzarone ha escrit:
> 2012/9/13 David Planella <email address hidden>:
>> Al 06/09/12 13:00, En/na Andrea Azzarone ha escrit:
>>> Hi,
>>>
>>> I'd like to add file-system icons to the "Folder" section of the
>>> unity-lens-files.
>>>
>>> Unity Launcher changed the way it handles the file-system icons (see
>>> bug 713423): by default all file-systems are displayed in the
>>> launcher.
>>> You can blacklist them using a quick-list item.
>>> By design you can un-blacklist a file-system dragging and dropping the
>>> file-system icon from dash to launcher.
>>> So right now there is no easy way to un-blacklist a file-system.
>>>
>>> Can we please make a ui freeze exception for this?
>>>
>>> UIFe bug report: https://bugs.launchpad.net/unity-lens-files/+bug/1046774
>>>
>>
>
>> If it doesn't change any translatable strings, then no objections from
>> the translations team.
>>
>
> It adds other translatable strings
>
> 148 + preview.subtitle = _("Total capacity %s").printf
> (GLib.format_size(total_capacity));
> 149 + preview.add_info (new InfoHint ("filesytem_type",
> _("Filesystem type"), null, filesystem_type));
> 150 + preview.add_info (new InfoHint ("contents", _("Contents"),
> null, _("%s, %u items").printf (GLib.format_size (contents_size),
> contents_count)));
> 151 +
> 152 + var open_action = new Unity.PreviewAction ("open", _("Open"), null);
>

Ok, seeing that the strings are needed and are just a few and short,
then will still give +1.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Andrea Azzarone (azzar1) on 2012-09-18
Changed in unity-lens-files (Ubuntu):
status: Triaged → Fix Committed
Changed in unity-lens-files:
status: In Progress → Fix Committed
Changed in unity-lens-files (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity-lens-files (Ubuntu):
milestone: none → ubuntu-12.10-beta-2
Jeremy Bicha (jbicha) wrote :

+1 from the Docs Team since we already approved the UIFE for bug 713423.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-files - 6.6.0-0ubuntu1

---------------
unity-lens-files (6.6.0-0ubuntu1) quantal-proposed; urgency=low

  [ Timo Jyrinki ]
  * New upstream release.
    - Filter out dummy 'x-desktop-nautilus' entry in .gtk-bookmarks
      (LP: #1044309)
    - Set provide_personal_content flag (LP: #1049593)
    - Add filesystem icons in the "Folders" category of the files lens.
      (LP: #713423) (LP: #1046774)
    - Use uuid+label as volume IDs
    - Don't crash on startup if device label or uuid are null (LP: #1052691)

  [ Didier Roche ]
  * debian/control:
    - build-dep on latest libunity
 -- Didier Roche <email address hidden> Thu, 20 Sep 2012 16:23:12 +0200

Changed in unity-lens-files (Ubuntu):
status: Fix Committed → Fix Released
Andrea Azzarone (azzar1) on 2012-09-24
Changed in unity-lens-files:
status: Fix Committed → Fix Released
tags: added: uife
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers