Popularity sorting not working correctly

Bug #985495 reported by Michal Hruby on 2012-04-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
High
Michal Hruby
unity-lens-applications
High
Michal Hruby
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
unity-lens-applications (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned

Bug Description

Test case:
1. Start with a fresh system
2. Open the dash, type in Sound (or locale equivalent) and run the Sound preferences 4-5 times
3. Close the dash
4. Open the dash, type in Sound
   -> The "Sound" application should be the first one appearing

===

There are some cases where the popularity sorting is not working correctly - this seems to be connected to the way we do bins when applying the popularity sort.

As an example - searching for "sound" always puts "Sound Recorder" as the first result, even though "Sound" is used more frequently, same goes for "office", the order changes once you go from "offic" -> "office" and we don't want that.

(this is caused by "Sound recorder" having a relevancy of 100 and "Sound" just 99, therefore they get into different bins and popularity is not taken into account)

Michal Hruby (mhr3) on 2012-04-19
Changed in unity-lens-applications:
milestone: none → 5.12.0
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → High
status: New → In Progress
Changed in unity:
milestone: none → 5.12.0
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → High
status: New → In Progress
Michal Hruby (mhr3) on 2012-04-19
description: updated
Michal Hruby (mhr3) on 2012-04-19
Changed in unity:
status: In Progress → Fix Committed
Changed in unity-lens-applications:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-04-26
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
importance: Medium → High
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: Fix Committed → Fix Released

Hello Michal, or anyone else affected,

Accepted unity-lens-applications into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity-lens-applications (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 5.12.0-0ubuntu1

---------------
unity-lens-applications (5.12.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Popularity sorting not working correctly (LP: #985495)
    - run command (alt+F2): results do not contain the exact match
      (LP: #842108)
    - [11.0412.04 upgrade] Dash is always empty due to zeitgeist crash:
      Unable to upgrade from schema version 3 (LP: #986191)
 -- Didier Roche <email address hidden> Fri, 27 Apr 2012 11:18:48 +0200

Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-lens-applications (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers