Unity Applications Lens

unity-lens-applications doesn't search the "GenericName" field

Reported by kroq-gar78 on 2012-04-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity-lens-applications
Medium
Unassigned
unity-lens-applications (Ubuntu)
Medium
Unassigned

Bug Description

As an example, I will be using Lingo dictionary. In its .desktop file, it says its GenericName is "Dictionary". I type in "dictionary" into Unity (and Apps' lens) and Lingo does not come up. This can be confirmed with other programs, too (forgot which).

Changed in lingo-dictionary:
status: New → Confirmed
milestone: none → luna-beta1

There's a keywords field in desktop file specification (AFAIK it used to be a GNOME extension but then was mainlined), so it should be fixed either in keywords or in description (to conform http://elementaryos.org/docs/human-interface-guidelines/desktop-integration/app-launchers)

kroq-gar78 (kroq-gar78) wrote :

Okay, it looks like applications lens doesn't look for anything in GenericName. It only looks in the "Comment" field... should I report the bug to 'unity-lens-applications'?

Andrea Basso (voluntatefaber) wrote :

Marking as Invalid since this is a Unity error. http://standards.freedesktop.org/desktop-entry-spec/latest/ar01s05.html suggests not to use the Keyword entry to duplicate the Generic Name.

Changed in lingo-dictionary:
status: Confirmed → Invalid

Can I just set it to affecting 'unity-lens-applications' instead and just
change the information to fit, or should I just report a new bug (and mark
this as a duplicate?)?

Sincerely,
Kroq-gar78

On Sat, Apr 28, 2012 at 7:17 AM, Andrea Basso <email address hidden>wrote:

> Marking as Invalid since this is a Unity error.
> http://standards.freedesktop.org/desktop-entry-spec/latest/ar01s05.html
> suggests not to use the Keyword entry to duplicate the Generic Name.
>
> ** Changed in: lingo-dictionary
> Status: Confirmed => Invalid
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/975733
>
> Title:
> When "Dictionary" is searched in Unity, Lingo doesn't appear
>
> Status in Lingo Dictionary:
> Invalid
>
> Bug description:
> Lingo version: 0.8-0~r127+pkg5~precise1
>
> I know this is probably not that important (especially because this is
> elementary and not Ubuntu), but when I search for "Lingo" in the Unity
> Dash, I don't get Lingo as a result. I think this is because the
> correct words aren't in the .desktop file.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/lingo-dictionary/+bug/975733/+subscriptions
>

I'd suggest reporting another bug and making it more generic (maybe using Lingo only as an example), but I think reassigning it is fine all the same.

kroq-gar78 (kroq-gar78) wrote :

Ok I converted it to be a unity-lens-applications bug.

affects: lingo-dictionary → unity
Changed in unity:
milestone: luna-beta1 → none
affects: unity → unity-lens-applications
Changed in unity-lens-applications:
status: Invalid → Confirmed
summary: - When "Dictionary" is searched in Unity, Lingo doesn't appear
+ unity-lens-applications doesn't search the "GenericName" field
description: updated
kroq-gar78 (kroq-gar78) on 2012-10-07
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-10-15
Changed in unity-lens-applications:
importance: Undecided → Medium
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers