Dash - Currently the app lens doesn't show applications that are available for purchase

Bug #916121 reported by Dave Morley on 2012-01-13
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
Medium
Michal Hruby
unity-lens-applications
Medium
Michael Vogt
unity (Ubuntu)
Medium
Unassigned
unity-lens-applications (Ubuntu)
Medium
Unassigned

Bug Description

Steps to Reproduce:
1. Open dash
2. Click on Applications Lens
3. Type in world of goo
4. Type in volleybrawl
5. Type in 7zip

3 and 4 won't show up however 5 will. I'm assuming this is because it just searches the package repos

Desired solution:

- All available apps (including apps available to purchase) should be displayed under the "apps available to download" category header.

David Pitkin (dpitkin) wrote :

The database to search is ~/.cache/software-center/software-center-agent.db/

Changed in unity-lens-applications:
status: New → Confirmed
Changed in unity:
importance: Undecided → High
status: New → Incomplete
description: updated
John Lea (johnlea) on 2012-01-30
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
John Lea (johnlea) on 2012-01-30
description: updated
Changed in ayatana-design:
importance: Undecided → High
status: New → Triaged
Changed in unity:
status: Incomplete → Confirmed
tags: added: udp
Changed in unity:
milestone: none → backlog
Didier Roche (didrocks) on 2012-02-01
Changed in unity-lens-applications (Ubuntu):
status: New → Confirmed
Tim Penhey (thumper) on 2012-02-07
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
status: Confirmed → Triaged
Changed in unity-lens-applications:
importance: Undecided → High
Omer Akram (om26er) on 2012-02-13
Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity-lens-applications:
importance: High → Medium
Changed in unity-lens-applications (Ubuntu):
importance: Undecided → Medium
John Lea (johnlea) on 2012-02-16
summary: - Currently the lens doesn't show applications that are for purchase
+ Dash - Currently the app lens doesn't show applications that are
+ available for purchase
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
Michal Hruby (mhr3) on 2012-02-20
Changed in unity-lens-applications:
status: Confirmed → In Progress
milestone: none → 5.6.0
assignee: nobody → Michael Vogt (mvo)
Michal Hruby (mhr3) on 2012-02-20
Changed in unity-lens-applications:
status: In Progress → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
assignee: nobody → Michal Hruby (mhr3)
milestone: backlog → 5.6.0
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-02-21
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity-lens-applications (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-applications:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 5.6.0-0ubuntu1

---------------
unity-lens-applications (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Can't launch applications from the launcher (LP: #938505)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - non-existent icons are referenced: category-available and category-
      installed (LP: #932212)
 -- Didier Roche <email address hidden> Mon, 12 Mar 2012 11:52:14 +0100

Changed in unity-lens-applications (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package unity - 5.6.0-0ubuntu1

---------------
unity (5.6.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in g_type_check_instance_cast()
      (LP: #862972)
    - compiz crashed with SIGABRT in __gnu_cxx::__verbose_terminate_handler()
      (LP: #926793)
    - compiz crashed with SIGSEGV in gdk_pixbuf_get_width() (LP: #937421)
    - Unity causes ibus to not work correctly (spaces incorrectly placed)
      (LP: #880876)
    - Dash - update Dash keyboard shortcuts so the 'CTRL + TAB' switches
      between Lenses and 'TAB' by itself moves the focus between categories
      (LP: #891648)
    - HUD - closing a window with <Alt>+<F4> opens the hud (LP: #923410)
    - unity-applications-daemon crashed with SIGSEGV in
      dee_sequence_model_free_row() (LP: #916356)
    - Launcher, Window Management - Launcher reveal should not be triggered
      when dragging a window (LP: #928805)
    - lenses are loaded on start, should be lazy loaded (LP: #929506)
    - Trash icon jumps about when trying to drag an icon onto it (LP: #932365)
    - HUD loses keypresses for the first second after opening (LP: #932906)
    - HUD doesn't give the focus back to the active application after dash/hud
      use (LP: #934061)
    - Launcher - unpinned apps show with empty pips in the launcher as if they
      exist on another workspace (LP: #937898)
    - Unity Dash should support Keywords parameter in .desktop (formerly X
      -GNOME-Keywords or X-AppInstall-Keywords) (LP: #941231)
    - Support FD.o Desktop Actions spec (LP: #942042)
    - Unity hangs when touching my touchpad/trackpad (LP: #942625)
    - [regression] Pressing alt doesn't show the menu title bar in top panel
      (LP: #943194)
    - Alt + F (or other mnemonic) doesn't work in gnome-terminal (LP: #943239)
    - [unity 5.6] Using Alt+F1 or Alt+F2 sends a ";3P" or ";3Q" to the active
      windows (LP: #943456)
    - [unity 5.6] holding alt and pressing a direction opens the alt-tab list
      in a buggy way (LP: #943902)
    - [unity-5.6] can't enter accents (^o->) in the dash since recent updates
      (LP: #944674)
    - Dash - Keyboard navigation for search filters is broken (LP: #844033)
    - Dash - If mouse highlights one icon in grid, keyboard navigation
      highlights another, so there are 2 highlighted icons (LP: #817436)
    - Alt+Tab default delay of 150ms is too long (LP: #888636)
    - Keyboard shortcut - F10 shortcut is used to show menu and this is wrong
      (LP: #878492)
    - Dash - Currently the app lens doesn't show applications that are
      available for purchase (LP: #916121)
    - Chromium is running, but not showing in launcher or alt-tab.
      (LP: #918474)
    - Dash - Different states of rating stars, and dimensions (LP: #924884)
    - alt-tab confused by a multiple instances of an application on different
      workspaces (LP: #925484)
    - Launcher - Icons are not colorized properly (LP: #930949)
    - Remove glow from Alt-tab edge and Search Field image assets
      (LP: #933578)
    - "Left Mouse Drag" and "Middle Mouse Drag" should be translatable
      (LP: #930510)
    - Launcher switcher...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-03-13
tags: added: furtherdesignreviewrequiredp
Tim Penhey (thumper) on 2012-04-16
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-16
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2012-04-26
description: updated
tags: added: reviewedbydesignp
removed: furtherdesignreviewrequiredp top5p udp
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

Marking as fixed released, however one of the issues in the original bug report is outstanding so I have reported this in a new bug. See https://bugs.launchpad.net/unity/+bug/988785

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers