Support X-GNOME-Keywords

Bug #828356 reported by Michael Terry on 2011-08-17
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Mikkel Kamstrup Erlandsen
libunity
Fix Released
High
Mikkel Kamstrup Erlandsen
unity-lens-applications
High
Mikkel Kamstrup Erlandsen
libunity (Ubuntu)
High
Mikkel Kamstrup Erlandsen
Oneiric
High
Mikkel Kamstrup Erlandsen
Precise
High
Unassigned
unity (Ubuntu)
High
Mikkel Kamstrup Erlandsen
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
unity-lens-applications (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

X-GNOME-Keywords is a desktop field used in the gnome-control-center and probably gnome-shell (https://bugzilla.gnome.org/show_bug.cgi?id=609702) to specify search keywords for applications.

It would be nice if Unity used the same key.

Related branches

Mackenzie Morgan (maco.m) wrote :

If Unity used these keys, Universal Access, Orca, etc. would show up when users type in "accessibility". As it is, they show up through typing "access" but if they are typing fast enough not to spot this (or otherwise can't see it, given I'm referring to accessibility...) but as soon as the user goes for that next "i" in "accessibility" they all disappear.

Alan Bell (alanbell) wrote :

specifically it would mean that the following applications could be searched for in the dash using the corresponding keywords which have already been populated:

deja-dup-ccpanel.desktop:22:X-GNOME-Keywords=déjà;deja;dup;
deja-dup-preferences.desktop:21:X-GNOME-Keywords=déjà;deja;dup;
gnome-background-panel.desktop:13:X-GNOME-Keywords=Wallpaper;Screen;Desktop;Theme;
gnome-color-panel.desktop:17:X-GNOME-Keywords=Color;ICC;Profile;Calibrate;Printer;Display;
gnome-datetime-panel.desktop:13:X-GNOME-Keywords=Clock;Timezone;Location;
gnome-display-panel.desktop:17:X-GNOME-Keywords=Panel;Projector;xrandr;Screen;Resolution;Refresh;
gnome-info-panel.desktop:19:X-GNOME-Keywords=device;system;information;memory;processor;version;default;application;fallback;preferred;
gnome-keyboard-panel.desktop:17:X-GNOME-Keywords=Shortcut;Repeat;Blink;
gnome-media-panel.desktop:17:X-GNOME-Keywords=cd;dvd;usb;audio;video;disc;
gnome-mouse-panel.desktop:17:X-GNOME-Keywords=Trackpad;Pointer;Click;Tap;Double;Button;Trackball;
gnome-network-panel.desktop:17:X-GNOME-Keywords=Network;Wireless;IP;LAN;
gnome-online-accounts-panel.desktop:17:X-GNOME-Keywords=Google;Facebook;Twitter;Yahoo;Web;Online;Chat;Calendar;Mail;Contact;
gnome-power-panel.desktop:17:X-GNOME-Keywords=Power;Sleep;Suspend;Hibernate;Battery;
gnome-printers-panel.desktop:14:X-GNOME-Keywords=Printer;Queue;Print;Paper;Ink;Toner;
gnome-region-panel.desktop:17:X-GNOME-Keywords=Language;Layout;Keyboard;
gnome-screen-panel.desktop:17:X-GNOME-Keywords=Brightness;Lock;Dim;Blank;Monitor;
gnome-sound-panel.desktop:17:X-GNOME-Keywords=Card;Microphone;Volume;Fade;Balance;Bluetooth;Headset;
gnome-universal-access-panel.desktop:17:X-GNOME-Keywords=Keyboard;Mouse;a11y;Accessibility;Contrast;Zoom;Screen Reader;text;font;size;AccessX;Sticky Keys;Slow Keys;Bounce Keys;Mouse Keys
gnome-user-accounts-panel.desktop:17:X-GNOME-Keywords=Login;Name;Fingerprint;Avatar;Logo;Face;Password;
gnome-wacom-panel.desktop:17:X-GNOME-Keywords=Tablet;Wacom;Stylus;Eraser;Mouse;
gnomine.desktop:13:X-AppInstall-Keywords=minesweeper
language-selector.desktop:12:X-GNOME-Keywords=Language;Input method;Region;Format;
system-config-printer.desktop:15:X-GNOME-Keywords=Printer;Queue;Print;Paper;Ink;Toner;
transmission-gtk.desktop:70:X-AppInstall-Keywords=torrent

Changed in unity:
status: New → Confirmed
affects: unity → ubuntu
Changed in ubuntu:
status: Confirmed → New
affects: ubuntu → unity
Changed in ubuntu:
status: New → Confirmed
importance: Undecided → High
tags: added: rls-mgr-o-tracking
tags: added: a11y
removed: rls-mgr-o-tracking
tags: added: rls-mgr-o-tracking
affects: unity → unity-lens-applications
Changed in unity-lens-applications:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)

I guess we want X-AppInstall-Keywords as well, to match gnomine as 'minesweeper' etc

Changed in unity-lens-applications:
importance: Undecided → High
milestone: none → 0.4.10
status: New → In Progress
Changed in unity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → High
milestone: none → 4.20.0
status: New → In Progress
Changed in libunity:
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → High
milestone: none → 4.0.6
status: New → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in unity-lens-applications:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-27
affects: Ubuntu Oneiric → libunity (Ubuntu Oneiric)
Didier Roche (didrocks) on 2011-09-27
Changed in unity-lens-applications:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in libunity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 4.0.6-0ubuntu1

---------------
libunity (4.0.6-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - doesn't clear models when a scope dies (LP: #859760)
    - Support X-GNOME-Keywords (LP: #828356)
  * update debian/libunity6.symbols
 -- Didier Roche <email address hidden> Tue, 27 Sep 2011 15:41:33 +0200

Changed in libunity (Ubuntu Oneiric):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-applications - 0.4.10-0ubuntu1

---------------
unity-lens-applications (0.4.10-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Support X-GNOME-Keywords (LP: #828356)
    - Ratings filter in apps lens allows unrated apps through (LP: #860537)
  * debian/control:
    - build-dep on latest libunity
 -- Didier Roche <email address hidden> Tue, 27 Sep 2011 15:41:45 +0200

Changed in unity-lens-applications (Ubuntu Oneiric):
status: New → Fix Released
Michael Terry (mterry) wrote :

XDG has accepted a standard key "Keywords" now, which has the same syntax as X-GNOME-Keywords. So ideally that would be supported too. Should I open a new bug for that or can we re-use this one?

Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: libunity (Ubuntu Quantal)
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
Rodrigo (rodhos-hp) wrote :

Thank you for taking the time to report this bug. We have tried to recreate this on the latest release of Ubuntu, but cannot reproduce it. This bug is being marked as Invalid. If you believe the problem to still exist in the latest version of Ubuntu, please comment on why that is the case and change the bug status to NEW.

Changed in unity (Ubuntu):
status: New → Invalid
Changed in unity (Ubuntu):
status: Invalid → Fix Released
assignee: nobody → Mikkel Kamstrup Erlandsen (kamstrup)
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers